aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-03-13 03:03:13 +0800
committerknu <knu@FreeBSD.org>2001-03-13 03:03:13 +0800
commit4cb3093b241c6db8cc076acf72a2b369563f398d (patch)
treee37e4e7f525e1b8f90dcdd221fa78e626c21fffc /x11-toolkits
parent974161a11dd0a9e4903038a7a9b3619aac8d4e41 (diff)
downloadfreebsd-ports-gnome-4cb3093b241c6db8cc076acf72a2b369563f398d.tar.gz
freebsd-ports-gnome-4cb3093b241c6db8cc076acf72a2b369563f398d.tar.zst
freebsd-ports-gnome-4cb3093b241c6db8cc076acf72a2b369563f398d.zip
Add ruby-qt2iconview, Qt2 iconview extension for Ruby.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/ruby-qt2iconview/Makefile42
-rw-r--r--x11-toolkits/ruby-qt2iconview/pkg-comment1
-rw-r--r--x11-toolkits/ruby-qt2iconview/pkg-descr4
-rw-r--r--x11-toolkits/ruby-qt2iconview/pkg-plist4
5 files changed, 52 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index ad1b03d4b181..f66f277e66c0 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -85,6 +85,7 @@
SUBDIR += ruby-qt
SUBDIR += ruby-qt2
SUBDIR += ruby-qt2canvas
+ SUBDIR += ruby-qt2iconview
SUBDIR += ruby-qt2table
SUBDIR += ruby-tk
SUBDIR += ruby14-tk
diff --git a/x11-toolkits/ruby-qt2iconview/Makefile b/x11-toolkits/ruby-qt2iconview/Makefile
new file mode 100644
index 000000000000..854a6359fb43
--- /dev/null
+++ b/x11-toolkits/ruby-qt2iconview/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: Ruby-qt2iconview
+# Date created: 13 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt2iconview
+PORTVERSION= ${RUBY_QT2_PORTVERSION}
+CATEGORIES= x11-toolkits ruby
+MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_QT2_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+USE_GMAKE= yes
+
+.include "${.CURDIR}/../ruby-qt2/Makefile.common"
+
+WRKSRC= ${RUBY_QT2_WRKSRC}/modules/iconview
+CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
+ --with-qt2-lib=${X11BASE}/lib \
+ --with-qt2=qt2 \
+ --with-x11-dir=${X11BASE}
+MAKE_ARGS= LOCAL_LIBS=-lgcc
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/ruby-qt2iconview/pkg-comment b/x11-toolkits/ruby-qt2iconview/pkg-comment
new file mode 100644
index 000000000000..6533d98c2a05
--- /dev/null
+++ b/x11-toolkits/ruby-qt2iconview/pkg-comment
@@ -0,0 +1 @@
+Qt2 iconview extension for Ruby
diff --git a/x11-toolkits/ruby-qt2iconview/pkg-descr b/x11-toolkits/ruby-qt2iconview/pkg-descr
new file mode 100644
index 000000000000..ab70e88b79e0
--- /dev/null
+++ b/x11-toolkits/ruby-qt2iconview/pkg-descr
@@ -0,0 +1,4 @@
+This is a Qt2 iconview extension for Ruby.
+
+Author: Nobuyuki Horie <horie@smail.u-shizuoka-ken.ac.jp>
+WWW: http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/index.html
diff --git a/x11-toolkits/ruby-qt2iconview/pkg-plist b/x11-toolkits/ruby-qt2iconview/pkg-plist
new file mode 100644
index 000000000000..98f72e1dc3ec
--- /dev/null
+++ b/x11-toolkits/ruby-qt2iconview/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITEARCHLIBDIR%%/qt2iconview.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/qt2iconview/iconview/iconview.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2iconview/iconview
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/qt2iconview