aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 18:40:22 +0800
commit4f3e737e3339df65a7737d86948a5c8dacedae60 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /x11-toolkits
parent38d22f91997e71dd03618ec2d16c51e19e000cd9 (diff)
downloadfreebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.gz
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.tar.zst
freebsd-ports-gnome-4f3e737e3339df65a7737d86948a5c8dacedae60.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/libwnck/Makefile12
-rw-r--r--x11-toolkits/py-gtk2/Makefile24
2 files changed, 18 insertions, 18 deletions
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
index a0fb35fe56b1..989e75710e40 100644
--- a/x11-toolkits/libwnck/Makefile
+++ b/x11-toolkits/libwnck/Makefile
@@ -30,17 +30,19 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= STARTUP "Enable startup notification support" on
+OPTIONS_DEFINE= STARTUP
+OPTIONS_DEFAULT=STARTUP
+STARTUP_DESC= Startup notification support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_STARTUP)
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+.if ${PORT_OPTIONS:MSTARTUP}
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
.endif
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index e3c6a10d92cf..228c984d8b4f 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: py-gtk2
-# Date created: 08/13/2002
-# Whom: marc@informatik.uni-bremen.de
-#
+# Created by: marc@informatik.uni-bremen.de
# $FreeBSD$
# $MCom: ports/x11-toolkits/py-gtk2/Makefile,v 1.78 2011/04/01 12:35:27 kwm Exp $
-#
PORTNAME= gtk
PORTVERSION= 2.24.0
@@ -17,7 +13,7 @@ DISTNAME= pygtk-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A set of Python bindings for GTK+
+COMMENT= Set of Python bindings for GTK+
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo
@@ -25,7 +21,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cair
LATEST_LINK= py-gtk2
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack libglade2 pygobject
+USES= pathfix
+USE_GNOME= libglade2 pygobject
USE_PYTHON= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
@@ -41,11 +38,12 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-gtk
CONFLICTS= py*-gtk-0*
-OPTIONS= NUMPY "Enable numpy support (pulls in gcc44)" off
+OPTIONS_DEFINE= NUMPY
+NUMPY_DESC= Numpy support (pulls in gcc44)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_NUMPY)
+.if ${PORT_OPTIONS:MNUMPY}
BUILD_DEPENDS+= ${PYNUMPY}
RUN_DEPENDS+= ${PYNUMPY}
CONFIGURE_ARGS+=--enable-numpy
@@ -66,17 +64,17 @@ CONFIGURE_ARGS+= --disable-thread
.endif
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EXAMPLESDIR} -xf -
${CHOWN} -R ${BINOWN}:${BINGRP} ${EXAMPLESDIR}
${FIND} ${EXAMPLESDIR} -type d -print | ${XARGS} ${CHMOD} 0555
${FIND} ${EXAMPLESDIR} -type f -print | ${XARGS} ${CHMOD} 0444
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/MAPPING ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/THREADS ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>