aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-05-19 16:32:12 +0800
committergahr <gahr@FreeBSD.org>2011-05-19 16:32:12 +0800
commit6c3d088da4b3b5508f728e341725f698e05182c9 (patch)
treee5a99b7d396368f97746681cd58434cf6e4701b9 /x11-toolkits
parentfc89df9f1af6bbfba7fcebce71d9c03521fec249 (diff)
downloadfreebsd-ports-gnome-6c3d088da4b3b5508f728e341725f698e05182c9.tar.gz
freebsd-ports-gnome-6c3d088da4b3b5508f728e341725f698e05182c9.tar.zst
freebsd-ports-gnome-6c3d088da4b3b5508f728e341725f698e05182c9.zip
- Update to 1.7.26
Changes: http://www.fox-toolkit.org/news.html
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile4
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp20
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXThread.cpp6
-rw-r--r--x11-toolkits/fox17/pkg-plist7
5 files changed, 10 insertions, 31 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index b9c9fb7e6113..9eddffb0b7e3 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fox
-PORTVERSION= 1.7.25
+PORTVERSION= 1.7.26
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/
@@ -32,7 +32,7 @@ USE_GNOME= gnomehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-opengl=yes
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index b0ff998b7e89..861cebcd9d6a 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.25.tar.gz) = 508a18ac7eda524ea207d206d2aff2f3f78b53ad7e2e749e6149d9a5e985afdc
-SIZE (fox-1.7.25.tar.gz) = 4946475
+SHA256 (fox-1.7.26.tar.gz) = ad40627ff5adf4fac2d2176c016aceb5ad38fcc4ab61b4676f6472c08c582406
+SIZE (fox-1.7.26.tar.gz) = 4882077
diff --git a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
deleted file mode 100644
index 649ced565c7e..000000000000
--- a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/FXAtomic.cpp.orig 2010-12-20 09:35:19.000000000 +0000
-+++ lib/FXAtomic.cpp 2010-12-20 09:35:58.000000000 +0000
-@@ -101,7 +101,7 @@
- // Have API to find out which.
-
- // If neither windows, nor inline assembly, then fallback to global mutex
--#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__))))
-+#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__)))) || defined(__FreeBSD__)
- static pthread_mutex_t global_mutex=PTHREAD_MUTEX_INITIALIZER;
- #endif
-
-@@ -323,7 +323,7 @@
- "movl %%esi,%%ebx\n\t" // Swap ESI back to restore EBX
- "setz %0\n\t" : "=a"(ret), "=D"(ptr) : "D"(ptr), "a"(cmpa), "d"(cmpb), "S"(a), "c"(b) : "memory", "cc");
- return ret;
--#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__))
-+#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__)) && !defined(__FreeBSD__)
- register FXbool ret;
- // CMPXCHG16B: if(RDX:RAX == MEM128){ MEM128 = RCX:RBX } else { RDX:RAX = MEM128; }
- __asm__ __volatile__ ("lock\n\t"
diff --git a/x11-toolkits/fox17/files/patch-lib_FXThread.cpp b/x11-toolkits/fox17/files/patch-lib_FXThread.cpp
index ba069d1ea744..8e8a56877012 100644
--- a/x11-toolkits/fox17/files/patch-lib_FXThread.cpp
+++ b/x11-toolkits/fox17/files/patch-lib_FXThread.cpp
@@ -1,6 +1,6 @@
---- lib/FXThread.cpp.orig 2010-09-27 08:48:52.000000000 +0000
-+++ lib/FXThread.cpp 2010-09-27 08:49:43.000000000 +0000
-@@ -582,7 +582,7 @@
+--- lib/FXThread.cpp.orig 2011-05-19 09:10:16.000000000 +0200
++++ lib/FXThread.cpp 2011-05-19 09:10:38.000000000 +0200
+@@ -599,7 +599,7 @@
InitializeCriticalSection(((RWLOCK*)data)->mutex);
InitializeCriticalSection(((RWLOCK*)data)->access);
((RWLOCK*)data)->readers=0;
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index 7e39596af466..2cecb86d6326 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -5,8 +5,7 @@ bin/Adie.stx
bin/PathFinder
bin/calculator
bin/ControlPanel
-bin/fox-config
-libdata/pkgconfig/fox.pc
+libdata/pkgconfig/fox17.pc
lib/libCHART-%%MAJORVER%%.a
lib/libCHART-%%MAJORVER%%.la
lib/libCHART-%%MAJORVER%%.so
@@ -149,6 +148,7 @@ include/fox-%%MAJORVER%%/FXGLTriangleMesh.h
include/fox-%%MAJORVER%%/FXGLViewer.h
include/fox-%%MAJORVER%%/FXGLVisual.h
include/fox-%%MAJORVER%%/FXGZFileStream.h
+include/fox-%%MAJORVER%%/FXGauge.h
include/fox-%%MAJORVER%%/FXGradientBar.h
include/fox-%%MAJORVER%%/FXGroupBox.h
include/fox-%%MAJORVER%%/FXHash.h
@@ -203,6 +203,7 @@ include/fox-%%MAJORVER%%/FXMenuSeparator.h
include/fox-%%MAJORVER%%/FXMenuTitle.h
include/fox-%%MAJORVER%%/FXMessageBox.h
include/fox-%%MAJORVER%%/FXMessageChannel.h
+include/fox-%%MAJORVER%%/FXMetaClass.h
include/fox-%%MAJORVER%%/FXObject.h
include/fox-%%MAJORVER%%/FXObjectList.h
include/fox-%%MAJORVER%%/FXOptionMenu.h
@@ -431,8 +432,6 @@ include/fox-%%MAJORVER%%/xincs.h
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/cometassay.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/contact.gif
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/dirdialog.png
-%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/dlgedit1.png
-%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/dlgedit2.png
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/emso_screen.png
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/emso_screen_small.jpg
%%PORTDOCS%%%%DOCSDIR%%/html/screenshots/filedialog.png