aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-04-13 04:32:12 +0800
committerasami <asami@FreeBSD.org>1995-04-13 04:32:12 +0800
commit8b4236cf7ebe88317356fa74570fea802de1bd0e (patch)
tree7e4bc01a5237a086344bcf19181b850324b0cc72 /x11-toolkits
parent4b66b1425f949394009f8068fe492c88c8864a2e (diff)
downloadfreebsd-ports-gnome-8b4236cf7ebe88317356fa74570fea802de1bd0e.tar.gz
freebsd-ports-gnome-8b4236cf7ebe88317356fa74570fea802de1bd0e.tar.zst
freebsd-ports-gnome-8b4236cf7ebe88317356fa74570fea802de1bd0e.zip
And now the rest of the x11 ports Makefiles.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Xaw3d/Makefile8
-rw-r--r--x11-toolkits/blt/Makefile8
-rw-r--r--x11-toolkits/iv/Makefile10
3 files changed, 15 insertions, 11 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 1acbb21c1f70..86c02f652e6d 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -3,14 +3,16 @@
# Date created: 18 November 1994
# Whom: asami
#
-# $Id: Makefile,v 1.0 1994/11/18 00:00:00 asami Exp $
+# $Id: Makefile,v 1.6 1995/04/04 09:24:46 asami Exp $
#
DISTNAME= Xaw3d-1.1
-USE_IMAKE= yes
-MASTER_SITES= ftp://crl.dec.com/pub/X11/contrib/widgets/Xaw3d/R6/
CATEGORIES+= x11
+MASTER_SITES= ftp://crl.dec.com/pub/X11/contrib/widgets/Xaw3d/R6/
+
MAINTAINER= asami@FreeBSD.ORG
+
WRKSRC= ${WRKDIR}/lib/Xaw3d
+USE_IMAKE= yes
.include <bsd.port.mk>
diff --git a/x11-toolkits/blt/Makefile b/x11-toolkits/blt/Makefile
index 0af732bd5794..0b00c7039a0d 100644
--- a/x11-toolkits/blt/Makefile
+++ b/x11-toolkits/blt/Makefile
@@ -3,14 +3,16 @@
# Date created: 14 December 1994
# Whom: wollman
#
-# $Id: Makefile,v 1.2 1995/02/11 13:51:16 asami Exp $
+# $Id: Makefile,v 1.3 1995/04/01 12:50:43 jkh Exp $
#
DISTNAME= blt-1.7
-DISTFILES= BLT-1.7.tar.gz
-MASTER_SITES= ftp://ftp.aud.alcatel.com/tcl/extensions/
CATEGORIES+= x11
+MASTER_SITES= ftp://ftp.aud.alcatel.com/tcl/extensions/
+DISTFILES= BLT-1.7.tar.gz
+
LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
+
GNU_CONFIGURE= yes
ALL_TARGET= all sharedlib
diff --git a/x11-toolkits/iv/Makefile b/x11-toolkits/iv/Makefile
index 41888929dd5e..b5ce5b6fa0ef 100644
--- a/x11-toolkits/iv/Makefile
+++ b/x11-toolkits/iv/Makefile
@@ -3,13 +3,14 @@
# Date created: 23.sept.1994
# Whom: adam
#
-# $Id: Makefile,v 1.3 1994/11/15 03:19:35 adam Exp $
+# $Id: Makefile,v 1.4 1995/04/01 12:50:56 jkh Exp $
#
-EXTRACT_SUFFIX= .tar.Z
VERSION= 3.1
DISTNAME= iv-${VERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFFIX}
+EXTRACT_SUFX= .tar.Z
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+
WRKSRC= ${WRKDIR}/iv
MAKEFILE= makefile
NCFTPFLAGS= -NP
@@ -19,9 +20,8 @@ pre-fetch:
@if [ ! -f ${DISTDIR}/${DISTFILES} ]; then \
mkdir -p ${DISTDIR}/${DISTNAME} ; \
${MAKE} MASTER_SITES=ftp://interviews.stanford.edu/pub/ \
-CATEGORIES+= x11
DISTDIR=${DISTDIR}/${DISTNAME} DISTNAME=${VERSION} fetch ; \
- mv ${DISTDIR}/${DISTNAME}/${VERSION}${EXTRACT_SUFFIX} \
+ mv ${DISTDIR}/${DISTNAME}/${VERSION}${EXTRACT_SUFX} \
${DISTDIR}/${DISTFILES} ; \
rmdir ${DISTDIR}/${DISTNAME} ; \
fi