aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
committerbapt <bapt@FreeBSD.org>2015-04-09 15:44:41 +0800
commitba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7 (patch)
treeb7aed86ac84412d11603ce23b7893d46f0d7475b /x11-toolkits
parent3fcb7028e93fb51c19b4379e9c99091b90563e30 (diff)
downloadfreebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.gz
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.tar.zst
freebsd-ports-gnome-ba50e6fa6dadb80fdb12b7fc2be35a67b6867ec7.zip
Convert bsd.gnustep.mk to USES=gnustep
Simplify gnustep ports Hook into the regular ports framework: - LIB_DEPENDS for library dependencies - Use regular USE_LDCONFIG Reuse USES=objc (automatic) USE_GNUSTEP is now a macro to set the dependencies and build feature needed. Accepted arguments: back base build gui Merge deskutils/preferencepanes into deskutils/systempreferences
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-back/Makefile31
-rw-r--r--x11-toolkits/gnustep-gui/Makefile14
2 files changed, 16 insertions, 29 deletions
diff --git a/x11-toolkits/gnustep-back/Makefile b/x11-toolkits/gnustep-back/Makefile
index c801515bd3e9..032cc1ff21da 100644
--- a/x11-toolkits/gnustep-back/Makefile
+++ b/x11-toolkits/gnustep-back/Makefile
@@ -4,9 +4,7 @@ PORTNAME= gnustep-back
PORTVERSION= 0.24.0
PORTREVISION= 5
CATEGORIES= x11-toolkits gnustep
-MASTER_SITES= ${MASTER_SITE_GNUSTEP}
-MASTER_SITE_SUBDIR= core
-PKGNAMESUFFIX?= ${BACK_SUFFIX}${PKGNAMESUFFIX2}
+MASTER_SITES= GNUSTEP/core
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep GUI backend
@@ -32,24 +30,19 @@ CONFIGURE_ARGS= --with-tiff-library=${LOCALBASE}/lib \
--enable-graphics=cairo \
--disable-glitz
-USES= pkgconfig
-USE_GNUSTEP= yes
-USE_GNUSTEP_GUI= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_XORG= xft xrender xmu xext x11 xcursor xfixes xmu
-USE_GL= yes
+USES= gnustep pkgconfig
+USE_GNUSTEP= base gui build
+USE_XORG= xft xrender xmu xext x11 xcursor xfixes xmu
+USE_GL= yes
+USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
-MAKE_FLAGS+= OPTFLAG="${CFLAGS} -I${LOCALBASE}/include"
-MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-BACKVERSION= ${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
-BREAKS_IF_PEDANTIC= yes
+MAKE_FLAGS+= OPTFLAG="${CFLAGS} -I${LOCALBASE}/include"
+MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
+BACKVERSION= ${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
-CFLAGS+= -I${LOCALBASE}/include/freetype2
-PLIST_SUB+= BACK=back-${BACKVERSION}
-
-PLIST_SUB+= BACKVERSION=${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
+CFLAGS+= -I${LOCALBASE}/include/freetype2
+PLIST_SUB+= BACK=back-${BACKVERSION}
+PLIST_SUB+= BACKVERSION=${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
pre-configure:
.for file in config.guess config.sub install-sh
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 19f8f73668ed..75fba785f0dd 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -38,13 +38,8 @@ CONFIGURE_ARGS+= --with-x
CONFIGURE_ARGS+= --with-x-include=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-x-include=${LOCALBASE}/lib
-USES= pkgconfig
-USE_GNUSTEP= yes
-USE_GNUSTEP_CONFIGURE= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GNUSTEP_BASE= yes
-USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
+USES= gnustep pkgconfig
+USE_GNUSTEP= base build
USE_XORG= x11 xt
EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.patch
@@ -52,17 +47,16 @@ EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.speech.patch
EXTRA_PATCHES+= ${FILESDIR}/AudioOutputSink.m.patch
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
-BREAKS_IF_PEDANTIC= yes
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
-ADDITIONAL_INCLUDE_DIRS+= -I${LOCALBASE}/include/libpng15
-
CUPS_CONFIGURE_ENABLE= cups
CUPS_LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
ASPELL_CONFIGURE_ENABLE= aspell
+USE_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
+
post-patch:
${REINPLACE_CMD} -e "s|libpng/png.h|png.h|" ${WRKSRC}/configure
${REINPLACE_CMD} -e "s|doc=no|doc=yes|" ${WRKSRC}/GNUmakefile