aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
committermat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
commit0691688a506fc2dffc574eeeb80dc0d876378fed (patch)
tree204c01c7973e83331fc29d8b09e59b3e9f219bd6 /x11-toolkits
parent33639ffbb666f12097ddeff5ef7da2226febf15b (diff)
downloadfreebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.gz
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.zst
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.zip
Remove OSVERSION checks that do not make sense any more.
For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true, as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107). Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when it is always needed, I renamed it, in one case, I merged two patches. Differential Revision: https://reviews.freebsd.org/D2209
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/xview-clients/Makefile10
-rw-r--r--x11-toolkits/xview/Makefile10
2 files changed, 2 insertions, 18 deletions
diff --git a/x11-toolkits/xview-clients/Makefile b/x11-toolkits/xview-clients/Makefile
index e7771fd25992..b3441170301a 100644
--- a/x11-toolkits/xview-clients/Makefile
+++ b/x11-toolkits/xview-clients/Makefile
@@ -28,11 +28,7 @@ ALL_TARGET= Clients
X11BASE2FIX= clients/olwmslave/help_file.c lib/libxview/help/help_file.c \
lib/libxview/misc/gettext.h lib/libxview/textsw/txt_e_menu.c
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 800089
CFLAGS+= -DCOMPAT_43TTY
-.endif
IMAKECPPFLAGS+= -DXVDestDir=${STAGEDIR}${PREFIX}
@@ -44,10 +40,6 @@ pre-configure:
${WRKSRC}/config/XView.cf
@${REINPLACE_CMD} -e "s,CcCmd cc,CcCmd ${CC}," \
${WRKSRC}/config/XView.tmpl
-.if ${OSVERSION} < 800090
- @${REINPLACE_CMD} -e "s/-DCOMPAT_43TTY//" \
- ${WRKSRC}/config/XView.tmpl
-.endif
@${REINPLACE_CMD} -e 's+/usr/X11/+${PREFIX}/+g;' \
${WRKSRC}/clients/olwm/screen.c
${REINPLACE_CMD} -e 's+/usr/lib+${PREFIX}/lib+' \
@@ -62,4 +54,4 @@ do-install:
@cd ${WRKSRC}/clients; ${MAKE} install install.man
@${INSTALL_DATA} ${WRKSRC}/misc/support/textedit.info ${STAGEDIR}${PREFIX}/lib/help/textedit.info
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/xview/Makefile b/x11-toolkits/xview/Makefile
index 1bf21352d8ef..1b2588f524d6 100644
--- a/x11-toolkits/xview/Makefile
+++ b/x11-toolkits/xview/Makefile
@@ -28,7 +28,7 @@ IMAKEINCLUDE= "-I${WRKSRC}/config -I${LOCALBASE}/lib/X11/config"
MAKE_ENV+= IMAKEINCLUDE=${IMAKEINCLUDE}
ALL_TARGET= World
SUB_FILES= pkg-message
-CFLAGS+= -Wno-return-type
+CFLAGS+= -Wno-return-type -DCOMPAT_43TTY
DESTDIRNAME= NONEXISTENT
X11BASE2FIX= clients/olwmslave/help_file.c lib/libxview/help/help_file.c \
@@ -38,10 +38,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 800089
-CFLAGS+= -DCOMPAT_43TTY
-.endif
-
post-extract:
@${MV} ${WRKSRC}/xview.man ${WRKSRC}/XView.man
@@ -50,10 +46,6 @@ pre-configure:
${WRKSRC}/config/XView.cf
@${REINPLACE_CMD} -e "s,CcCmd cc,CcCmd ${CC}," \
${WRKSRC}/config/XView.tmpl
-.if ${OSVERSION} < 800090
- @${REINPLACE_CMD} -e "s/-DCOMPAT_43TTY//" \
- ${WRKSRC}/config/XView.tmpl
-.endif
@${REINPLACE_CMD} -e 's+/usr/X11/+${PREFIX}/+g;' \
${WRKSRC}/clients/olwm/screen.c
${REINPLACE_CMD} -e 's+/usr/lib+${PREFIX}/lib+' \