aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-03-30 22:02:58 +0800
committerjbeich <jbeich@FreeBSD.org>2017-03-30 22:02:58 +0800
commit371ab96a2119aac3240c11d58da0d56af70bc63a (patch)
tree2b34b12aaf4d42030714d229a2ea8c53f35a282d /x11-toolkits
parent1b3626dc02c60772f9cc9a8dfa24d2094692814b (diff)
downloadfreebsd-ports-gnome-371ab96a2119aac3240c11d58da0d56af70bc63a.tar.gz
freebsd-ports-gnome-371ab96a2119aac3240c11d58da0d56af70bc63a.tar.zst
freebsd-ports-gnome-371ab96a2119aac3240c11d58da0d56af70bc63a.zip
x11-toolkits/gtk30: prefer warnings over crashes on bad behavior
devel/glib20 and x11-toolkits/gtk20 don't use --disable-debug. Neither does gtk3 package on Debian or ArchLinux. https://bugzilla.mozilla.org/show_bug.cgi?id=1351246#c9 $ cat >a.c #include <gdk/gdk.h> int main() { gdk_get_default_root_window(); return 0; } $ cc a.c $(pkg-config --cflags --libs gtk+-3.0) $ ./a.out Segmentation fault vs. (new behavior) $ ./a.out (process:40995): Gdk-CRITICAL **: gdk_screen_get_root_window: assertion 'GDK_IS_SCREEN (screen)' failed Pointy hat to: kwm (r372768 broke consistency)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk30/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 795032716c6b..d2d89ba15bb0 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -5,7 +5,7 @@
PORTNAME= gtk
PORTVERSION= 3.18.8
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PKGNAMESUFFIX= 3
@@ -73,7 +73,7 @@ CLOUDPRINT_CONFIGURE_ENABLE= cloudprint
CLOUDPRINT_LIB_DEPENDS= librest-0.7.so:devel/librest \
libjson-glib-1.0.so:devel/json-glib
-DEBUG_CONFIGURE_ENABLE=debug
+DEBUG_CONFIGURE_ON= --enable-debug=yes
post-patch:
@${REINPLACE_CMD} -e 's|[{]libdir[}]/locale|{datadir}/locale|g' \