aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /x11-toolkits
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/SoXt/Makefile4
-rw-r--r--x11-toolkits/bakery/Makefile6
-rw-r--r--x11-toolkits/eel/Makefile4
-rw-r--r--x11-toolkits/fox14/Makefile4
-rw-r--r--x11-toolkits/fox16/Makefile4
-rw-r--r--x11-toolkits/fox17/Makefile4
-rw-r--r--x11-toolkits/fxscintilla/Makefile4
-rw-r--r--x11-toolkits/gal2/Makefile6
-rw-r--r--x11-toolkits/gdl/Makefile4
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile4
-rw-r--r--x11-toolkits/gstreamer1-plugins-pango/Makefile2
-rw-r--r--x11-toolkits/gtkdatabox/Makefile4
-rw-r--r--x11-toolkits/gtkextra2/Makefile4
-rw-r--r--x11-toolkits/gtkglarea2/Makefile8
-rw-r--r--x11-toolkits/gtkmm20/Makefile4
-rw-r--r--x11-toolkits/gtkmm30/Makefile4
-rw-r--r--x11-toolkits/gtksourceview/Makefile6
-rw-r--r--x11-toolkits/gtksourceview2/Makefile6
-rw-r--r--x11-toolkits/gtksourceview3/Makefile6
-rw-r--r--x11-toolkits/gtksourceviewmm3/Makefile4
-rw-r--r--x11-toolkits/libXaw/Makefile2
-rw-r--r--x11-toolkits/libXmu/Makefile2
-rw-r--r--x11-toolkits/libXt/Makefile2
-rw-r--r--x11-toolkits/libbonoboui/Makefile4
-rw-r--r--x11-toolkits/libgdiplus/Makefile4
-rw-r--r--x11-toolkits/libgnomeprintui/Makefile4
-rw-r--r--x11-toolkits/libgnomeprintuimm/Makefile4
-rw-r--r--x11-toolkits/libgnomeuimm26/Makefile4
-rw-r--r--x11-toolkits/libpanelappletmm/Makefile4
-rw-r--r--x11-toolkits/libunique3/Makefile3
-rw-r--r--x11-toolkits/libzvt/Makefile4
-rw-r--r--x11-toolkits/mowitz/Makefile4
-rw-r--r--x11-toolkits/pango/Makefile4
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile6
-rw-r--r--x11-toolkits/py-gnome-extras/Makefile6
-rw-r--r--x11-toolkits/py-gnome2/Makefile6
-rw-r--r--x11-toolkits/py-gtksourceview/Makefile4
-rw-r--r--x11-toolkits/vdk/Makefile4
-rw-r--r--x11-toolkits/vte/Makefile4
39 files changed, 82 insertions, 85 deletions
diff --git a/x11-toolkits/SoXt/Makefile b/x11-toolkits/SoXt/Makefile
index 54d6ef5f7bc0..7e5f5e286f19 100644
--- a/x11-toolkits/SoXt/Makefile
+++ b/x11-toolkits/SoXt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= SoXt
PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/
@@ -12,7 +12,7 @@ COMMENT= GUI binding for using Open Inventor with Xt/Motif
LIB_DEPENDS= libCoin.so:${PORTSDIR}/graphics/Coin
-USES= libtool motif pathfix perl5
+USES= libtool:keepla motif pathfix perl5
USE_GL= yes
USE_PERL5= build
USE_XORG= xi
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index c7bad2fe28fb..c818ee474021 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -4,20 +4,20 @@
PORTNAME= bakery
PORTVERSION= 2.6.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A C++ Application Framework for use with Gtkmm
+COMMENT= C++ Application Framework for use with Gtkmm
LIB_DEPENDS= libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26 \
libglademm-2.4.so:${PORTSDIR}/devel/libglademm24 \
libgnomevfsmm-2.6.so:${PORTSDIR}/devel/gnome-vfsmm \
libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix intlhack
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
index 3c59958e9e0a..f45eb5120a00 100644
--- a/x11-toolkits/eel/Makefile
+++ b/x11-toolkits/eel/Makefile
@@ -4,7 +4,7 @@
PORTNAME= eel
PORTVERSION= 2.26.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -12,7 +12,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Generally useful classes and extensions to GNOME
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_XORG= xrender
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomedesktop intlhack
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 8ea3a3ad21ae..c5a8c0143bdf 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fox
PORTVERSION= 1.4.35
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -21,7 +21,7 @@ MAJORVER= ${PORTVERSION:R}
SHVER= ${PORTVERSION:S/${MAJORVER}.//}
PLIST_SUB+= MAJORVER=${MAJORVER} SHVER=${SHVER}
-USES= libtool
+USES= libtool:keepla
USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-opengl=yes \
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index 0cde01add3b9..e852c83fd925 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fox
PORTVERSION= 1.6.49
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.fox-toolkit.org/pub/ \
http://ftp.fox-toolkit.org/pub/
@@ -19,7 +19,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
MAJORVER= ${PORTVERSION:R}
PLIST_SUB+= MAJORVER=${MAJORVER}
-USES+= libtool pathfix
+USES= libtool:keepla pathfix
USE_GL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index afbee6c6ca89..4e07eff95316 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fox
PORTVERSION= 1.7.46
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
@@ -19,8 +19,8 @@ MAJORVER= ${PORTVERSION:R}
PLIST_SUB+= MAJORVER=${MAJORVER}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${MAJORVER}
-USES+= libtool pathfix
GNU_CONFIGURE= yes
+USES= libtool:keepla pathfix
USE_GL= glut
USE_XORG= sm xft
USE_LDCONFIG= yes
diff --git a/x11-toolkits/fxscintilla/Makefile b/x11-toolkits/fxscintilla/Makefile
index 973b02705057..63a5d85ed756 100644
--- a/x11-toolkits/fxscintilla/Makefile
+++ b/x11-toolkits/fxscintilla/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fxscintilla
PORTVERSION= 2.28.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-toolkits
MASTER_SITES= SAVANNAH
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
-USES= libtool pathfix pkgconfig
+USES= libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index 306644eded11..104b6d902d8c 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gal2
PORTVERSION= 2.5.3
-PORTREVISION?= 11
+PORTREVISION?= 12
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.5
@@ -12,13 +12,13 @@ DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A collection of widgets taken from GNOME 2 gnumeric
+COMMENT= Collection of widgets taken from GNOME 2 gnumeric
USES+= tar:bzip2
.if !defined(REFERENCE_PORT)
-USES+= pathfix gettext perl5 gmake pkgconfig libtool
+USES+= gettext gmake libtool:keepla pathfix perl5 pkgconfig
USE_GNOME= gnomeprefix intlhack libgnomeui libgnomeprintui
USE_XORG= x11
USE_LDCONFIG= yes
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index a9e38f8fe4cf..fe51f85de348 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -4,15 +4,15 @@
PORTNAME= gdl
PORTVERSION= 2.30.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Components intended to be shared between GNOME development tools
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix gtk20
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index f6b384b40bde..54394acc3067 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-sharp
PORTVERSION= 2.24.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
@@ -12,7 +12,7 @@ COMMENT= GNOME interfaces for the .NET runtime
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake libtool pathfix perl5 pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix perl5 pkgconfig tar:bzip2
USE_PERL5= run
USE_GNOME= gnomepanel gtksharp20 librsvg2 vte libgnomeprintui libgnomeui
MAKE_JOBS_UNSAFE= yes
diff --git a/x11-toolkits/gstreamer1-plugins-pango/Makefile b/x11-toolkits/gstreamer1-plugins-pango/Makefile
index ce7fd500bfb6..b2950e795aaf 100644
--- a/x11-toolkits/gstreamer1-plugins-pango/Makefile
+++ b/x11-toolkits/gstreamer1-plugins-pango/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-toolkits
COMMENT= Gstreamer pango textoverlay plugin
diff --git a/x11-toolkits/gtkdatabox/Makefile b/x11-toolkits/gtkdatabox/Makefile
index 676b584c2c8b..42e4457f1074 100644
--- a/x11-toolkits/gtkdatabox/Makefile
+++ b/x11-toolkits/gtkdatabox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkdatabox
PORTVERSION= 0.9.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= SF
DIST_SUBDIR= gnome2
@@ -17,7 +17,7 @@ OPTIONS_DEFINE= GLADE GLADEUI DOCS EXAMPLES
GLADE_DESC= Enable libglade2 support
GLADEUI_DESC= Enable glade3 support
-USES= libtool pathfix pkgconfig
+USES= libtool:keepla pathfix pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}" \
diff --git a/x11-toolkits/gtkextra2/Makefile b/x11-toolkits/gtkextra2/Makefile
index e6be90876966..425f4fcfa7ae 100644
--- a/x11-toolkits/gtkextra2/Makefile
+++ b/x11-toolkits/gtkextra2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkextra
PORTVERSION= 2.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME:S/gtk/gtk+/}-${PORTVERSION}
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME:S/gtk/gtk+/}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Useful widget set complementary to GTK+ 2.0
-USES= libtool pathfix pkgconfig gmake
+USES= gmake libtool:keepla pathfix pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
USE_CSTD= gnu89
diff --git a/x11-toolkits/gtkglarea2/Makefile b/x11-toolkits/gtkglarea2/Makefile
index 60200526c820..867d9dce4f1a 100644
--- a/x11-toolkits/gtkglarea2/Makefile
+++ b/x11-toolkits/gtkglarea2/Makefile
@@ -4,18 +4,18 @@
PORTNAME= gtkglarea
PORTVERSION= 2.0.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
DISTNAME= gtkglarea-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An OpenGL widget for the GTK+2 GUI toolkit
+COMMENT= OpenGL widget for the GTK+2 GUI toolkit
-USE_GNOME= gtk20
+USES= libtool:keepla pathfix pkgconfig tar:bzip2
+USE_GNOME= gtk20
USE_GL= yes
-USES= libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lib-GL
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index f6ffa2cf0e2d..e8dc0d67f1a7 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.12
-PORTREVISION?= 14
+PORTREVISION?= 15
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME/sources/${PORTNAME}/2.2
PKGNAMESUFFIX= 20
@@ -20,7 +20,7 @@ USES+= tar:bzip2
LIB_DEPENDS= libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES+= pathfix gmake libtool pkgconfig
+USES+= gmake libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= gtk20
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index 95e58c12effa..b7c7af252758 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gtkmm
PORTVERSION= 3.8.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
PKGNAMESUFFIX= 30
@@ -21,7 +21,7 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES+= gettext gmake libtool pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
USE_GNOME= gtk30 glibmm cairomm atkmm pangomm
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/x11-toolkits/gtksourceview/Makefile b/x11-toolkits/gtksourceview/Makefile
index b8798a82a363..462bc48f0c34 100644
--- a/x11-toolkits/gtksourceview/Makefile
+++ b/x11-toolkits/gtksourceview/Makefile
@@ -4,19 +4,19 @@
PORTNAME= gtksourceview
PORTVERSION= 1.8.5
-PORTREVISION?= 9
+PORTREVISION?= 10
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+COMMENT= Widget that adds syntax highlighting to GtkTextView
USES+= tar:bzip2
.if !defined(REFERENCE_PORT)
-USES+= gettext gmake libtool pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix libgnome libgnomeprintui intlhack referencehack
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/gtksourceview2/Makefile b/x11-toolkits/gtksourceview2/Makefile
index 8bfebaf26407..f0e0ea60eca8 100644
--- a/x11-toolkits/gtksourceview2/Makefile
+++ b/x11-toolkits/gtksourceview2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gtksourceview2
PORTVERSION= 2.10.5
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -12,13 +12,13 @@ DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+COMMENT= Widget that adds syntax highlighting to GtkTextView
USES= tar:bzip2
.if !defined(REFERENCE_PORT)
-USES+= gettext gmake pathfix libtool pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gtk20 gconf2 libxml2 intlhack referencehack
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/gtksourceview3/Makefile b/x11-toolkits/gtksourceview3/Makefile
index 4974e4dcccfa..dae93e80f0f0 100644
--- a/x11-toolkits/gtksourceview3/Makefile
+++ b/x11-toolkits/gtksourceview3/Makefile
@@ -4,21 +4,21 @@
PORTNAME= gtksourceview
PORTVERSION= 3.4.2
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 3
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+COMMENT= Widget that adds syntax highlighting to GtkTextView
USES= tar:xz
.if !defined(REFERENCE_PORT)
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
-USES+= libtool pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix gtk30 libxml2 intlhack referencehack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-compile-warnings=no --enable-glade-catalog=no \
diff --git a/x11-toolkits/gtksourceviewmm3/Makefile b/x11-toolkits/gtksourceviewmm3/Makefile
index 12711a42dced..a8b425d34d7b 100644
--- a/x11-toolkits/gtksourceviewmm3/Makefile
+++ b/x11-toolkits/gtksourceviewmm3/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gtksourceviewmm
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 3
@@ -12,8 +12,8 @@ PKGNAMESUFFIX= 3
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ binding of GtkSourceView3
+USES= gmake libtool:keepla pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
-USES= pathfix gmake pkgconfig tar:xz libtool
USE_GNOME= gtksourceview3 gnomeprefix gtkmm30
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/libXaw/Makefile b/x11-toolkits/libXaw/Makefile
index 24f4e9d75eec..3da042767ade 100644
--- a/x11-toolkits/libXaw/Makefile
+++ b/x11-toolkits/libXaw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libXaw
PORTVERSION= 1.0.12
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= x11-toolkits
diff --git a/x11-toolkits/libXmu/Makefile b/x11-toolkits/libXmu/Makefile
index 6463fa5537ab..edc3cf1d6889 100644
--- a/x11-toolkits/libXmu/Makefile
+++ b/x11-toolkits/libXmu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libXmu
PORTVERSION= 1.1.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= x11-toolkits
diff --git a/x11-toolkits/libXt/Makefile b/x11-toolkits/libXt/Makefile
index 5fe8f304528d..786efb51d8e5 100644
--- a/x11-toolkits/libXt/Makefile
+++ b/x11-toolkits/libXt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libXt
PORTVERSION= 1.1.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= x11-toolkits
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
index fa96d3b9cc13..0af60edbb4dc 100644
--- a/x11-toolkits/libbonoboui/Makefile
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libbonoboui
PORTVERSION= 2.24.4
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
@@ -16,7 +16,7 @@ USES+= tar:bzip2
.if !defined(REFERENCE_PORT)
-USES+= gettext gmake libtool pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehier intlhack \
libgnomecanvas libgnome referencehack
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index edf064efc774..edfd4c7c9277 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgdiplus
PORTVERSION= 2.10
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
@@ -16,7 +16,7 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libcairo.so:${PORTSDIR}/graphics/cairo
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_XORG= x11
diff --git a/x11-toolkits/libgnomeprintui/Makefile b/x11-toolkits/libgnomeprintui/Makefile
index 43fb730c506b..5e6e14891dbc 100644
--- a/x11-toolkits/libgnomeprintui/Makefile
+++ b/x11-toolkits/libgnomeprintui/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libgnomeprintui
PORTVERSION= 2.18.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,8 +15,8 @@ COMMENT= Gnome print support library
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
+USES= bison gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_XORG= x11 xpm
-USES= bison pathfix gettext gmake pkgconfig libtool tar:bzip2
USE_GNOME= gnomeprefix libgnomeprint libgnomecanvas \
intlhack
USE_LDCONFIG= yes
diff --git a/x11-toolkits/libgnomeprintuimm/Makefile b/x11-toolkits/libgnomeprintuimm/Makefile
index 64dade5fbe7a..3a13b68ec7ee 100644
--- a/x11-toolkits/libgnomeprintuimm/Makefile
+++ b/x11-toolkits/libgnomeprintuimm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libgnomeprintuimm
PORTVERSION= 2.5.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
libgnomeprintmm-2.5.so:${PORTSDIR}/print/libgnomeprintmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix libgnomeprintui
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/libgnomeuimm26/Makefile b/x11-toolkits/libgnomeuimm26/Makefile
index 75469cf540c6..5780c1d0c689 100644
--- a/x11-toolkits/libgnomeuimm26/Makefile
+++ b/x11-toolkits/libgnomeuimm26/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libgnomeuimm
PORTVERSION= 2.28.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -19,8 +19,8 @@ LIB_DEPENDS= libgnomemm-2.6.so:${PORTSDIR}/x11/libgnomemm26 \
libgnomevfsmm-2.6.so:${PORTSDIR}/devel/gnome-vfsmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_XORG= x11
-USES= gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= libgnomeui
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/x11-toolkits/libpanelappletmm/Makefile b/x11-toolkits/libpanelappletmm/Makefile
index d3c70b266ef8..37d8c87f6b59 100644
--- a/x11-toolkits/libpanelappletmm/Makefile
+++ b/x11-toolkits/libpanelappletmm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libpanelappletmm
PORTVERSION= 2.26.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
libgconfmm-2.6.so:${PORTSDIR}/devel/gconfmm26
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomepanel
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/libunique3/Makefile b/x11-toolkits/libunique3/Makefile
index 92758e2306fe..af60176afe78 100644
--- a/x11-toolkits/libunique3/Makefile
+++ b/x11-toolkits/libunique3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libunique
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
@@ -13,7 +14,7 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USE_XORG= ice x11
USE_XZ= yes
-USES= gettext gmake libtool pathfix pkgconfig
+USES= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
USE_GNOME= gtk30 gnomeprefix
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/libzvt/Makefile b/x11-toolkits/libzvt/Makefile
index edfffadb06e6..5535889ea47e 100644
--- a/x11-toolkits/libzvt/Makefile
+++ b/x11-toolkits/libzvt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libzvt
PORTVERSION= 2.0.1
-PORTREVISION= 22
+PORTREVISION= 23
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -11,8 +11,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library components for Zed's Virtual Terminal
+USES= bison gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_XORG= x11
-USES= bison libtool pathfix gmake pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_GNOME= gnomeprefix gtk20 libartlgpl2
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/mowitz/Makefile b/x11-toolkits/mowitz/Makefile
index 02a17aa2e732..061ab3654f03 100644
--- a/x11-toolkits/mowitz/Makefile
+++ b/x11-toolkits/mowitz/Makefile
@@ -19,8 +19,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xawm=Xaw3d
INSTALL_TARGET= install-strip
-post-install:
- ${RM} ${STAGEDIR}${PREFIX}/lib/libMowitz.la
-# Anyone knows a better way?
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 2f4961dc972d..35f1bedef29a 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -4,7 +4,7 @@
PORTNAME= pango
PORTVERSION= 1.34.1
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -23,7 +23,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
RUN_DEPENDS= ${FONTSCALE}:${PORTSDIR}/x11-fonts/xorg-fonts-truetype \
${FONTENCOD}:${PORTSDIR}/x11-fonts/encodings
-USES+= gettext gmake libtool pathfix pkgconfig
+USES+= gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= cairo glib20 introspection:build referencehack
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
index 655dad501118..c6c5424b96a6 100644
--- a/x11-toolkits/py-gnome-desktop/Makefile
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-desktop
PORTVERSION= 2.32.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -13,7 +13,7 @@ DISTNAME= gnome-python-desktop-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A set of Python bindings used by modules in the GNOME Desktop
+COMMENT= Python bindings used by modules in the GNOME Desktop
OPTIONS_DEFINE= DOCS EXAMPLES
OPTIONS_SUB= yes
@@ -28,7 +28,7 @@ LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
libevdocument.so:${PORTSDIR}/graphics/evince
RUN_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_PYTHON= 2
USE_GNOME= libgnomeprintui gnomepanel gnomedesktop \
gtksourceview libwnck nautilus2 pygnome2 metacity \
diff --git a/x11-toolkits/py-gnome-extras/Makefile b/x11-toolkits/py-gnome-extras/Makefile
index 0f05161b7105..e4f212dc29e3 100644
--- a/x11-toolkits/py-gnome-extras/Makefile
+++ b/x11-toolkits/py-gnome-extras/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome-extras
PORTVERSION= 2.25.3
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python-extras/${PORTVERSION:C/..$//}
@@ -13,7 +13,7 @@ DISTNAME= gnome-python-extras-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A set of Python bindings for GNOME 2
+COMMENT= Python bindings for GNOME 2
OPTIONS_DEFINE= EXAMPLES
OPTIONS_SUB= yes
@@ -22,7 +22,7 @@ LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell \
libgksu2.so:${PORTSDIR}/sysutils/libgksu \
# gdl-1.2:${PORTSDIR}/x11-toolkits/gdl
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_PYTHON= yes
USE_GNOME= libgtkhtml pygnome2 libgda4
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index 1f6e0a1913dd..598e88a6f811 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gnome
PORTVERSION= 2.28.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -13,7 +13,7 @@ DISTNAME= gnome-python-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A set of Python bindings for GNOME 2
+COMMENT= Python bindings for GNOME 2
OPTIONS_DEFINE= EXAMPLES
@@ -22,9 +22,9 @@ OPTIONS_SUB= yes
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/ORBit.so:${PORTSDIR}/devel/py-orbit
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ORBit.so:${PORTSDIR}/devel/py-orbit
+USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_PYTHON= 2
USE_LDCONFIG= yes
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= libgnomeui pygtk2
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
diff --git a/x11-toolkits/py-gtksourceview/Makefile b/x11-toolkits/py-gtksourceview/Makefile
index ecc4436c7e9e..a217594a58fa 100644
--- a/x11-toolkits/py-gtksourceview/Makefile
+++ b/x11-toolkits/py-gtksourceview/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pygtksourceview-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A python bindings for the version 2 of the GtkSourceView library
+COMMENT= Python bindings for GtkSourceView 2
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix gtksourceview2 pygtk2
USE_PYTHON= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index 02af51825542..916162517570 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vdk
PORTVERSION= 2.5.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MASTER_SITES= SF/${PORTNAME}lib/VDK%20for%20both%20Linux%20and%20Windows%20%28this%20is%20the%20new%20version%29/VDKLIB%20%28C%2B%2B%20wrapper%20for%20GTK%2B%29
@@ -13,7 +13,7 @@ COMMENT= C++ wrapper for GTK+ toolkit
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool pathfix pkgconfig
+USES= libtool:keepla pathfix pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no --enable-testvdk=no
diff --git a/x11-toolkits/vte/Makefile b/x11-toolkits/vte/Makefile
index ebd0a06521dd..2e258c1b0aae 100644
--- a/x11-toolkits/vte/Makefile
+++ b/x11-toolkits/vte/Makefile
@@ -4,7 +4,7 @@
PORTNAME= vte
PORTVERSION= 0.28.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,7 +18,7 @@ USES+= tar:xz
RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
-USES+= bison gettext gmake libtool pathfix pkgconfig
+USES+= bison gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomeprefix gtk20 introspection:build referencehack