aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-15 20:42:48 +0800
committergahr <gahr@FreeBSD.org>2014-07-15 20:42:48 +0800
commit58944727969d2ffbd2e6986c583cc9ef8fca9567 (patch)
treed6873dc70f90d413e93f68f68726b7d0f0f6ee10 /x11-toolkits
parent679afe496c391df7de06834f5cbcde85222f3b5f (diff)
downloadfreebsd-ports-gnome-58944727969d2ffbd2e6986c583cc9ef8fca9567.tar.gz
freebsd-ports-gnome-58944727969d2ffbd2e6986c583cc9ef8fca9567.tar.zst
freebsd-ports-gnome-58944727969d2ffbd2e6986c583cc9ef8fca9567.zip
- Update to 1.7.48
Changes: * Added verbose option to reswrap. * Updated BMP loader routines, some bullet-proofing against malicious bitmap files. * Changes in FXVariant: operator bool returns true for non-zero numerical values, non-empty arrays or non-empty dictionaries. It only returns false if the variant is FXVariant::null. This new interpretation strokes much better with common usage patterns. * Added asChars() API to FXVariant. * FXPtrList now index with FXival. * Print routines fxprintf() are now supporting NaN and Inf printouts. Also fixed -0 printout. * Change in FXThreadPool::wait() routine: now waits till all jobs are finished. * Added executeAndWait() routine to FXThreadPool and FXTaskGroup. * Small change in FXParallel: ensure tasks are aligned in memory. * Added FXEXEIcon and FXEXEImage. These should icons or bitmaps embedded in Windows Executable files. * Added FXCOLORREF2RGB and FXRGB2COLORREF macros for Windows based FOX applications. * Some complex math transcendentals added. * Population-count inline functions added to fxendian.h. These use x86 builtins when possible. * API fixes (bad parameter signatures) fixed in the list-widgets. * CDECL attributes in some FXApp member functions (Windows Only).
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile2
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-include_FXParallel.h11
3 files changed, 14 insertions, 3 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 7e357f934b1a..72b69cf031c4 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.47
+PORTVERSION= 1.7.48
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index ee14bf4d51e7..87b855b5bdf8 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.47.tar.gz) = 7f1de8566b88b0010137ea1172168d53494d2d14bfa03fe32f7796146a31a2a3
-SIZE (fox-1.7.47.tar.gz) = 5271135
+SHA256 (fox-1.7.48.tar.gz) = 90e011aa83eed8a1b3ffe1c1571cb5de41fae8162c7ae01e22697f98aeaa9b7f
+SIZE (fox-1.7.48.tar.gz) = 5334145
diff --git a/x11-toolkits/fox17/files/patch-include_FXParallel.h b/x11-toolkits/fox17/files/patch-include_FXParallel.h
new file mode 100644
index 000000000000..002f83348d9a
--- /dev/null
+++ b/x11-toolkits/fox17/files/patch-include_FXParallel.h
@@ -0,0 +1,11 @@
+--- include/FXParallel.h.orig 2014-07-15 12:35:48.000000000 +0200
++++ include/FXParallel.h 2014-07-15 12:35:18.000000000 +0200
+@@ -287,7 +287,7 @@
+ const FXuval size((sizeof(FXParallelLoopFunctor<Functor,Index>)+sizeof(FXulong)-1)/sizeof(FXulong));
+ if(fm<to){
+ FXTaskGroup group(pool);
+- FXlong space[128*size];
++ FXlong space[128*(sizeof(FXParallelLoopFunctor<Functor,Index>)+sizeof(FXulong)-1)/sizeof(FXulong)];
+ Index nits=1+(to-fm-1)/by,ni,c;
+ if(nc>128) nc=128;
+ if(nc>nits) nc=nits;