aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-01-02 22:09:42 +0800
committerrakuco <rakuco@FreeBSD.org>2015-01-02 22:09:42 +0800
commit6934f49d4c0a8659cd09a148f6c1d4a457ccfb8f (patch)
tree0d348b4cd5e76f6087cd22630052349b6ba724f6 /x11-toolkits
parent4443f5642b7245c21fbbd59730eb7b63f07218dd (diff)
downloadfreebsd-ports-gnome-6934f49d4c0a8659cd09a148f6c1d4a457ccfb8f.tar.gz
freebsd-ports-gnome-6934f49d4c0a8659cd09a148f6c1d4a457ccfb8f.tar.zst
freebsd-ports-gnome-6934f49d4c0a8659cd09a148f6c1d4a457ccfb8f.zip
Add patch (committed upstream) to make the port build with CMake 3.1.0.
Also tested with CMake 3.0.2. The patch itself contains an explanation of what is being changed and why. There is no need to bump PORTREVISION as there are no functional changes.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/vtkfox/files/patch-CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-toolkits/vtkfox/files/patch-CMakeLists.txt b/x11-toolkits/vtkfox/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..60366c8ee66b
--- /dev/null
+++ b/x11-toolkits/vtkfox/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+commit 1d2853c1ec4a1375d011b295c210e5220c1fda90
+Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Fri Jan 2 12:05:39 2015 +0200
+
+ Make vtkfox compatible with CMake 3.1.0.
+
+ Use VTK_USE_FILE instead of USE_VTK_FILE. The latter had been deprecated
+ for 12 years and was only present in CMake's FindVTK.cmake, which was
+ removed in 3.1.0 because VTK ships its own Config.cmake file with all
+ the required variables.
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -8,7 +8,7 @@ SET (VTKFOX_VERSION 1.0.0)
+ # VTK
+ #
+ FIND_PACKAGE(VTK REQUIRED)
+-INCLUDE(${USE_VTK_FILE})
++INCLUDE(${VTK_USE_FILE})
+
+ #
+ # FOX version to use