aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-06-17 21:44:51 +0800
committerrakuco <rakuco@FreeBSD.org>2017-06-17 21:44:51 +0800
commita2880768945f05bbf59562f04f686051be7e8815 (patch)
treed722a6757db1136f92f82f7b7d4e4d968a16b536 /x11-toolkits
parentcc481717d1735ea8e83dbb2e13c938361009a1e4 (diff)
downloadfreebsd-ports-gnome-a2880768945f05bbf59562f04f686051be7e8815.tar.gz
freebsd-ports-gnome-a2880768945f05bbf59562f04f686051be7e8815.tar.zst
freebsd-ports-gnome-a2880768945f05bbf59562f04f686051be7e8815.zip
Update the Calligra ports to 3.0.1.
The 3.x series is based on KDE Frameworks 5, and some programs have been split into separate ports: - Sheets, Words & co are in editors/calligra. - Krita is in graphics/krita. - Kexi is in databases/kexi. - The calligra-l10n* ports are now part of editors/calligra itself. Okular support in editors/calligra and Marble support in textproc/kreport have been disabled for now because they need the KF5 version of those ports. Thanks to everyone who's tested it and worked on it in our area51 repository. Submitted by: Adrian de Groot <groot@kde.org>, tcberner, rakuco Reviewed by: rakuco, mat (earlier versions) Differential Revision: https://reviews.freebsd.org/D10167
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/kproperty/Makefile19
-rw-r--r--x11-toolkits/kproperty/distinfo3
-rw-r--r--x11-toolkits/kproperty/pkg-descr7
-rw-r--r--x11-toolkits/kproperty/pkg-plist94
5 files changed, 124 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 58dfa139e9cf..d77e78f94341 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -93,6 +93,7 @@
SUBDIR += kf5-kxmlgui
SUBDIR += kirigami
SUBDIR += kirigami2
+ SUBDIR += kproperty
SUBDIR += lesstif
SUBDIR += libXaw
SUBDIR += libXmu
diff --git a/x11-toolkits/kproperty/Makefile b/x11-toolkits/kproperty/Makefile
new file mode 100644
index 000000000000..008ff8367ecd
--- /dev/null
+++ b/x11-toolkits/kproperty/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= kproperty
+PORTVERSION= 3.0.0
+CATEGORIES= x11-toolkits kde
+MASTER_SITES= KDE/stable/${PORTNAME}/src
+DIST_SUBDIR= KDE/${PORTNAME}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Property editing framwork
+
+USES= cmake:outsource gettext kde:5 tar:xz
+USE_KDE= ecm config coreaddons guiaddons i18n widgetsaddons
+USE_QT5= core gui widgets xml \
+ buildtools_build qmake_build qml
+
+CONFLICTS_INSTALL= calligra-2*
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/kproperty/distinfo b/x11-toolkits/kproperty/distinfo
new file mode 100644
index 000000000000..1df395012938
--- /dev/null
+++ b/x11-toolkits/kproperty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481142955
+SHA256 (KDE/kproperty/kproperty-3.0.0.tar.xz) = 86cd24007d6b313a0217e4a0a7e4b594f46b3fc2d2d4aee2db1d14fdf16b0e99
+SIZE (KDE/kproperty/kproperty-3.0.0.tar.xz) = 98484
diff --git a/x11-toolkits/kproperty/pkg-descr b/x11-toolkits/kproperty/pkg-descr
new file mode 100644
index 000000000000..c577365248d5
--- /dev/null
+++ b/x11-toolkits/kproperty/pkg-descr
@@ -0,0 +1,7 @@
+A property editing framework with editor widget similar to what is known
+from Qt Designer.
+
+It is useful in applications such as IDEs where large amounts of properties
+are available for the user to edit.
+
+WWW: http://www.kexi-project.org/
diff --git a/x11-toolkits/kproperty/pkg-plist b/x11-toolkits/kproperty/pkg-plist
new file mode 100644
index 000000000000..a77902d64b87
--- /dev/null
+++ b/x11-toolkits/kproperty/pkg-plist
@@ -0,0 +1,94 @@
+include/KPropertyCore3/KProperty
+include/KPropertyCore3/KProperty.h
+include/KPropertyCore3/KPropertyFactory
+include/KPropertyCore3/KPropertyFactory.h
+include/KPropertyCore3/KPropertySet
+include/KPropertyCore3/KPropertySet.h
+include/KPropertyCore3/config-kproperty.h
+include/KPropertyCore3/kproperty_version.h
+include/KPropertyCore3/kpropertycore_export.h
+include/KPropertyWidgets3/BoolEdit
+include/KPropertyWidgets3/ColorEdit
+include/KPropertyWidgets3/ComboBox
+include/KPropertyWidgets3/CursorEdit
+include/KPropertyWidgets3/DateEdit
+include/KPropertyWidgets3/DateTimeEdit
+include/KPropertyWidgets3/FontEdit
+include/KPropertyWidgets3/KPropertyEditorView
+include/KPropertyWidgets3/KPropertyEditorView.h
+include/KPropertyWidgets3/KPropertyGenericSelectionEditor
+include/KPropertyWidgets3/KPropertyGenericSelectionEditor.h
+include/KPropertyWidgets3/KPropertyStringEditor
+include/KPropertyWidgets3/KPropertyStringEditor.h
+include/KPropertyWidgets3/KPropertyUrlEditor
+include/KPropertyWidgets3/KPropertyUrlEditor.h
+include/KPropertyWidgets3/KPropertyUtils
+include/KPropertyWidgets3/KPropertyUtils.h
+include/KPropertyWidgets3/KPropertyWidgetsFactory
+include/KPropertyWidgets3/KPropertyWidgetsFactory.h
+include/KPropertyWidgets3/KPropertyWidgetsPluginManager
+include/KPropertyWidgets3/KPropertyWidgetsPluginManager.h
+include/KPropertyWidgets3/LineStyleEdit
+include/KPropertyWidgets3/PixmapEdit
+include/KPropertyWidgets3/PointEdit
+include/KPropertyWidgets3/RectEdit
+include/KPropertyWidgets3/SizeEdit
+include/KPropertyWidgets3/SizePolicyEdit
+include/KPropertyWidgets3/SpinBox
+include/KPropertyWidgets3/TimeEdit
+include/KPropertyWidgets3/Utils
+include/KPropertyWidgets3/booledit.h
+include/KPropertyWidgets3/coloredit.h
+include/KPropertyWidgets3/combobox.h
+include/KPropertyWidgets3/cursoredit.h
+include/KPropertyWidgets3/dateedit.h
+include/KPropertyWidgets3/datetimeedit.h
+include/KPropertyWidgets3/fontedit.h
+include/KPropertyWidgets3/kpropertywidgets_export.h
+include/KPropertyWidgets3/linestyleedit.h
+include/KPropertyWidgets3/pixmapedit.h
+include/KPropertyWidgets3/pointedit.h
+include/KPropertyWidgets3/rectedit.h
+include/KPropertyWidgets3/sizeedit.h
+include/KPropertyWidgets3/sizepolicyedit.h
+include/KPropertyWidgets3/spinbox.h
+include/KPropertyWidgets3/timeedit.h
+include/KPropertyWidgets3/utils.h
+lib/cmake/KPropertyCore3/KPropertyCoreConfig.cmake
+lib/cmake/KPropertyCore3/KPropertyCoreConfigVersion.cmake
+lib/cmake/KPropertyCore3/KPropertyCoreTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KPropertyCore3/KPropertyCoreTargets.cmake
+lib/cmake/KPropertyWidgets3/KPropertyWidgetsConfig.cmake
+lib/cmake/KPropertyWidgets3/KPropertyWidgetsConfigVersion.cmake
+lib/cmake/KPropertyWidgets3/KPropertyWidgetsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KPropertyWidgets3/KPropertyWidgetsTargets.cmake
+lib/libKPropertyCore3.so
+lib/libKPropertyCore3.so.3
+lib/libKPropertyCore3.so.3.0
+lib/libKPropertyWidgets3.so
+lib/libKPropertyWidgets3.so.3
+lib/libKPropertyWidgets3.so.3.0
+libdata/pkgconfig/KPropertyCore3.pc
+libdata/pkgconfig/KPropertyWidgets3.pc
+share/kpropertywidgets3/icons/kproperty_breeze.rcc
+share/locale/ast/LC_MESSAGES/kproperty_qt.mo
+share/locale/ca/LC_MESSAGES/kproperty_qt.mo
+share/locale/ca@valencia/LC_MESSAGES/kproperty_qt.mo
+share/locale/cs/LC_MESSAGES/kproperty_qt.mo
+share/locale/de/LC_MESSAGES/kproperty_qt.mo
+share/locale/en_GB/LC_MESSAGES/kproperty_qt.mo
+share/locale/es/LC_MESSAGES/kproperty_qt.mo
+share/locale/fi/LC_MESSAGES/kproperty_qt.mo
+share/locale/gl/LC_MESSAGES/kproperty_qt.mo
+share/locale/ja/LC_MESSAGES/kproperty_qt.mo
+share/locale/lt/LC_MESSAGES/kproperty_qt.mo
+share/locale/nl/LC_MESSAGES/kproperty_qt.mo
+share/locale/pl/LC_MESSAGES/kproperty_qt.mo
+share/locale/pt/LC_MESSAGES/kproperty_qt.mo
+share/locale/pt_BR/LC_MESSAGES/kproperty_qt.mo
+share/locale/ru/LC_MESSAGES/kproperty_qt.mo
+share/locale/sk/LC_MESSAGES/kproperty_qt.mo
+share/locale/sv/LC_MESSAGES/kproperty_qt.mo
+share/locale/tr/LC_MESSAGES/kproperty_qt.mo
+share/locale/uk/LC_MESSAGES/kproperty_qt.mo
+share/locale/zh_CN/LC_MESSAGES/kproperty_qt.mo