aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /x11-toolkits
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Xaw3d/Makefile1
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/Makefile1
-rw-r--r--x11-toolkits/tk86/Makefile1
-rw-r--r--x11-toolkits/wxgtk29/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 21348ef17350..76994652ab81 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -14,6 +14,7 @@ COMMENT= A 3-D Athena Widget set that looks like Motif
LICENSE= MIT
WRKSRC= ${WRKDIR}/xc/lib/Xaw3d
+USE_GCC= any
USE_IMAKE= yes
USE_XORG= x11 xext xmu xt sm ice xpm
USE_LDCONFIG= yes
diff --git a/x11-toolkits/p5-Alien-wxWidgets/Makefile b/x11-toolkits/p5-Alien-wxWidgets/Makefile
index a6d7236a3732..99bd99d7b26b 100644
--- a/x11-toolkits/p5-Alien-wxWidgets/Makefile
+++ b/x11-toolkits/p5-Alien-wxWidgets/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= p5-ExtUtils-CBuilder>=0:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
OPTIONS= UNICODE "Build with Unicode support" on
+USE_GCC= any
USE_WX= 2.6+
WX_COMPS= wx contrib
PERL_MODBUILD= yes
diff --git a/x11-toolkits/tk86/Makefile b/x11-toolkits/tk86/Makefile
index 8913527849c8..bbfc12df8d1f 100644
--- a/x11-toolkits/tk86/Makefile
+++ b/x11-toolkits/tk86/Makefile
@@ -15,6 +15,7 @@ LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/../license.terms
LATEST_LINK?= tk86
+USE_GCC= any
USE_XORG= x11
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}/unix
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index dbfe41c5ff42..f1dce9e1f18f 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
USE_BZIP2= yes
+USE_GCC= any
USE_XORG= x11 sm xxf86vm xinerama
USE_GL= glu
USE_GMAKE= yes