aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-09-03 10:38:12 +0800
committerbland <bland@FreeBSD.org>2005-09-03 10:38:12 +0800
commit1cdcabdb51edd3fc13836ce0d46db621a7fcd934 (patch)
treef77e367a6f3255a3ba3d62a39c5317148bb059a9 /x11-toolkits
parent756f0e0883dba70b6be57bdb1378a7fb07817139 (diff)
downloadfreebsd-ports-gnome-1cdcabdb51edd3fc13836ce0d46db621a7fcd934.tar.gz
freebsd-ports-gnome-1cdcabdb51edd3fc13836ce0d46db621a7fcd934.tar.zst
freebsd-ports-gnome-1cdcabdb51edd3fc13836ce0d46db621a7fcd934.zip
Unbreak 4-STABLE build (gcc 2.95.x does not know anything about SSE2).
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile3
-rw-r--r--x11-toolkits/gtk30/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index a02f9ce8f997..3001ebcaaaad 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -78,7 +78,8 @@ STRIP=
# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
# for detail.
-.if ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) && ${CC} != "icc"
+.if ${OSVERSION} >= 500000 && ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) \
+ && ${CC} != "icc"
CFLAGS+= -mno-sse2
.endif
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index a02f9ce8f997..3001ebcaaaad 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -78,7 +78,8 @@ STRIP=
# is being use in CPUTYPE that enable SSE2 will causing Java with GTK2 and
# Mono/gtk-sharp crash. Disable SSE2 to solve the crash and see ports/72014
# for detail.
-.if ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) && ${CC} != "icc"
+.if ${OSVERSION} >= 500000 && ( ${ARCH} == "i386" || ${ARCH} == "amd64" ) \
+ && ${CC} != "icc"
CFLAGS+= -mno-sse2
.endif