aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-02-14 04:10:24 +0800
committermiwi <miwi@FreeBSD.org>2010-02-14 04:10:24 +0800
commitab9437db64e13e285034e283c230ebe89580d4fa (patch)
tree20915ddb8150bffaf3c186beca1628aa78371605 /x11-toolkits
parent18d874273b6b600668d1bc514da7ed5a008d4094 (diff)
downloadfreebsd-ports-gnome-ab9437db64e13e285034e283c230ebe89580d4fa.tar.gz
freebsd-ports-gnome-ab9437db64e13e285034e283c230ebe89580d4fa.tar.zst
freebsd-ports-gnome-ab9437db64e13e285034e283c230ebe89580d4fa.zip
- Unbreak with qt 4.6.X
- Update to 2.0 PR: 143081 Submitted by: fluffy Approved by: maintainer timeout
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt4pas/Makefile20
-rw-r--r--x11-toolkits/qt4pas/distinfo6
-rw-r--r--x11-toolkits/qt4pas/files/patch-compile_lib.sh33
-rw-r--r--x11-toolkits/qt4pas/pkg-plist6
4 files changed, 13 insertions, 52 deletions
diff --git a/x11-toolkits/qt4pas/Makefile b/x11-toolkits/qt4pas/Makefile
index 87e5bc702254..8d0849d3a743 100644
--- a/x11-toolkits/qt4pas/Makefile
+++ b/x11-toolkits/qt4pas/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qt4pas
-PORTVERSION= 1.70
+PORTVERSION= 2.0
CATEGORIES= x11-toolkits
MASTER_SITES= http://users.telenet.be/Jan.Van.hijfte/qtforfpc/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/^/V/}_Qt${QT4_VER_MIN}
@@ -16,9 +16,10 @@ COMMENT= Qt4 binding for FreePascal
USE_LDCONFIG= yes
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network script webkit
+QT_COMPONENTS= corelib gui network script webkit qmake_build \
+ moc_build
-QT4_VER_MIN= 4.5.0
+QT4_VER_MIN= 4.5.3
.include <bsd.port.pre.mk>
@@ -26,16 +27,7 @@ QT4_VER_MIN= 4.5.0
IGNORE= Please update your current qt4 version to ${QT4_VER_MIN}
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|%%QT_INCDIR%%|${QT_INCDIR}|' -e 's|%%QT_LIBDIR%%|${QT_LIBDIR}|g' -e \
- 's|%%CXX%%|${CXX}|g' -e 's|%%STRIP_CMD%%|${STRIP_CMD}|g' -e 's|bash|sh|g' ${WRKSRC}/compile_lib.sh
-
-do-build:
- @cd ${WRKSRC} && \
- ${SH} compile_lib.sh
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/qt4
- ${INSTALL_PROGRAM} ${WRKSRC}/libqt4intf.so ${PREFIX}/lib/qt4
+pre-build:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt4pas/distinfo b/x11-toolkits/qt4pas/distinfo
index 36ce2e0929b2..519d622c19b5 100644
--- a/x11-toolkits/qt4pas/distinfo
+++ b/x11-toolkits/qt4pas/distinfo
@@ -1,3 +1,3 @@
-MD5 (qt4pas-V1.70_Qt4.5.0.tar.gz) = 1b44cd72a6c226524a54afe93b68ecb8
-SHA256 (qt4pas-V1.70_Qt4.5.0.tar.gz) = d20c6cf48b854074a5449e621aaf1f3fde7d38f13abb945887ef9b642fcbd01e
-SIZE (qt4pas-V1.70_Qt4.5.0.tar.gz) = 403932
+MD5 (qt4pas-V2.0_Qt4.5.3.tar.gz) = 56afc2d3e4088c27fbffbc08b2e3862c
+SHA256 (qt4pas-V2.0_Qt4.5.3.tar.gz) = 06486792523ea01b89a3985f844015a93a353719c85e700e5c56d3504ac8a428
+SIZE (qt4pas-V2.0_Qt4.5.3.tar.gz) = 347301
diff --git a/x11-toolkits/qt4pas/files/patch-compile_lib.sh b/x11-toolkits/qt4pas/files/patch-compile_lib.sh
deleted file mode 100644
index 52aaa983ff5a..000000000000
--- a/x11-toolkits/qt4pas/files/patch-compile_lib.sh
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./compile_lib.sh.orig 2009-04-20 17:59:59.000000000 +0400
-+++ ./compile_lib.sh 2009-07-12 15:18:58.000000000 +0400
-@@ -1,4 +1,4 @@
--#!/bin/env bash
-+#!/bin/env sh
- # get latest from http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html
- # for more info, you can visit the links on above page to FreePascal and Lazarus wiki
-
-@@ -7,18 +7,16 @@
- # do configure and gmake in that Qt4 dir
-
- NAME=libqt4intf.so
--QTDIR=../qt-all-opensource-src-4.5.0
--INCLUDE_PATH="-I. -I$QTDIR/include -I$QTDIR/include/Qt -I$QTDIR/include/QtGui -I$QTDIR/include/QtCore -Iqlcl "
--LIB_PATH=$QTDIR/lib
--export LD_LIBRARY_PATH=$LIB_PATH
-+QTDIR=%%QT_INCDIR%%
-+INCLUDE_PATH="-I. -I$QTDIR -I$QTDIR/Qt -I$QTDIR/QtGui -I$QTDIR/QtCore -Iqlcl "
-+LIB_PATH=%%QT_LIBDIR%%
-+
- if [ -e "$LIB_PATH/libQtCore.so.4" ]
- then
- echo please wait for compile to finish ...
-- g++ -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -lQtNetwork -lQtWebKit -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
-- echo Showing used Qt libraries when LD_LIBRARY_PATH=$LD_LIBRARY_PATH
-- ldd $NAME | grep libQt
-+ %%CXX%% -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -lQtNetwork -lQtWebKit -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
- echo stripping library
-- strip --strip-all $NAME
-+ %%STRIP_CMD%% --strip-all $NAME
- echo Done
- else
- echo "Please Modify location of Qt4 in this script"
diff --git a/x11-toolkits/qt4pas/pkg-plist b/x11-toolkits/qt4pas/pkg-plist
index a8bb3299eddf..aa01718d22f1 100644
--- a/x11-toolkits/qt4pas/pkg-plist
+++ b/x11-toolkits/qt4pas/pkg-plist
@@ -1,2 +1,4 @@
-lib/qt4/libqt4intf.so
-@dirrmtry lib/qt4
+lib/qt4/libQt4Pas.so
+lib/qt4/libQt4Pas.so.5
+lib/qt4/libQt4Pas.so.5.2
+lib/qt4/libQt4Pas.so.5.2.0