aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/afterstep-stable/files
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2006-08-02 02:27:53 +0800
committerglewis <glewis@FreeBSD.org>2006-08-02 02:27:53 +0800
commit1dcbb5881654ac6b91703492d8f49de1f5fe9d10 (patch)
tree5268c21192afdd784b54e4b516d08acb0c911a7c /x11-wm/afterstep-stable/files
parented8ab36599cc4c549536b01151fba06b099a8984 (diff)
downloadfreebsd-ports-gnome-1dcbb5881654ac6b91703492d8f49de1f5fe9d10.tar.gz
freebsd-ports-gnome-1dcbb5881654ac6b91703492d8f49de1f5fe9d10.tar.zst
freebsd-ports-gnome-1dcbb5881654ac6b91703492d8f49de1f5fe9d10.zip
. Update to 2.2.2.
. Use ${REINPLACE} rather than ${PERL}. This isn't based on the changes in PR 100705. Extra changes present there will be incorporated in the near future.
Diffstat (limited to 'x11-wm/afterstep-stable/files')
-rw-r--r--x11-wm/afterstep-stable/files/patch-configure35
-rw-r--r--x11-wm/afterstep-stable/files/patch-configure.h.in30
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterBase::configure13
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterBase::parse.c13
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterConf::Makefile.in13
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage::configure16
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterStep::kde.c15
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterStep::parser.c14
-rw-r--r--x11-wm/afterstep-stable/files/patch-src::ASDocGen::Makefile.in34
-rw-r--r--x11-wm/afterstep-stable/files/patch-src::WinCommand::WinCommand.c20
10 files changed, 173 insertions, 30 deletions
diff --git a/x11-wm/afterstep-stable/files/patch-configure b/x11-wm/afterstep-stable/files/patch-configure
index e37779b740eb..8f4d3f154c1b 100644
--- a/x11-wm/afterstep-stable/files/patch-configure
+++ b/x11-wm/afterstep-stable/files/patch-configure
@@ -1,8 +1,8 @@
$FreeBSD$
---- configure.orig Mon Sep 13 11:43:06 2004
-+++ configure Mon Sep 13 11:43:30 2004
-@@ -1734,7 +1734,7 @@
+--- configure Sat Jun 24 21:55:24 2006
++++ configure.orig Sat Jun 24 21:54:41 2006
+@@ -1811,7 +1811,7 @@
# Check whether --enable-reuse-font or --disable-reuse-font was given.
if test "${enable_reuse_font+set}" = set; then
enableval="$enable_reuse_font"
@@ -11,7 +11,7 @@ $FreeBSD$
cat >>confdefs.h <<\_ACEOF
#define MODULE_REUSE_LOADED_FONT 1
_ACEOF
-@@ -5450,7 +5450,7 @@
+@@ -5830,7 +5830,7 @@
have_shmimage=no
@@ -20,3 +20,30 @@ $FreeBSD$
enable_shmimage=no
fi
+@@ -7955,7 +7955,7 @@
+ fi
+
+ if test "x$enable_staticlibs" = "xyes"; then
+- AFTERBASE_LIB="../../libAfterBase/libAfterBase.a"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a %%LOCALBASE%%/lib/libexecinfo.a"
+ AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.a"
+ AFTERSTEP_LIB="../../libAfterStep/libAfterStep.a"
+ AFTERCONF_LIB="../../libAfterConf/libAfterConf.a"
+@@ -7974,7 +7974,7 @@
+ LIBPROG='$(LIB_SHARED_CYG)'
+ LIBINSTALL="install.cyg"
+ else
+- AFTERBASE_LIB="../../libAfterBase/libAfterBase.so"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so %%LOCALBASE%%/lib/libexecinfo.a"
+ AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.so"
+ AFTERSTEP_LIB="../../libAfterStep/libAfterStep.so"
+ AFTERCONF_LIB="../../libAfterConf/libAfterConf.so"
+@@ -7985,7 +7985,7 @@
+ fi
+ fi
+
+-AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a"
++AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a %%LOCALBASE%%/lib/libexecinfo.a"
+ AFTERIMAGE_STATIC_LIB="../../libAfterImage/libAfterImage.a"
+ AFTERSTEP_STATIC_LIB="../../libAfterStep/libAfterStep.a"
+ AFTERCONF_STATIC_LIB="../../libAfterConf/libAfterConf.a"
diff --git a/x11-wm/afterstep-stable/files/patch-configure.h.in b/x11-wm/afterstep-stable/files/patch-configure.h.in
index 4f3821e4bd38..969d72780e97 100644
--- a/x11-wm/afterstep-stable/files/patch-configure.h.in
+++ b/x11-wm/afterstep-stable/files/patch-configure.h.in
@@ -1,17 +1,17 @@
$FreeBSD$
-*** configure.h.in.orig Fri Jul 30 23:51:22 2004
---- configure.h.in Fri Jul 30 23:51:27 2004
-***************
-*** 1,10 ****
- #include "config.h"
-
-- #ifdef __FreeBSD__
-- #include <sys/syslimits.h>
-- #else
- #include <limits.h>
-- #endif
-
- /* we don't do interhost network communications ! WE use Unix domain sockets! */
- #define SAME_HOST
---- 1,6 ----
+--- configure.h.in.orig Thu Jun 22 10:44:12 2006
++++ configure.h.in Thu Jun 22 10:44:26 2006
+@@ -2,12 +2,7 @@
+
+ #define AFTERSTEP_INTERNALS
+
+-#ifdef __FreeBSD__
+-#include <sys/cdefs.h>
+-#include <sys/syslimits.h>
+-#else
+ #include <limits.h>
+-#endif
+
+ /* we don't do interhost network communications ! WE use Unix domain sockets! */
+ #define SAME_HOST
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterBase::configure b/x11-wm/afterstep-stable/files/patch-libAfterBase::configure
new file mode 100644
index 000000000000..a02d7789fff9
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterBase::configure
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- libAfterBase/configure.orig Tue May 23 10:59:30 2006
++++ libAfterBase/configure Thu Jun 22 15:09:25 2006
+@@ -6379,6 +6379,8 @@
+
+
+
++execinfo_libs="-L%%LOCALBASE%%/lib -lexecinfo"
++LIBS="$execinfo_libs $LIBS"
+ for ac_func in backtrace_symbols
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterBase::parse.c b/x11-wm/afterstep-stable/files/patch-libAfterBase::parse.c
new file mode 100644
index 000000000000..71dda047d81f
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterBase::parse.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- libAfterBase/parse.c.orig Thu Jun 22 11:14:06 2006
++++ libAfterBase/parse.c Thu Jun 22 11:17:46 2006
+@@ -690,7 +690,7 @@
+ char *
+ tokenskip( const char *ptr, unsigned int n_tokens )
+ {
+- int tok_no = 0 ; ;
++ int tok_no = 0 ;
+ register int curr = 0 ;
+
+ if( ptr == NULL ) return NULL ;
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterConf::Makefile.in b/x11-wm/afterstep-stable/files/patch-libAfterConf::Makefile.in
new file mode 100644
index 000000000000..0ca064885f5f
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterConf::Makefile.in
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- libAfterConf/Makefile.in.orig Sat Jun 24 22:04:08 2006
++++ libAfterConf/Makefile.in Sat Jun 24 22:04:21 2006
+@@ -3,7 +3,7 @@
+ #
+
+ LIBS_PRIVATE = ../libAfterConf/libAfterConf.a ../libAfterStep/libAfterStep.a\
+- ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a
++ ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a -L%%LOCALBASE%%/lib -lexecinfo
+
+ LIB_INCS= afterconf.h
+
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage::configure b/x11-wm/afterstep-stable/files/patch-libAfterImage::configure
new file mode 100644
index 000000000000..206a2d058200
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterImage::configure
@@ -0,0 +1,16 @@
+$FreeBSD$
+
+--- libAfterImage/configure.orig Thu Jun 22 21:27:08 2006
++++ libAfterImage/configure Thu Jun 22 21:27:53 2006
+@@ -8443,9 +8443,9 @@
+ HAVE_AFTERBASE_FLAG=1
+ AFTERBASE_C=
+ if test "x$have_x" != "xyes" -a "x$have_gif" = "xyes"; then
+- AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase"
++ AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase -L%%LOCALBASE%%/lib -lexecinfo"
+ else
+- AFTERIMAGE_LIBS="-lAfterBase $AFTERIMAGE_LIBS"
++ AFTERIMAGE_LIBS="-lAfterBase -L%%LOCALBASE%%/lib -lexecinfo $AFTERIMAGE_LIBS"
+ fi
+ if test -r "../libAfterBase/astypes.h"; then
+ AFTERIMAGE_APPS_LIBS="-L../ -L../../libAfterBase -lAfterImage $AFTERIMAGE_LIBS"
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterStep::kde.c b/x11-wm/afterstep-stable/files/patch-libAfterStep::kde.c
new file mode 100644
index 000000000000..bdd2ef6c392d
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterStep::kde.c
@@ -0,0 +1,15 @@
+$FreeBSD$
+
+--- libAfterStep/kde.c.orig Thu Jun 22 21:30:40 2006
++++ libAfterStep/kde.c Thu Jun 22 21:31:14 2006
+@@ -115,8 +115,9 @@
+ {
+ if( (tag = make_kde_config_comment_tag()) != NULL )
+ {
++ size_t len;
+ ++i ;
+- int len = strlen( &buffer[i] ) ;
++ len = strlen( &buffer[i] ) ;
+ while( len > 0 && isspace( buffer[i+len-1] ) ) --len ;
+ if( len > 0 )
+ {
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterStep::parser.c b/x11-wm/afterstep-stable/files/patch-libAfterStep::parser.c
new file mode 100644
index 000000000000..8fd20f0fb0f9
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterStep::parser.c
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- libAfterStep/parser.c.orig Thu Jun 22 21:33:08 2006
++++ libAfterStep/parser.c Thu Jun 22 21:33:46 2006
+@@ -771,8 +771,8 @@
+ {
+ while (GetNextStatement (config, ignore_foreign))
+ { /* untill not end of text */
+- flags = 0x00;
+ TermDef *pterm = NULL ;
++ flags = 0x00;
+
+ #ifdef DEBUG_PARSER
+ fprintf (stderr, "\nSentence Found:[%.50s ...]\n,\tData=\t[%s]", config->tline, config->current_data);
diff --git a/x11-wm/afterstep-stable/files/patch-src::ASDocGen::Makefile.in b/x11-wm/afterstep-stable/files/patch-src::ASDocGen::Makefile.in
index d93c1a08a6d3..546d86e36f53 100644
--- a/x11-wm/afterstep-stable/files/patch-src::ASDocGen::Makefile.in
+++ b/x11-wm/afterstep-stable/files/patch-src::ASDocGen::Makefile.in
@@ -1,19 +1,31 @@
---- src/ASDocGen/Makefile.in.orig Wed Sep 15 07:55:46 2004
-+++ src/ASDocGen/Makefile.in Wed Sep 29 18:17:40 2004
-@@ -43,12 +43,12 @@
- echo $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_DIR)/$$page_name.1x; \
- $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_DIR)/$$page_name.1x; \
- done; echo "Done"; \
-- cd API; echo "Installing API man pages ..." ; \
+$FreeBSD$
+
+--- src/ASDocGen/Makefile.in.orig Tue Dec 13 14:48:33 2005
++++ src/ASDocGen/Makefile.in Mon Jun 26 08:53:46 2006
+@@ -50,19 +50,19 @@
+
+ install.man: $(PROG)
+ @cd man; echo "Installing application man pages using command - " ; \
+- echo " \"$(INSTALL_DATA) <name>.man $(AFTER_MAN_DIR)/html/<name>.1x\""; \
++ echo " \"$(INSTALL_DATA) <name>.man $(AFTER_MAN_DIR)/<name>.1x\""; \
+ for f in `ls *.man`; do \
+ page_name=`echo $$f| awk -F . '{print $$1}'`; \
+ echo -n "$$f "; \
+- $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_DIR)/$$page_name.1x; \
+- done; echo "Done"; \
+- cd API; echo "Installing API man pages using command - " ; \
+- echo " \"$(INSTALL_DATA) <name>.man $(AFTER_MAN_API_DIR)/html/<name>.3x\""; \
- for f in `ls *.man`; do \
- page_name=`echo $$f| awk -F . '{print $$1}'`; \
-- echo $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_API_DIR)/$$page_name.3x; \
+- echo -n "$$f "; \
- $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_API_DIR)/$$page_name.3x; \
-- done; echo "Done"; \
-+# cd API; echo "Installing API man pages ..." ; \
++ $(INSTALL_DATA) "$$page_name.man" $(AFTER_MAN_DIR)/$$page_name.1x; \
+ done; echo "Done"; \
++# cd API; echo "Installing API man pages using command - " ; \
++# echo " \"$(INSTALL_DATA) <name>.man $(AFTER_MAN_API_DIR)/html/<name>.3x\""; \
+# for f in `ls *.man`; do \
+# page_name=`echo $$f| awk -F . '{print $$1}'`; \
-+# echo $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_API_DIR)/$$page_name.3x; \
++# echo -n "$$f "; \
+# $(INSTALL_DATA) $$page_name.man $(AFTER_MAN_API_DIR)/$$page_name.3x; \
+# done; echo "Done"; \
cd ../..
diff --git a/x11-wm/afterstep-stable/files/patch-src::WinCommand::WinCommand.c b/x11-wm/afterstep-stable/files/patch-src::WinCommand::WinCommand.c
new file mode 100644
index 000000000000..1494b600b66f
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-src::WinCommand::WinCommand.c
@@ -0,0 +1,20 @@
+$FreeBSD$
+
+--- src/WinCommand/WinCommand.c.orig Sat Jun 24 22:08:22 2006
++++ src/WinCommand/WinCommand.c Sat Jun 24 22:09:07 2006
+@@ -307,12 +307,13 @@
+ ASBiDirElem *curr;
+ char *command;
+ action_t *a;
+- ASWinCommandState WinCommandState ;
++ ASWinCommandState WinCommandState ;
++ ASBiDirList *operations;
+
+ InitMyApp (CLASS_WINCOMMAND, argc, argv, NULL, NULL, OPTION_SINGLE|OPTION_RESTART );
+ ConnectX( ASDefaultScr, 0 );
+
+- ASBiDirList *operations = create_asbidirlist( NULL );
++ operations = create_asbidirlist( NULL );
+
+ /* Initialize State */
+ memset( &WinCommandState, 0x00, sizeof(WinCommandState));