aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-30 00:17:47 +0800
committeradamw <adamw@FreeBSD.org>2014-07-30 00:17:47 +0800
commit6f3db87c43941a697f3177d2fdfd3e171510f1e6 (patch)
tree9040baa23b5520d316d81c13553593f60eb5d625 /x11-wm/afterstep
parent0884bab4a549508c3a35612e3ad2b7933d694e39 (diff)
downloadfreebsd-ports-gnome-6f3db87c43941a697f3177d2fdfd3e171510f1e6.tar.gz
freebsd-ports-gnome-6f3db87c43941a697f3177d2fdfd3e171510f1e6.tar.zst
freebsd-ports-gnome-6f3db87c43941a697f3177d2fdfd3e171510f1e6.zip
Use OPTIONS instead of WITH_*
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index d4d94a39fd0a..9bd18f22eb90 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -31,6 +31,11 @@ SRCDIRS= afterstep \
modules/Banner modules/Pager modules/Wharf \
modules/Wharf/ASSound
+OPTIONS_DEFINE= HICOLOR_ICONS
+HICOLOR_ICONS_DESC= Use hi-color icons
+
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} \
-e 's|%%PREFIX%%|${PREFIX}|g' \
@@ -43,7 +48,7 @@ post-patch:
done
pre-build:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles
+ @ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${SH} MakeMakefiles)
post-install:
@ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/backgrounds/
@@ -51,15 +56,10 @@ post-install:
@ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/afterstep/sounds/
${INSTALL_DATA} ${WRKSRC}/sounds/* ${STAGEDIR}${PREFIX}/lib/X11/afterstep/sounds/
@ ${MKDIR} ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
-.if defined(WITH_HICOLOR_ICONS)
+.if ${PORT_OPTIONS:MHICOLOR_ICONS}
${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
${INSTALL_DATA} ${FILESDIR}/monitor_bsd.xpm ${STAGEDIR}${PREFIX}/include/X11/pixmaps/
.else
-.if !defined(BATCH)
- @${ECHO_MSG} "===> Note: to use the hi-color icons,"
- @${ECHO_MSG} " reinstall this port with -DWITH_HICOLOR_ICONS"
- @${ECHO_MSG} " defined"
-.endif
@for i in AFstep.xpm penguin.xpm monitor_bsd.xpm; do \
${CP} ${FILESDIR}/$$i ${WRKSRC}/icons/8bit/; \
done