aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/antiwm
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-06-24 21:17:43 +0800
committerdhn <dhn@FreeBSD.org>2011-06-24 21:17:43 +0800
commit9672ec1d0930891a2a22d7f35e2dedfd4cac308e (patch)
treee5bda5aa7af88deb8e70238609a771bf41118d02 /x11-wm/antiwm
parent6130e7e9f6ac311dcacc37aa5a07493527a42772 (diff)
downloadfreebsd-ports-gnome-9672ec1d0930891a2a22d7f35e2dedfd4cac308e.tar.gz
freebsd-ports-gnome-9672ec1d0930891a2a22d7f35e2dedfd4cac308e.tar.zst
freebsd-ports-gnome-9672ec1d0930891a2a22d7f35e2dedfd4cac308e.zip
- Fix build with clang
Diffstat (limited to 'x11-wm/antiwm')
-rw-r--r--x11-wm/antiwm/files/patch-Makefile6
-rw-r--r--x11-wm/antiwm/files/patch-list.c10
-rw-r--r--x11-wm/antiwm/files/patch-manage.c10
3 files changed, 23 insertions, 3 deletions
diff --git a/x11-wm/antiwm/files/patch-Makefile b/x11-wm/antiwm/files/patch-Makefile
index b89d73dc6614..2f267008cea2 100644
--- a/x11-wm/antiwm/files/patch-Makefile
+++ b/x11-wm/antiwm/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2008-08-01 02:59:17.000000000 +0200
-+++ Makefile 2009-02-01 10:00:20.000000000 +0100
+--- ./Makefile.orig 2008-08-01 02:59:17.000000000 +0200
++++ ./Makefile 2011-06-24 15:12:36.000000000 +0200
@@ -1,22 +1,36 @@
# install directory
-INSTALL_DIR=/usr/local/bin
@@ -34,7 +34,7 @@
+
antiwm: $(SRC)
- gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS) $(LIBS)
-+ gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS)
++ $(CC) $(SRC) -o $@ $(CFLAGS) $(LDFLAGS)
-install: antiwm
- cp antiwm $(INSTALL_DIR)
diff --git a/x11-wm/antiwm/files/patch-list.c b/x11-wm/antiwm/files/patch-list.c
new file mode 100644
index 000000000000..747bf004fad2
--- /dev/null
+++ b/x11-wm/antiwm/files/patch-list.c
@@ -0,0 +1,10 @@
+--- ./list.c.orig 2011-06-24 15:14:48.000000000 +0200
++++ ./list.c 2011-06-24 15:15:27.000000000 +0200
+@@ -4,6 +4,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "antiwm.h"
+
diff --git a/x11-wm/antiwm/files/patch-manage.c b/x11-wm/antiwm/files/patch-manage.c
new file mode 100644
index 000000000000..8583cdc02745
--- /dev/null
+++ b/x11-wm/antiwm/files/patch-manage.c
@@ -0,0 +1,10 @@
+--- ./manage.c.orig 2011-06-24 15:13:24.000000000 +0200
++++ ./manage.c 2011-06-24 15:13:59.000000000 +0200
+@@ -10,6 +10,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include "antiwm.h"
+