aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/awesome/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-13 02:58:57 +0800
committermiwi <miwi@FreeBSD.org>2007-12-13 02:58:57 +0800
commit038f9c183469f431a3c997b890a6b11801f14c72 (patch)
treeaf8288d695be164407a79add059611a2c2ce599b /x11-wm/awesome/Makefile
parentf1ee2c8adab4ddf571a15e93f637ccfa7301aed2 (diff)
downloadfreebsd-ports-gnome-038f9c183469f431a3c997b890a6b11801f14c72.tar.gz
freebsd-ports-gnome-038f9c183469f431a3c997b890a6b11801f14c72.tar.zst
freebsd-ports-gnome-038f9c183469f431a3c997b890a6b11801f14c72.zip
- Update to 2.0
PR: 118560 Submitted by: Nikos Ntarmos <ntarmos@ceid.upatras.gr> (maintainer)
Diffstat (limited to 'x11-wm/awesome/Makefile')
-rw-r--r--x11-wm/awesome/Makefile32
1 files changed, 12 insertions, 20 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 2f86be2ccdaf..6a14744567b7 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -6,36 +6,28 @@
#
PORTNAME= awesome
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTVERSION= 2.0
CATEGORIES= x11-wm
MASTER_SITES= http://awesome.naquadah.org/download/
MAINTAINER= ntarmos@ceid.upatras.gr
-COMMENT= A tiling window manager initialy based on a dwm code rewriting
+COMMENT= A tiling window manager initially based on a dwm code rewriting
-LIB_DEPENDS= config.4:${PORTSDIR}/devel/libconfig
+BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
+ xmlto:${PORTSDIR}/textproc/xmlto
+LIB_DEPENDS= confuse.0:${PORTSDIR}/devel/libconfuse \
+ cairo.2:${PORTSDIR}/graphics/cairo \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_XLIB= yes
-MAN1= awesome.1
-PLIST_FILES= bin/awesome
+MAN1= awesome.1 \
+ awesome-client.1
+PLIST_FILES= bin/awesome \
+ bin/awesome-client
PORTDOCS= AUTHORS LICENSE README
PORTEXAMPLES= awesomerc
-OPTIONS= LWRFLT "Support lowering of floating windows" on \
- WARP "Support mouse warping" on
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_LWRFLT)
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-lowerfloat
-.endif
-
-.if defined(WITH_WARP)
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-warp
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@@ -50,4 +42,4 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/awesomerc ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>