aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/awesome
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-04-02 01:43:39 +0800
committerwxs <wxs@FreeBSD.org>2009-04-02 01:43:39 +0800
commit34bcf606eb9307b8b76726fe7fa484f0d3f8e54f (patch)
tree603c1fe93a977bb9f27634c25b79c6465871196d /x11-wm/awesome
parent6c3e533a395486e59e3879e44609c06b1638d12a (diff)
downloadfreebsd-ports-gnome-34bcf606eb9307b8b76726fe7fa484f0d3f8e54f.tar.gz
freebsd-ports-gnome-34bcf606eb9307b8b76726fe7fa484f0d3f8e54f.tar.zst
freebsd-ports-gnome-34bcf606eb9307b8b76726fe7fa484f0d3f8e54f.zip
- Make dbus support optional and on by default.
PR: ports/133231 Submitted by: Pierre Guinoiseau <geekounet@poildetroll.net> Approved by: Nikos Ntarmos <ntarmos@cs.uoi.gr> (maintainer)
Diffstat (limited to 'x11-wm/awesome')
-rw-r--r--x11-wm/awesome/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-wm/awesome/Makefile b/x11-wm/awesome/Makefile
index 8a2a0b9d777a..6c26b2aed4e7 100644
--- a/x11-wm/awesome/Makefile
+++ b/x11-wm/awesome/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= asciidoc:${PORTSDIR}/textproc/asciidoc \
xcb-util>=0.3.3:${PORTSDIR}/x11/xcb-util \
xproto>=7.0.11:${PORTSDIR}/x11/xproto
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- dbus-1.3:${PORTSDIR}/devel/dbus \
ev.3:${PORTSDIR}/devel/libev \
freetype.9:${PORTSDIR}/print/freetype2 \
xcb.2:${PORTSDIR}/x11/libxcb \
@@ -44,6 +43,8 @@ MAN5= awesomerc.5
MANCOMPRESSED= yes
PORTDOCS= AUTHORS BUGS LICENSE README
+OPTIONS+= DBUS "Enable D-BUS support" On
+
.include <bsd.port.pre.mk>
.if (exists(${LOCALBASE}/libdata/pkgconfig/cairo.pc) && \
@@ -51,12 +52,19 @@ PORTDOCS= AUTHORS BUGS LICENSE README
IGNORE= cannot find dependency: The cairo exists but not with XCB support. Please reinstall graphics/cairo with XCB support
.endif
+.ifdef(WITH_DBUS)
+LIB_DEPENDS += dbus-1.3:${PORTSDIR}/devel/dbus
+CMAKE_ARGS += -DWITH_DBUS=YES
+.else
+CMAKE_ARGS += -DWITH_DBUS=NO
+.endif
+
pre-configure:
@${REINPLACE_CMD} \
-e 's/"generate luadoc" ON/\"generate luadoc" OFF/g' \
${WRKSRC}/awesomeConfig.cmake
@${REINPLACE_CMD} \
- -e 's,tr ,env LC_ALL="C" tr ,g' \
+ -e 's,tr ,env LC_ALL="C" ${TR} ,g' \
-e 's,gperf,${LOCALBASE}/bin/gperf,g' \
${WRKSRC}/build-utils/gperf.sh
.if defined(NOPORTDOCS)