aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/blackbox
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-07-08 18:27:20 +0800
committerdanfe <danfe@FreeBSD.org>2011-07-08 18:27:20 +0800
commitc3611c58d5289ed5628de6a181047415d287458e (patch)
treedf395ef51adc0a806b0de13ccab9d01d55b1ae1a /x11-wm/blackbox
parent574013401c51b57bd442883466bd588b44c7a935 (diff)
downloadfreebsd-ports-gnome-c3611c58d5289ed5628de6a181047415d287458e.tar.gz
freebsd-ports-gnome-c3611c58d5289ed5628de6a181047415d287458e.tar.zst
freebsd-ports-gnome-c3611c58d5289ed5628de6a181047415d287458e.zip
Remove `x11-wm/boxtools' port and provide an OPTION to install tools only.
Blackbox port is very light, and this separation does not really buys us anything expect having to maintain two ports that operate on the very same distfile. I could have probably just completely removed tools-only mode, but there might be folks out there who believe this is a useful feature. Approved by: maintainer (general idea)
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/Makefile32
1 files changed, 22 insertions, 10 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 77c9644c0199..f0c5d08c2013 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blackbox
PORTVERSION= 0.70.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}wm/${PORTNAME}wm/Blackbox%20${PORTVERSION}
@@ -16,22 +16,34 @@ COMMENT= A small and fast window manager for X11R6
LICENSE= MIT
-CONFLICTS= boxtools-*
-
-PORTDOCS= AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO
-MAN1= blackbox.1
-
GNU_CONFIGURE= yes
USE_ICONV= yes
USE_GNOME= gnomehack pkgconfig
USE_XORG= x11 xft
-post-patch:
- @${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' \
- ${WRKSRC}/doc/Makefile.in
+MAN1= bsetbg.1 bsetroot.1
+PORTDOCS= README.bbtools README.bsetbg
+
+OPTIONS= TOOLS_ONLY "Do not install window manager, only tools" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TOOLS_ONLY)
+PKGNAMESUFFIX= -tools
+COMMENT+= (tools only)
+MAKE_ARGS= SUBDIRS="doc lib util" bin_PROGRAMS=bsetroot
+INSTALL_TARGET= -C util install # XXX dirty hack :(
+.else
+MAN1+= blackbox.1
+PORTDOCS+= AUTHORS COMPLIANCE ChangeLog README RELNOTES TODO
+.endif
post-install:
+.if defined(WITH_TOOLS_ONLY)
+ @${REINPLACE_CMD} -E '/[^s]\/blackbox|bstyleconvert|lib|include/d' \
+ ${TMPPLIST}
+ ${INSTALL_MAN} ${MAN1:S#^#${WRKSRC}/doc/#} ${MANPREFIX}/man/man1
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S#^#${WRKSRC}/#} ${DOCSDIR}