aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/e17-module-alarm/Makefile
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
committerstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
commitea0b2f30fe3fda2784bed10c50a24cff87e5bae0 (patch)
treed85ff1f5968af1d6a70c1852bacf3e546d97c800 /x11-wm/e17-module-alarm/Makefile
parentff78984cfcc8530917b60f277d53c92434a50fd2 (diff)
downloadfreebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.gz
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.zst
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.zip
- Update e17 applications suite to the recent snapshot.
Thanks to Grzegorz Blach <magik@roorback.net> for doing the hard work preparing the initial version of the update! PR: ports/148038 Submitted by: Grzegorz Blach <magik@roorback.net> (based on)
Diffstat (limited to 'x11-wm/e17-module-alarm/Makefile')
-rw-r--r--x11-wm/e17-module-alarm/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-wm/e17-module-alarm/Makefile b/x11-wm/e17-module-alarm/Makefile
new file mode 100644
index 000000000000..9b8a93d4bddc
--- /dev/null
+++ b/x11-wm/e17-module-alarm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-alarm
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alarm
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A module to set Alarms in Enlightenment 17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>