aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/e17-module-drawer
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
committerstas <stas@FreeBSD.org>2010-12-14 15:30:56 +0800
commitea0b2f30fe3fda2784bed10c50a24cff87e5bae0 (patch)
treed85ff1f5968af1d6a70c1852bacf3e546d97c800 /x11-wm/e17-module-drawer
parentff78984cfcc8530917b60f277d53c92434a50fd2 (diff)
downloadfreebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.gz
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.tar.zst
freebsd-ports-gnome-ea0b2f30fe3fda2784bed10c50a24cff87e5bae0.zip
- Update e17 applications suite to the recent snapshot.
Thanks to Grzegorz Blach <magik@roorback.net> for doing the hard work preparing the initial version of the update! PR: ports/148038 Submitted by: Grzegorz Blach <magik@roorback.net> (based on)
Diffstat (limited to 'x11-wm/e17-module-drawer')
-rw-r--r--x11-wm/e17-module-drawer/Makefile39
-rw-r--r--x11-wm/e17-module-drawer/distinfo2
-rw-r--r--x11-wm/e17-module-drawer/pkg-descr3
-rw-r--r--x11-wm/e17-module-drawer/pkg-plist68
4 files changed, 112 insertions, 0 deletions
diff --git a/x11-wm/e17-module-drawer/Makefile b/x11-wm/e17-module-drawer/Makefile
new file mode 100644
index 000000000000..73fb4dcf36d9
--- /dev/null
+++ b/x11-wm/e17-module-drawer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: e17-module-drawer
+# Date created: 29 August 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drawer
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= An e17 module to display/organize different types of information
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment \
+ ethumb:${PORTSDIR}/graphics/ethumb
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment \
+ ethumb:${PORTSDIR}/graphics/ethumb
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-drawer/distinfo b/x11-wm/e17-module-drawer/distinfo
new file mode 100644
index 000000000000..00efa63a624c
--- /dev/null
+++ b/x11-wm/e17-module-drawer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/drawer-20101003.tar.bz2) = 9df0bae8a2ece92e835ce8ef35510c0b1422428e38f37328aed2a5f9a974f156
+SIZE (e17/drawer-20101003.tar.bz2) = 625350
diff --git a/x11-wm/e17-module-drawer/pkg-descr b/x11-wm/e17-module-drawer/pkg-descr
new file mode 100644
index 000000000000..e800e9c1d1be
--- /dev/null
+++ b/x11-wm/e17-module-drawer/pkg-descr
@@ -0,0 +1,3 @@
+A module to display/organize different types of information.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-drawer/pkg-plist b/x11-wm/e17-module-drawer/pkg-plist
new file mode 100644
index 000000000000..e6938d7299b9
--- /dev/null
+++ b/x11-wm/e17-module-drawer/pkg-plist
@@ -0,0 +1,68 @@
+include/drawer/Drawer.h
+libdata/pkgconfig/drawer.pc
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/views/grid.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/views/list.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/views/grid.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/views/list.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/directory_watcher.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/launcher.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/history.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/directory_watcher.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/history.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/winlist.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/winlist.so
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources/launcher.desktop
+lib/enlightenment/modules/drawer/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/drawer/e-module-drawer.edj
+lib/enlightenment/modules/drawer/module.desktop
+%%NLS%%lib/enlightenment/modules/drawer/locale/tr/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/eo/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/it/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/pt_BR/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/pt/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/fi/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/el/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/uk/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/fr/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/lt/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/cs/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/zh_CN/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/es/LC_MESSAGES/drawer.mo
+%%NLS%%lib/enlightenment/modules/drawer/locale/hr/LC_MESSAGES/drawer.mo
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/hr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/hr
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/es/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/es
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/zh_CN
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/cs/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/cs
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/lt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/lt
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/uk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/uk
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/el/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/el
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/fi/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/fi
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/pt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/pt
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/pt_BR/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/pt_BR
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/eo/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/eo
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/tr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale/tr
+%%NLS%%@dirrm lib/enlightenment/modules/drawer/locale
+@dirrm include/drawer
+@dirrm lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/sources
+@dirrm lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins/views
+@dirrm lib/enlightenment/modules/drawer/%%E17_ARCH%%/plugins
+@dirrm lib/enlightenment/modules/drawer/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/drawer
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment