aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/emerald
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-12 23:29:37 +0800
committertijl <tijl@FreeBSD.org>2014-08-12 23:29:37 +0800
commit4cb8aa2cbc52a616e4f442310a09cc5f408303f3 (patch)
tree88f5fc59ca92cb0cc696d418e8dff349c265467f /x11-wm/emerald
parent98e780c1c7270e84b6fb00c8eb4bdb03e6702f80 (diff)
downloadfreebsd-ports-gnome-4cb8aa2cbc52a616e4f442310a09cc5f408303f3.tar.gz
freebsd-ports-gnome-4cb8aa2cbc52a616e4f442310a09cc5f408303f3.tar.zst
freebsd-ports-gnome-4cb8aa2cbc52a616e4f442310a09cc5f408303f3.zip
Fix problems with missing libs when the linker enforces explicit linking
(ports that are dependencies of other ports) net-p2p/transmission-cli: add USES=libtool and remove PTHREAD_LIBS sysutils/deltup: simplify patch by using MAKE_ARGS x11-fm/rox-filer: convert to USES=shared-mime-info x11-wm/emerald: remove PTHREAD_LIBS PR: 192062
Diffstat (limited to 'x11-wm/emerald')
-rw-r--r--x11-wm/emerald/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index ebdb0486c631..35365832dab6 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -22,12 +22,13 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LIBS+= -L${LOCALBASE}/lib
# XXX - might want to change that
post-patch:
@${REINPLACE_CMD} 's|icons/gnome|icons/hicolor|' ${WRKSRC}/misc/Makefile.in
@${REINPLACE_CMD} -e 's|#define GDK_DISABLE_DEPRECATED||g' \
-e 's|#define GTK_DISABLE_DEPRECATED||g' ${WRKSRC}/include/emerald.h
+ @${REINPLACE_CMD} '/^emerald_LDADD =/s/$$/ -lm/' ${WRKSRC}/src/Makefile.in
.include <bsd.port.mk>