aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/enlightenment-devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
committerstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
commit173755349dc2dd22744f67ee65b533ef3b1c3649 (patch)
treefcddf9b33a006f3b495b40ac5641012787c2a99e /x11-wm/enlightenment-devel
parented21c3e01f7d2d837804666f445b9249d985c327 (diff)
downloadfreebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.gz
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.zst
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.zip
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Diffstat (limited to 'x11-wm/enlightenment-devel')
-rw-r--r--x11-wm/enlightenment-devel/Makefile25
-rw-r--r--x11-wm/enlightenment-devel/bsd.efl.mk307
-rw-r--r--x11-wm/enlightenment-devel/distinfo6
-rw-r--r--x11-wm/enlightenment-devel/pkg-plist188
4 files changed, 436 insertions, 90 deletions
diff --git a/x11-wm/enlightenment-devel/Makefile b/x11-wm/enlightenment-devel/Makefile
index 82232ce1d6ce..a6cbb3d0ce0a 100644
--- a/x11-wm/enlightenment-devel/Makefile
+++ b/x11-wm/enlightenment-devel/Makefile
@@ -6,33 +6,25 @@
#
PORTNAME= enlightenment
-PORTVERSION= 0.16.999.032
+PORTVERSION= 20060926
PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= x11-wm
-MASTER_SITES= http://enlightenment.freedesktop.org/files/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+DISTNAME= e-${PORTVERSION}
-MAINTAINER= vanilla@FreeBSD.org
+MAINTAINER= stas@FreeBSD.org
COMMENT= A very artistic X window manager
-LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
- evas.1:${PORTSDIR}/graphics/evas \
- edje.5:${PORTSDIR}/graphics/edje \
- ecore.1:${PORTSDIR}/x11/ecore \
- embryo.9:${PORTSDIR}/lang/embryo \
- eet.9:${PORTSDIR}/devel/eet
-
USE_GMAKE= yes
-USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnometarget
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_EFL= imlib2 evas edje ecore embryo eet
USE_ICONV= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-
-PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
.include <bsd.port.pre.mk>
@@ -40,4 +32,5 @@ PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
IGNORE= does not build on 4.X
.endif
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
.include <bsd.port.post.mk>
diff --git a/x11-wm/enlightenment-devel/bsd.efl.mk b/x11-wm/enlightenment-devel/bsd.efl.mk
new file mode 100644
index 000000000000..58a4c15dca60
--- /dev/null
+++ b/x11-wm/enlightenment-devel/bsd.efl.mk
@@ -0,0 +1,307 @@
+#
+# $MBSDlabs: portmk/bsd.efl.mk,v 1.17 2006/10/02 14:57:48 stas Exp $
+# $FreeBSD$
+#
+# bsd.efl.mk - Support for Enlightenment Foundation Libraries (EFL)
+#
+# Author: Stanislav Sedov <ssedov@mbsd.msk.ru>
+# Inspired by bsd.sdl.mk by Edwin Groothuis <edwin@freebsd.org>
+#
+# You can specify EFL-related library dependency using "USE_EFL=" statement,
+# e.g. "USE_EFL= ecore evas" will add x11/ecore and graphics/evas as dependency
+# for your port.
+# You can check existency of certain library throught "WANT_EFL/HAVE_EFL" pair.
+# Note: WANT_EFL should be defined before including <bsd.port.pre.mk>, and
+# HAVE_EFL variable could be tested after it. For example:
+#
+# WANT_EFL= yes
+# .include <bsd.port.pre.mk>
+# .if ${HAVE_EFL:Mevas}
+# USE_EFL+= evas
+# .endif
+#
+# Currently recognized variables are:
+# USE_EFL - lists all EFL libraries which port depends on
+# WANT_EFL - the port wants to test which of EFL libraries are installed
+# on the target system
+# USE_EFL_ESMART- the ports depends on specified esmart objects (or on all
+# esmart objects if "yes")
+#
+# The following variables could be tested after inclusion of bsd.port.pre.mk:
+# HAVE_EFL - lists all EFL libraries which are available on target system
+# HAVE_EFL_ESMART - esmart objects available
+#
+# Feel free to send any comments and suggestion to maintainer.
+#
+
+EFL_Include_MAINTAINER= ssedov@mbsd.msk.ru
+
+#
+# Define all supported libraries
+#
+_USE_EFL_ALL= ecore edb edje eet embryo emotion engrave enhance epeg \
+ epsilon etk etox evas evfs ewl exml imlib2
+
+# For each library supported we define the following variables:
+# _%%LIB%%_CATEGORY - category the port belongs to
+# _%%LIB%%_DEPENDS - other EFL libraries the library
+# itself depends on. We'll define them explicitly
+# to handle unwanted deinstalls.
+# _%%LIB%%_PREFIX - where the library is installed
+# _%%LIB%%_VERSION - version of the shared library
+# _%%LIB%%_SLIB - name of the shared library
+#
+
+_ecore_CATEGORY= x11
+_ecore_DEPENDS= evas
+_ecore_PREFIX= ${LOCALBASE}
+_ecore_VERSION= 1
+
+_edb_CATEGORY= databases
+_edb_PREFIX= ${LOCALBASE}
+_edb_VERSION= 1
+
+_eet_CATEGORY= devel
+_eet_PREFIX= ${LOCALBASE}
+_eet_VERSION= 9
+
+_edje_CATEGORY= graphics
+_edje_DEPENDS= embryo eet imlib2 evas ecore
+_edje_PREFIX= ${LOCALBASE}
+_edje_VERSION= 5
+
+_embryo_CATEGORY= lang
+_embryo_PREFIX= ${LOCALBASE}
+_embryo_VERSION= 9
+
+_emotion_CATEGORY= multimedia
+_emotion_DEPENDS= ecore edje eet embryo evas
+_emotion_PREFIX= ${LOCALBASE}
+_emotion_VERSION= 0
+
+_engrave_CATEGORY= devel
+_engrave_DEPENDS= ecore evas
+_engrave_PREFIX= ${LOCALBASE}
+_engrave_VERSION= 1
+
+_enhance_CATEGORY= x11-toolkits
+_enhance_DEPENDS= ecore etk exml
+_enhance_PREFIX= ${LOCALBASE}
+_enhance_VERSION= 0
+
+_epeg_CATEGORY= graphics
+_epeg_PREFIX= ${LOCALBASE}
+_epeg_VERSION= 9
+
+_epsilon_CATEGORY= graphics
+_epsilon_DEPENDS= epeg edje imlib2 ecore
+_epsilon_PREFIX= ${LOCALBASE}
+_epsilon_VERSION= 0
+
+_etk_CATEGORY= x11-toolkits
+_etk_DEPENDS= evas ecore edje
+_etk_PREFIX= ${LOCALBASE}
+_etk_VERSION= 1
+
+_etox_CATEGORY= x11-toolkits
+_etox_DEPENDS= edb evas ecore
+_etox_PREFIX= ${LOCALBASE}
+_etox_VERSION= 0
+
+_evas_CATEGORY= graphics
+_evas_DEPENDS= eet edb
+_evas_PREFIX= ${LOCALBASE}
+_evas_VERSION= 1
+
+_evfs_CATEGORY= devel
+_evfs_DEPENDS= eet ecore
+_evfs_PREFIX= ${LOCALBASE}
+_evfs_VERSION= 0
+
+_ewl_CATEGORY= x11-toolkits
+_ewl_DEPENDS= evas ecore edje epsilon
+_ewl_PREFIX= ${LOCALBASE}
+_ewl_VERSION= 0
+
+_exml_CATEGORY= textproc
+_exml_DEPENDS= ecore
+_exml_PREFIX= ${LOCALBASE}
+_exml_VERSION= 1
+
+_imlib2_CATEGORY= graphics
+_imlib2_PREFIX= ${LOCALBASE}
+_imlib2_VERSION= 3
+_imlib2_SLIB= Imlib2
+
+#
+# Assign values for variables which were not defined explicitly
+#
+.for LIB in ${_USE_EFL_ALL}
+. if !defined(_${LIB}_DEPENDS)
+_${LIB}_DEPENDS= #empty
+. endif
+. if !defined(_${LIB}_SLIB)
+_${LIB}_SLIB=${LIB}
+. endif
+.endfor
+
+#
+# Esmart support. We'll define esmart components in the way the're
+# defined for EFL.
+# Values processed:
+# _esmart_COMP_CATEGORY - Where the port for this esmart object is located
+# _esmart_COMP_PORTNAME - Object's port subdirectory
+# _esmart_COMP_DEPENDS - Other components which this object depends on
+# _esmart_COMP_PREFIX - Where the shared library for this object is located
+# _esmart_COMP_VERSION - Version of the shared library
+#
+
+# All components that are currently supported
+_EFL_ESMART_ALL= container draggies file_dialog text_entry \
+ thumb trans_x11
+
+#
+# Generic stock esmart definitions
+#
+_EFL_ESMART_CATEGORY= graphics
+_EFL_ESMART_PORTNAME= esmart
+_EFL_ESMART_DEPENDS= epsilon evas ecore imlib2 edje
+_EFL_ESMART_PREFIX= ${LOCALBASE}
+_EFL_ESMART_VERSION= 0
+
+#
+# Assign values for variables which were not defined explicitly
+#
+.for COMP in ${_EFL_ESMART_ALL}
+. if !defined(_esmart_${COMP}_CATEGORY)
+_esmart_${COMP}_CATEGORY= ${_EFL_ESMART_CATEGORY}
+. endif
+. if !defined(_esmart_${COMP}_PORTNAME)
+_esmart_${COMP}_PORTNAME= ${_EFL_ESMART_PORTNAME}
+. endif
+. if !defined(_esmart_${COMP}_PREFIX)
+_esmart_${COMP}_PREFIX= ${_EFL_ESMART_PREFIX}
+. endif
+. if !defined(_esmart_${COMP}_DEPENDS)
+_esmart_${COMP}_DEPENDS= #empty
+. endif
+. if !defined(_esmart_${COMP}_SLIB)
+_esmart_${COMP}_SLIB= esmart_${COMP}
+. endif
+. if !defined(_esmart_${COMP}_VERSION)
+_esmart_${COMP}_VERSION= ${_EFL_ESMART_VERSION}
+. endif
+.endfor
+
+#
+# Handle WANT_EFL feature
+#
+.if !defined(AFTERPORTMK)
+.if !defined(EFL_Include_pre)
+
+EFL_Include_pre= bsd.efl.mk
+
+HAVE_EFL?=
+HAVE_EFL_ESMART?=
+.if defined(WANT_EFL)
+. for LIB in ${_USE_EFL_ALL}
+. if exists(${_${LIB}_PREFIX}/lib/lib${_${LIB}_SLIB}.so.${_${LIB}_VERSION})
+HAVE_EFL+= ${LIB}
+. endif
+. endfor
+. for COMP in ${_EFL_ESMART_ALL}
+. if exists(${_esmart_${COMP}_PREFIX}/lib/lib${_esmart_${COMP}_SLIB}.so.${_esmart_${COMP}_VERSION})
+HAVE_EFL_ESMART+= ${COMP}
+. endif
+. endfor
+.endif
+
+.endif #EFL_Include_pre
+.endif #AFTERPORTMK
+
+#
+# Handle USE_EFL & USE_ESMART feature
+#
+.if !defined(BEFOREPORTMK)
+.if !defined(EFL_Include_post)
+
+.if defined(USE_EFL_ESMART)
+
+USE_EFL+= ${_EFL_ESMART_DEPENDS} #we use EFL too
+
+_USE_EFL_ESMART= #empty
+.if USE_EFL_ESMART=="yes"
+_USE_EFL_ESMART= ${_EFL_ESMART_ALL}
+.else
+. for COMP in ${USE_EFL_ESMART}
+. if ${_EFL_ESMART_ALL:M${COMP}}==""
+IGNORE= cannot install: unknown Esmart component ${COMP}
+. else
+_USE_EFL_ESMART+= ${COMP} ${_esmart_${COMP}_DEPENDS}
+. endif
+. endfor
+.endif
+
+# Get rid of duplicates
+.if ${OSVERSION} > 700016
+_USE_EFL_ESMART_UQ= ${_USE_EFL_ESMART:O:u}
+.else
+_USE_EFL_ESMART_UQ= #empty
+. for COMP in ${_USE_EFL_ESMART}
+. if ${_USE_EFL_ESMART_UQ:M${COMP}}==""
+_USE_EFL_ESMART_UQ+= ${COMP}
+. endif
+. endfor
+.endif
+
+.for COMP in ${_USE_EFL_ESMART_UQ}
+LIB_DEPENDS+= ${_esmart_${COMP}_SLIB}.${_esmart_${COMP}_VERSION}:${PORTSDIR}/${_esmart_${COMP}_CATEGORY}/${_esmart_${COMP}_PORTNAME}
+.endfor
+
+.endif #USE_EFL_ESMART
+
+.if defined(USE_EFL)
+
+EFL_Include_post= bsd.efl.mk
+
+#
+# Check if we have all libraries requiested and build depends list
+#
+_USE_EFL= #empty
+.for LIB in ${USE_EFL}
+. if ${_USE_EFL_ALL:M${LIB}}==""
+IGNORE= cannot install: unknown library ${LIB}
+. endif
+_USE_EFL+= ${_${LIB}_DEPENDS} ${LIB}
+.endfor
+
+#
+# Get rid of duplicates
+#
+_USE_EFL_UQ= #empty
+.for LIB in ${_USE_EFL}
+. if ${_USE_EFL_UQ:M${LIB}}==""
+_USE_EFL_UQ+= ${LIB}
+. endif
+.endfor
+
+#
+# define dependencies
+#
+.for LIB in ${_USE_EFL_UQ}
+LIB_DEPENDS+= ${_${LIB}_SLIB}.${_${LIB}_VERSION}:${PORTSDIR}/${_${LIB}_CATEGORY}/${LIB}
+.endfor
+
+#
+# Initialize configure enviropment
+#
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ CFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${LDFLAGS}"
+
+PLIST_SUB+= E17_ARCH=freebsd${OSREL}-${ARCH}
+
+.endif #USE_EFL
+
+.endif #EFL_Include_post
+.endif #BEFOREPORTMK
diff --git a/x11-wm/enlightenment-devel/distinfo b/x11-wm/enlightenment-devel/distinfo
index 934d88520b6d..96e4ff935a0d 100644
--- a/x11-wm/enlightenment-devel/distinfo
+++ b/x11-wm/enlightenment-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (enlightenment-0.16.999.032.tar.gz) = 206dca9d967ea4898ca0b9139e51e31f
-SHA256 (enlightenment-0.16.999.032.tar.gz) = 7643f56131a6db9635e0224b1d6806c412c4638731f62355cf892236d0dcded9
-SIZE (enlightenment-0.16.999.032.tar.gz) = 29911903
+MD5 (e-20060926.tar.bz2) = 440377d3f561b2dc8dbc5a04be50193f
+SHA256 (e-20060926.tar.bz2) = fdba2748a0a172d11b5edd8f8ee1ecec17b4e270a7b9983a8d8f156d5e95d6bd
+SIZE (e-20060926.tar.bz2) = 31174715
diff --git a/x11-wm/enlightenment-devel/pkg-plist b/x11-wm/enlightenment-devel/pkg-plist
index e33de5dabce8..ce5df7f81b4c 100644
--- a/x11-wm/enlightenment-devel/pkg-plist
+++ b/x11-wm/enlightenment-devel/pkg-plist
@@ -1,17 +1,18 @@
+bin/eap_to_desktop
bin/enlightenment
bin/enlightenment-config
bin/enlightenment_eapp
-bin/enlightenment_eapp_cache_gen
bin/enlightenment_imc
bin/enlightenment_remote
bin/enlightenment_start
+bin/enlightenment_sys
bin/enlightenment_thumb
+etc/enlightenment/sysactions.conf
include/enlightenment/e.h
include/enlightenment/e_about.h
include/enlightenment/e_actions.h
include/enlightenment/e_alert.h
include/enlightenment/e_apps.h
-include/enlightenment/e_apps_cache.h
include/enlightenment/e_apps_error.h
include/enlightenment/e_atoms.h
include/enlightenment/e_bg.h
@@ -19,7 +20,9 @@ include/enlightenment/e_bindings.h
include/enlightenment/e_border.h
include/enlightenment/e_box.h
include/enlightenment/e_canvas.h
+include/enlightenment/e_color.h
include/enlightenment/e_color_class.h
+include/enlightenment/e_color_dialog.h
include/enlightenment/e_config.h
include/enlightenment/e_config_dialog.h
include/enlightenment/e_configure.h
@@ -32,29 +35,21 @@ include/enlightenment/e_deskpreview.h
include/enlightenment/e_dialog.h
include/enlightenment/e_dnd.h
include/enlightenment/e_eap_editor.h
+include/enlightenment/e_editable.h
include/enlightenment/e_entry.h
include/enlightenment/e_entry_dialog.h
include/enlightenment/e_error.h
include/enlightenment/e_exebuf.h
include/enlightenment/e_exehist.h
-include/enlightenment/e_file_dialog.h
-include/enlightenment/e_file_selector.h
-include/enlightenment/e_fileman.h
-include/enlightenment/e_fileman_file.h
-include/enlightenment/e_fileman_icon.h
-include/enlightenment/e_fileman_mime.h
-include/enlightenment/e_fileman_smart.h
+include/enlightenment/e_fdo_menu_to_order.h
include/enlightenment/e_fm.h
+include/enlightenment/e_fm_mime.h
include/enlightenment/e_focus.h
include/enlightenment/e_font.h
include/enlightenment/e_gadcon.h
-include/enlightenment/e_gadget.h
-include/enlightenment/e_gadman.h
include/enlightenment/e_grabinput.h
include/enlightenment/e_hints.h
include/enlightenment/e_icon.h
-include/enlightenment/e_icon_canvas.h
-include/enlightenment/e_icon_grid.h
include/enlightenment/e_ilist.h
include/enlightenment/e_includes.h
include/enlightenment/e_init.h
@@ -63,8 +58,7 @@ include/enlightenment/e_int_border_locks.h
include/enlightenment/e_int_border_menu.h
include/enlightenment/e_int_border_prop.h
include/enlightenment/e_int_border_remember.h
-include/enlightenment/e_int_config_background.h
-include/enlightenment/e_int_config_background_import.h
+include/enlightenment/e_int_config_apps.h
include/enlightenment/e_int_config_cfgdialogs.h
include/enlightenment/e_int_config_cursor.h
include/enlightenment/e_int_config_desklock.h
@@ -73,21 +67,28 @@ include/enlightenment/e_int_config_display.h
include/enlightenment/e_int_config_exebuf.h
include/enlightenment/e_int_config_focus.h
include/enlightenment/e_int_config_fonts.h
-include/enlightenment/e_int_config_hinting.h
+include/enlightenment/e_int_config_icon_themes.h
+include/enlightenment/e_int_config_intl.h
include/enlightenment/e_int_config_keybindings.h
-include/enlightenment/e_int_config_startup.h
include/enlightenment/e_int_config_menus.h
include/enlightenment/e_int_config_modules.h
+include/enlightenment/e_int_config_mousebindings.h
include/enlightenment/e_int_config_paths.h
include/enlightenment/e_int_config_performance.h
-include/enlightenment/e_int_config_shelf.h
+include/enlightenment/e_int_config_sh%%PORTOBJFORMAT%%.h
+include/enlightenment/e_int_config_startup.h
include/enlightenment/e_int_config_theme.h
+include/enlightenment/e_int_config_theme_import.h
+include/enlightenment/e_int_config_transitions.h
+include/enlightenment/e_int_config_wallpaper.h
+include/enlightenment/e_int_config_wallpaper_gradient.h
+include/enlightenment/e_int_config_wallpaper_import.h
include/enlightenment/e_int_config_window_display.h
include/enlightenment/e_int_config_window_manipulation.h
include/enlightenment/e_int_config_winlist.h
include/enlightenment/e_int_gadcon_config.h
include/enlightenment/e_int_menus.h
-include/enlightenment/e_int_shelf_config.h
+include/enlightenment/e_int_sh%%PORTOBJFORMAT%%_config.h
include/enlightenment/e_intl.h
include/enlightenment/e_ipc.h
include/enlightenment/e_ipc_codec.h
@@ -102,6 +103,7 @@ include/enlightenment/e_mmx.h
include/enlightenment/e_module.h
include/enlightenment/e_moveresize.h
include/enlightenment/e_msg.h
+include/enlightenment/e_obj_dialog.h
include/enlightenment/e_object.h
include/enlightenment/e_pan.h
include/enlightenment/e_path.h
@@ -113,11 +115,13 @@ include/enlightenment/e_remember.h
include/enlightenment/e_resist.h
include/enlightenment/e_scrollframe.h
include/enlightenment/e_sha1.h
-include/enlightenment/e_shelf.h
+include/enlightenment/e_sh%%PORTOBJFORMAT%%.h
include/enlightenment/e_signals.h
include/enlightenment/e_slider.h
+include/enlightenment/e_spectrum.h
include/enlightenment/e_startup.h
include/enlightenment/e_stolen.h
+include/enlightenment/e_sys.h
include/enlightenment/e_table.h
include/enlightenment/e_test.h
include/enlightenment/e_theme.h
@@ -129,13 +133,14 @@ include/enlightenment/e_utils.h
include/enlightenment/e_widget.h
include/enlightenment/e_widget_button.h
include/enlightenment/e_widget_check.h
+include/enlightenment/e_widget_color_well.h
include/enlightenment/e_widget_config_list.h
+include/enlightenment/e_widget_csel.h
+include/enlightenment/e_widget_cslider.h
include/enlightenment/e_widget_entry.h
-include/enlightenment/e_widget_fileman.h
include/enlightenment/e_widget_framelist.h
include/enlightenment/e_widget_frametable.h
include/enlightenment/e_widget_fsel.h
-include/enlightenment/e_widget_iconsel.h
include/enlightenment/e_widget_ilist.h
include/enlightenment/e_widget_image.h
include/enlightenment/e_widget_label.h
@@ -144,6 +149,7 @@ include/enlightenment/e_widget_preview.h
include/enlightenment/e_widget_radio.h
include/enlightenment/e_widget_scrollframe.h
include/enlightenment/e_widget_slider.h
+include/enlightenment/e_widget_spectrum.h
include/enlightenment/e_widget_table.h
include/enlightenment/e_widget_textblock.h
include/enlightenment/e_widget_tlist.h
@@ -151,45 +157,58 @@ include/enlightenment/e_win.h
include/enlightenment/e_winlist.h
include/enlightenment/e_xinerama.h
include/enlightenment/e_zone.h
-lib/enlightenment/modules/battery/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/battery/module.eap
-lib/enlightenment/modules/battery/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/battery/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/clock/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/clock/module.eap
-lib/enlightenment/modules/clock/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/clock/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/cpufreq/%%MODULE_ARCH%%/freqset
-lib/enlightenment/modules/cpufreq/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/cpufreq/module.eap
-lib/enlightenment/modules/cpufreq/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/cpufreq/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/dropshadow/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/dropshadow/module.eap
-lib/enlightenment/modules/dropshadow/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/dropshadow/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/ibar/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/ibar/module.eap
-lib/enlightenment/modules/ibar/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/ibar/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/ibox/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/ibox/module.eap
-lib/enlightenment/modules/ibox/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/ibox/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/pager/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/pager/module.eap
-lib/enlightenment/modules/pager/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/pager/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/start/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/start/module.eap
-lib/enlightenment/modules/start/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/start/%%MODULE_ARCH%%/module.so
-lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/temperature/module.eap
-lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.so
+lib/enlightenment/modules/battery/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/battery/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/battery/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/battery/module.desktop
+lib/enlightenment/modules/battery/module.edj
+lib/enlightenment/modules/clock/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/clock/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/clock/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/clock/module.desktop
+lib/enlightenment/modules/clock/module.edj
+lib/enlightenment/modules/cpufreq/%%E17_ARCH%%/freqset
+lib/enlightenment/modules/cpufreq/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/cpufreq/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/cpufreq/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/cpufreq/module.desktop
+lib/enlightenment/modules/cpufreq/module.edj
+lib/enlightenment/modules/dropshadow/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/dropshadow/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/dropshadow/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/dropshadow/module.desktop
+lib/enlightenment/modules/dropshadow/module.edj
+lib/enlightenment/modules/ibar/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/ibar/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/ibar/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/ibar/module.desktop
+lib/enlightenment/modules/ibar/module.edj
+lib/enlightenment/modules/ibox/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/ibox/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/ibox/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/ibox/module.desktop
+lib/enlightenment/modules/ibox/module.edj
+lib/enlightenment/modules/pager/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/pager/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/pager/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/pager/module.desktop
+lib/enlightenment/modules/pager/module.edj
+lib/enlightenment/modules/start/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/start/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/start/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/start/module.desktop
+lib/enlightenment/modules/start/module.edj
+lib/enlightenment/modules/temperature/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/temperature/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/temperature/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/temperature/module.desktop
+lib/enlightenment/modules/temperature/module.edj
%%DATADIR%%/AUTHORS
%%DATADIR%%/COPYING
+%%DATADIR%%/data/backgrounds/Blue_Sky_Tree.edj
+%%DATADIR%%/data/backgrounds/Cracked_Earth.edj
+%%DATADIR%%/data/backgrounds/Ivy_Wall.edj
+%%DATADIR%%/data/backgrounds/Ladybug.edj
%%DATADIR%%/data/fonts/Vera.COPYING
%%DATADIR%%/data/fonts/Vera.ttf
%%DATADIR%%/data/fonts/VeraBI.ttf
@@ -203,6 +222,10 @@ lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.so
%%DATADIR%%/data/fonts/VeraSeBd.ttf
%%DATADIR%%/data/fonts/fonts.alias
%%DATADIR%%/data/fonts/fonts.dir
+%%DATADIR%%/data/icons/audio_player.png
+%%DATADIR%%/data/icons/video_player.png
+%%DATADIR%%/data/icons/web_browser.png
+%%DATADIR%%/data/icons/xterm.png
%%DATADIR%%/data/images/button_in.png
%%DATADIR%%/data/images/button_out.png
%%DATADIR%%/data/images/e.png
@@ -210,7 +233,7 @@ lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.so
%%DATADIR%%/data/images/test.edj
%%DATADIR%%/data/images/test.jpg
%%DATADIR%%/data/images/test.png
-%%DATADIR%%/data/init/init.edj
+%%DATADIR%%/data/init/default.edj
%%DATADIR%%/data/input_methods/iiimf.imc
%%DATADIR%%/data/input_methods/scim.imc
%%DATADIR%%/data/input_methods/uim.imc
@@ -218,6 +241,8 @@ lib/enlightenment/modules/temperature/%%MODULE_ARCH%%/module.so
%%DATADIR%%/data/other/efm_favorites.tar.gz
%%DATADIR%%/data/other/icon_example.tar.gz
%%DATADIR%%/data/themes/default.edj
+%%DATADIR%%/doc/FDO.txt
+%%DATADIR%%/doc/cache.txt
%%DATADIR%%/doc/documentation.html
%%DATADIR%%/doc/enlightenment.png
share/locale/bg/LC_MESSAGES/enlightenment.mo
@@ -243,34 +268,55 @@ share/locale/sv/LC_MESSAGES/enlightenment.mo
share/locale/zh_CN/LC_MESSAGES/enlightenment.mo
share/locale/zh_TW/LC_MESSAGES/enlightenment.mo
share/xsessions/enlightenment.desktop
+@dirrmtry share/xsessions
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW
+@dirrmtry share/locale/zh_CN/LC_MESSAGES
+@dirrmtry share/locale/zh_CN
+@dirrmtry share/locale/sl/LC_MESSAGES
+@dirrmtry share/locale/sl
+@dirrmtry share/locale/sk/LC_MESSAGES
+@dirrmtry share/locale/sk
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/ko/LC_MESSAGES
+@dirrmtry share/locale/ko
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
@dirrm %%DATADIR%%/doc
@dirrm %%DATADIR%%/data/themes
@dirrm %%DATADIR%%/data/other
-@dirrm %%DATADIR%%/data/init
@dirrm %%DATADIR%%/data/input_methods
+@dirrm %%DATADIR%%/data/init
@dirrm %%DATADIR%%/data/images
+@dirrm %%DATADIR%%/data/icons
@dirrm %%DATADIR%%/data/fonts
+@dirrm %%DATADIR%%/data/backgrounds
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
-@dirrmtry share/xsessions
-@dirrm lib/enlightenment/modules/temperature/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/temperature/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/temperature
-@dirrm lib/enlightenment/modules/start/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/start/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/start
-@dirrm lib/enlightenment/modules/pager/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/pager/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/pager
-@dirrm lib/enlightenment/modules/ibox/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/ibox/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/ibox
-@dirrm lib/enlightenment/modules/ibar/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/ibar/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/ibar
-@dirrm lib/enlightenment/modules/dropshadow/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/dropshadow/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/dropshadow
-@dirrm lib/enlightenment/modules/cpufreq/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/cpufreq/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/cpufreq
-@dirrm lib/enlightenment/modules/clock/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/clock/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/clock
-@dirrm lib/enlightenment/modules/battery/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/battery/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/battery
@dirrm lib/enlightenment/modules
@dirrm lib/enlightenment
@dirrm include/enlightenment
+@dirrm etc/enlightenment