aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/epplets
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-19 04:53:33 +0800
committerkrion <krion@FreeBSD.org>2004-02-19 04:53:33 +0800
commitb6a65e144d707af1e463c15f7edc1cde480a52c8 (patch)
treef9ec5cb5ec1a0aad5b725910400850f49e307850 /x11-wm/epplets
parentf0714ff5abd0159a6499f32221c3f9ffd03e46de (diff)
downloadfreebsd-ports-gnome-b6a65e144d707af1e463c15f7edc1cde480a52c8.tar.gz
freebsd-ports-gnome-b6a65e144d707af1e463c15f7edc1cde480a52c8.tar.zst
freebsd-ports-gnome-b6a65e144d707af1e463c15f7edc1cde480a52c8.zip
- Fix build
PR: ports/63011 Submitted by: Ports Fury
Diffstat (limited to 'x11-wm/epplets')
-rw-r--r--x11-wm/epplets/Makefile15
-rw-r--r--x11-wm/epplets/files/patch-configure10
2 files changed, 8 insertions, 17 deletions
diff --git a/x11-wm/epplets/Makefile b/x11-wm/epplets/Makefile
index 3225f454fb62..29f70caffc64 100644
--- a/x11-wm/epplets/Makefile
+++ b/x11-wm/epplets/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= import:${PORTSDIR}/graphics/ImageMagick \
enlightenment:${PORTSDIR}/x11-wm/enlightenment
USE_X_PREFIX= yes
-USE_GNOME= esound
+USE_GNOME= esound lthack
USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -35,10 +35,6 @@ CONFIGURE_ARGS= --enable-fsstd
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-BROKEN= "Does not compile (missing dependency)"
-.endif
-
.if ${ARCH} == "i386"
APM_PROGS= E-Power.epplet
PLIST_SUB+= APM_PROGS=""
@@ -47,8 +43,13 @@ APM_PROGS= # none
PLIST_SUB+= APM_PROGS="@comment "
.endif
+post-extract:
+ @${RM} -f ${WRKSRC}/api/epplet.h*
+
post-patch:
- @${REINPLACE_CMD} -e \
- 's|@APM_PROGS@|${APM_PROGS}|g' ${WRKSRC}/epplets/Makefile.in
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's| ../api/epplet.h||g ; \
+ s|@APM_PROGS@|${APM_PROGS}|g'
+ @${REINPLACE_CMD} -e 's| api/epplet.h||g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/x11-wm/epplets/files/patch-configure b/x11-wm/epplets/files/patch-configure
deleted file mode 100644
index 8ed049a52175..000000000000
--- a/x11-wm/epplets/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Tue Aug 26 12:12:44 2003
-+++ configure Mon Dec 8 02:20:46 2003
-@@ -5414,6 +5414,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'