aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/fvwm2-devel/Makefile
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2004-04-07 02:08:18 +0800
committercy <cy@FreeBSD.org>2004-04-07 02:08:18 +0800
commit18e97eaa1838d82e662904b3c731418cc7dcea64 (patch)
tree4fcdf95123a20a1c79c78823076552b644c907c5 /x11-wm/fvwm2-devel/Makefile
parentc7fe4d0ec7d976eb4c456d19f9d50c1bff903b20 (diff)
downloadfreebsd-ports-gnome-18e97eaa1838d82e662904b3c731418cc7dcea64.tar.gz
freebsd-ports-gnome-18e97eaa1838d82e662904b3c731418cc7dcea64.tar.zst
freebsd-ports-gnome-18e97eaa1838d82e662904b3c731418cc7dcea64.zip
Update 2.5.8 --> 2.5.10
Diffstat (limited to 'x11-wm/fvwm2-devel/Makefile')
-rw-r--r--x11-wm/fvwm2-devel/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/x11-wm/fvwm2-devel/Makefile b/x11-wm/fvwm2-devel/Makefile
index 40b6a903dee0..a311af3e775e 100644
--- a/x11-wm/fvwm2-devel/Makefile
+++ b/x11-wm/fvwm2-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fvwm
-PORTVERSION= 2.5.8
-PORTREVISION= 2
+PORTVERSION= 2.5.10
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-2/ \
http://www.fvwm.org/generated/icon_download/
@@ -22,10 +21,15 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= cy@FreeBSD.org
COMMENT= Popular virtual window manager for X
-CONFIGURE_ARGS= --with-iconv-library=${LOCALBASE}/lib \
- --with-iconv-includes=${LOCALBASE}/include
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft \
- biconv.2:${PORTSDIR}/converters/iconv
+.if defined(WITHOUT_ICONV)
+CONFIGURE_ARGS+= --disable-iconv
+.else
+LIB_DEPENDS+= biconv.2:${PORTSDIR}/converters/iconv
+CONFIGURE_ARGS+= --with-iconv-library=${LOCALBASE}/lib \
+ --with-iconv-includes=${LOCALBASE}/include
+.endif
+
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/Xft
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
.if defined(WITH_STROKE)
@@ -80,14 +84,16 @@ PKGNAMESUFFIX= -imlib
CONFIGURE_ARGS+= --enable-gtktest --enable-imlibtest
PLIST_SUB+= GTK=""
.else
-CONFIGURE_ARGS+= --disable-gtktest --disable-imlibtest
+CONFIGURE_ARGS+= --disable-gtktest --disable-imlibtest \
+ --with-gtk-prefix=/no/dir --with-imlib-prefix=/no/dir
PLIST_SUB+= GTK="@comment not installed: "
+WITHOUT_GNOME= true
.endif
-.if !defined(WITHOUT_GNOME)
-CONFIGURE_ARGS+= --with-gnome --enable-gnome-hints
-.else
+.if defined(WITHOUT_GNOME)
CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
+.else
+CONFIGURE_ARGS+= --with-gnome --enable-gnome-hints
.endif
MAN1= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
@@ -126,9 +132,9 @@ post-install:
fi
.if !defined(WITHOUT_ICONS)
- @${MKDIR} ${PREFIX}/share/fvwm2/pixmaps
+ @${MKDIR} ${PREFIX}/share/fvwm/pixmaps
${INSTALL_DATA} ${WRKDIR}/icons/fvwm_icons/*.xpm \
- ${PREFIX}/share/fvwm2/pixmaps
+ ${PREFIX}/share/fvwm/pixmaps
.endif
.include <bsd.port.post.mk>