aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/fvwm2-devel/files
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-09-14 06:11:34 +0800
committerdanfe <danfe@FreeBSD.org>2005-09-14 06:11:34 +0800
commit5e6975f492fcd5ae8dfcab9f0fd8068c9ae9cabd (patch)
tree2cee7b37f97378354cca21f1339c86c468d8fd68 /x11-wm/fvwm2-devel/files
parent56c8eabc43530a4f820831384a40112f5a8ea8d4 (diff)
downloadfreebsd-ports-gnome-5e6975f492fcd5ae8dfcab9f0fd8068c9ae9cabd.tar.gz
freebsd-ports-gnome-5e6975f492fcd5ae8dfcab9f0fd8068c9ae9cabd.tar.zst
freebsd-ports-gnome-5e6975f492fcd5ae8dfcab9f0fd8068c9ae9cabd.zip
- Convert to OPTIONS
- Switch from rarely used biconv.2 to standard iconv.3 - Add WITH_RPLAY knob, kill WITHOUT_XINERAMA since it was of little use - Fix WITH_BIDI case (missing fribidi.0 dependency) - Remove evil `-imlib' PKGNAMESUFFIX - Do not forget FvwmGtk.1 in MAN1 - Fix NLS detection (and handle WITHOUT_NLS knob) - Adjust PLIST accordingly - Utilize DATADIR in pkg-plist - Pacify portlint to some degree PR: ports/81440 Submitted by: yours truly Approved by: maintainer
Diffstat (limited to 'x11-wm/fvwm2-devel/files')
-rw-r--r--x11-wm/fvwm2-devel/files/patch-configure171
1 files changed, 171 insertions, 0 deletions
diff --git a/x11-wm/fvwm2-devel/files/patch-configure b/x11-wm/fvwm2-devel/files/patch-configure
index a25c9230691d..608a507b3ce3 100644
--- a/x11-wm/fvwm2-devel/files/patch-configure
+++ b/x11-wm/fvwm2-devel/files/patch-configure
@@ -59,3 +59,174 @@
problem_png=""
else
with_png=no
+@@ -10812,149 +10812,6 @@
+
+ found_gettext=yes
+
+- $UNSET ac_cv_header_intl_h
+- $UNSET ac_cv_func_gettext
+- $UNSET ac_cv_func_bindtextdomain
+- $UNSET ac_cv_func_textdomain
+- $UNSET ac_cv_func_dgettext
+- #bind_textdomain_codeset
+- if test "${ac_cv_header_libintl_h+set}" = set; then
+- echo "$as_me:$LINENO: checking for libintl.h" >&5
+-echo $ECHO_N "checking for libintl.h... $ECHO_C" >&6
+-if test "${ac_cv_header_libintl_h+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_header_libintl_h" >&5
+-echo "${ECHO_T}$ac_cv_header_libintl_h" >&6
+-else
+- # Is the header compilable?
+-echo "$as_me:$LINENO: checking libintl.h usability" >&5
+-echo $ECHO_N "checking libintl.h usability... $ECHO_C" >&6
+-cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-$ac_includes_default
+-#include <libintl.h>
+-_ACEOF
+-rm -f conftest.$ac_objext
+-if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_header_compiler=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-ac_header_compiler=no
+-fi
+-rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
+-echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
+-echo "${ECHO_T}$ac_header_compiler" >&6
+-
+-# Is the header present?
+-echo "$as_me:$LINENO: checking libintl.h presence" >&5
+-echo $ECHO_N "checking libintl.h presence... $ECHO_C" >&6
+-cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-#include <libintl.h>
+-_ACEOF
+-if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
+- (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } >/dev/null; then
+- if test -s conftest.err; then
+- ac_cpp_err=$ac_c_preproc_warn_flag
+- ac_cpp_err=$ac_cpp_err$ac_c_werror_flag
+- else
+- ac_cpp_err=
+- fi
+-else
+- ac_cpp_err=yes
+-fi
+-if test -z "$ac_cpp_err"; then
+- ac_header_preproc=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+- ac_header_preproc=no
+-fi
+-rm -f conftest.err conftest.$ac_ext
+-echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
+-echo "${ECHO_T}$ac_header_preproc" >&6
+-
+-# So? What about this header?
+-case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
+- yes:no: )
+- { echo "$as_me:$LINENO: WARNING: libintl.h: accepted by the compiler, rejected by the preprocessor!" >&5
+-echo "$as_me: WARNING: libintl.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: proceeding with the compiler's result" >&5
+-echo "$as_me: WARNING: libintl.h: proceeding with the compiler's result" >&2;}
+- ac_header_preproc=yes
+- ;;
+- no:yes:* )
+- { echo "$as_me:$LINENO: WARNING: libintl.h: present but cannot be compiled" >&5
+-echo "$as_me: WARNING: libintl.h: present but cannot be compiled" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: check for missing prerequisite headers?" >&5
+-echo "$as_me: WARNING: libintl.h: check for missing prerequisite headers?" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: see the Autoconf documentation" >&5
+-echo "$as_me: WARNING: libintl.h: see the Autoconf documentation" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: section \"Present But Cannot Be Compiled\"" >&5
+-echo "$as_me: WARNING: libintl.h: section \"Present But Cannot Be Compiled\"" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: proceeding with the preprocessor's result" >&5
+-echo "$as_me: WARNING: libintl.h: proceeding with the preprocessor's result" >&2;}
+- { echo "$as_me:$LINENO: WARNING: libintl.h: in the future, the compiler will take precedence" >&5
+-echo "$as_me: WARNING: libintl.h: in the future, the compiler will take precedence" >&2;}
+- (
+- cat <<\_ASBOX
+-## ------------------------------------------ ##
+-## Report this to the AC_PACKAGE_NAME lists. ##
+-## ------------------------------------------ ##
+-_ASBOX
+- ) |
+- sed "s/^/$as_me: WARNING: /" >&2
+- ;;
+-esac
+-echo "$as_me:$LINENO: checking for libintl.h" >&5
+-echo $ECHO_N "checking for libintl.h... $ECHO_C" >&6
+-if test "${ac_cv_header_libintl_h+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_cv_header_libintl_h=$ac_header_preproc
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_header_libintl_h" >&5
+-echo "${ECHO_T}$ac_cv_header_libintl_h" >&6
+-
+-fi
+-if test $ac_cv_header_libintl_h = yes; then
+
+
+
+@@ -11588,7 +11445,7 @@
+ fi
+
+ if test "$no_dgettext" != "yes"; then
+- CFLAGS="$CFLAGS $intl_LIBS $iconv_LIBS"
++ CFLAGS="$CFLAGS $intl_CFLAGS $iconv_CFLAGS"
+ LIBS="$LIBS $intl_LIBS $iconv_LIBS"
+ echo "$as_me:$LINENO: checking if a simple gettext program link" >&5
+ echo $ECHO_N "checking if a simple gettext program link... $ECHO_C" >&6
+@@ -11665,10 +11522,8 @@
+ else
+ with_gettext="no"
+ problem_gettext=": Failed to detected GNU gettext"
++ USE_NLS=no
+ fi
+-else
+- USE_NLS=no
+-fi
+
+ # libs and buil
+