aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/fvwm2/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-05-27 08:10:24 +0800
committerpetef <petef@FreeBSD.org>2002-05-27 08:10:24 +0800
commit1768574b7d8952d710d384b2cfe72d5a0b0ae32c (patch)
tree5fe2bbf770dbb05888eaabd5dc35515d65659cd8 /x11-wm/fvwm2/Makefile
parenta8b2e2bd777003d6ac5a149f57b2bc97ebbf2a25 (diff)
downloadfreebsd-ports-gnome-1768574b7d8952d710d384b2cfe72d5a0b0ae32c.tar.gz
freebsd-ports-gnome-1768574b7d8952d710d384b2cfe72d5a0b0ae32c.tar.zst
freebsd-ports-gnome-1768574b7d8952d710d384b2cfe72d5a0b0ae32c.zip
Only depend on GTK & Imlib if we're buildling the GNOME version.
Submitted by: AMAKAWA Shuhei <sa264@cam.ac.uk>
Diffstat (limited to 'x11-wm/fvwm2/Makefile')
-rw-r--r--x11-wm/fvwm2/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-wm/fvwm2/Makefile b/x11-wm/fvwm2/Makefile
index 72e59ee515c1..219754ff6ae7 100644
--- a/x11-wm/fvwm2/Makefile
+++ b/x11-wm/fvwm2/Makefile
@@ -23,11 +23,16 @@ LIB_DEPENDS+= stroke.0:${PORTSDIR}/devel/libstroke
.endif
USE_GMAKE= yes
-USE_GTK= yes
-USE_IMLIB= yes
USE_XPM= yes
USE_X_PREFIX= yes
+
+.include <bsd.port.pre.mk>
+
WANT_GNOME= yes
+.if defined(HAVE_GNOME)
+USE_GTK= yes
+USE_IMLIB= yes
+.endif
GNU_CONFIGURE= yes
@@ -46,13 +51,12 @@ CONFIGURE_ARGS+= --disable-shape
PLIST_SUB+= FVWM_VERSION="${PORTVERSION}"
-.include <bsd.port.pre.mk>
-
.if defined(HAVE_GNOME)
USE_GNOME= yes
PLIST_SUB+= GNOMEDATADIR="share/gnome/fvwm"
.else
-CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints
+CONFIGURE_ARGS+= --without-gnome --disable-gnome-hints \
+ --disable-gtktest --disable-imlibtest
PLIST_SUB+= GNOMEDATADIR="share/fvwm"
.endif