aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/fvwm95
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2002-09-10 01:31:11 +0800
committerdemon <demon@FreeBSD.org>2002-09-10 01:31:11 +0800
commitae1c51995ebcbaa0af9bff692f61198c9f01b36b (patch)
treea07c5c690bd3a0f9b9594d779aedf3e889bb60be /x11-wm/fvwm95
parentb9a37a0764b1e021e6441c62fb89caa54c15f20e (diff)
downloadfreebsd-ports-gnome-ae1c51995ebcbaa0af9bff692f61198c9f01b36b.tar.gz
freebsd-ports-gnome-ae1c51995ebcbaa0af9bff692f61198c9f01b36b.tar.zst
freebsd-ports-gnome-ae1c51995ebcbaa0af9bff692f61198c9f01b36b.zip
Fix a bug which prevents fvwm95 from displaying a mail-notification
icon if one tries to use a mailbox other than the default one. Submitted by: Dmitry Sagalovskiy <dsagal@runningwave.com>
Diffstat (limited to 'x11-wm/fvwm95')
-rw-r--r--x11-wm/fvwm95/Makefile1
-rw-r--r--x11-wm/fvwm95/files/patch-modules-FvwmTaskBar-Goodies.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/x11-wm/fvwm95/Makefile b/x11-wm/fvwm95/Makefile
index c2a8bc9d8e39..354224aa5e3c 100644
--- a/x11-wm/fvwm95/Makefile
+++ b/x11-wm/fvwm95/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fvwm95
PORTVERSION= 2.0.43a
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= http://ftp.yars.free.net/pub/software/unix/platforms/linux/x/fvwm95/ \
http://ftp.cc.ntut.edu.tw/ftp/Xwindow/xfree86/Linux/wm/fvwm-95/
diff --git a/x11-wm/fvwm95/files/patch-modules-FvwmTaskBar-Goodies.c b/x11-wm/fvwm95/files/patch-modules-FvwmTaskBar-Goodies.c
new file mode 100644
index 000000000000..45cf038f553e
--- /dev/null
+++ b/x11-wm/fvwm95/files/patch-modules-FvwmTaskBar-Goodies.c
@@ -0,0 +1,13 @@
+--- modules/FvwmTaskBar/Goodies.c.orig Mon Sep 9 21:27:48 2002
++++ modules/FvwmTaskBar/Goodies.c Mon Sep 9 21:28:44 2002
+@@ -64,7 +64,9 @@
+ if (strcasecmp(&tline[Clength+8], "None") == 0) {
+ NoMailCheck = True;
+ } else {
+- UpdateString(&mailpath, &tline[Clength+11]);
++ /* UpdateString doesn't string spaces or newlines (and +11 is wrong) */
++ /* UpdateString(&mailpath, &tline[Clength+11]); */
++ CopyString(&mailpath, &tline[Clength+8]);
+ }
+ } else if(strncasecmp(tline,CatString3(Module, "ClockFormat",""),
+ Clength+11)==0) {