aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/golem
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-31 22:49:26 +0800
committerbapt <bapt@FreeBSD.org>2012-05-31 22:49:26 +0800
commit66780caf231381add129f8ab44ca54133051a1c5 (patch)
tree986ee858a70982e7ead92499315df9c0231da04d /x11-wm/golem
parent4297676582426ca3d54e1c10bdf5464fe141fb96 (diff)
downloadfreebsd-ports-gnome-66780caf231381add129f8ab44ca54133051a1c5.tar.gz
freebsd-ports-gnome-66780caf231381add129f8ab44ca54133051a1c5.tar.zst
freebsd-ports-gnome-66780caf231381add129f8ab44ca54133051a1c5.zip
Convert to new options framework
Diffstat (limited to 'x11-wm/golem')
-rw-r--r--x11-wm/golem/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11-wm/golem/Makefile b/x11-wm/golem/Makefile
index a7ed172e835d..b96bfd7af370 100644
--- a/x11-wm/golem/Makefile
+++ b/x11-wm/golem/Makefile
@@ -15,8 +15,8 @@ COMMENT= Small window manager with themes and plugins
LICENSE= BSD
-OPTIONS= ESOUND "Build sound plugin (requires EsounD)" off \
- XINERAMA "Enable Xinerama extension support" on
+OPTIONS_DEFINE= ESOUND XINERAMA
+OPTIONS_DEFAULT= XINERAMA
USE_PERL5_BUILD=yes
USE_BZIP2= yes
@@ -39,7 +39,7 @@ CFLAGS+= -fPIC
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-.if defined(WITH_ESOUND)
+.if ${PORT_OPTIONS:MESOUND}
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-sound
PLIST_SUB+= ESOUND=""
@@ -47,7 +47,7 @@ PLIST_SUB+= ESOUND=""
PLIST_SUB+= ESOUND="@comment "
.endif
-.if !defined(WITHOUT_XINERAMA)
+.if ${PORT_OPTIONS:MXINERAMA}
USE_XORG+= xinerama
CONFIGURE_ARGS+=--enable-xinerama
.endif