aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/icepref/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-13 07:36:23 +0800
committerwill <will@FreeBSD.org>2000-06-13 07:36:23 +0800
commit193f7f3320a32dcbd0217a6a297565bd0157c5f7 (patch)
treeba81334504f61ae291a5e4776430959c9e3b41d7 /x11-wm/icepref/Makefile
parent4f8670884529ed833e009b86f5061885f6145d5e (diff)
downloadfreebsd-ports-gnome-193f7f3320a32dcbd0217a6a297565bd0157c5f7.tar.gz
freebsd-ports-gnome-193f7f3320a32dcbd0217a6a297565bd0157c5f7.tar.zst
freebsd-ports-gnome-193f7f3320a32dcbd0217a6a297565bd0157c5f7.zip
Add icepref, a small graphical configuration utility for IceWM.
PR: 19097 Submitted by: Michael Urban <murban@tznet.com>
Diffstat (limited to 'x11-wm/icepref/Makefile')
-rw-r--r--x11-wm/icepref/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-wm/icepref/Makefile b/x11-wm/icepref/Makefile
new file mode 100644
index 000000000000..b26d24fa3b16
--- /dev/null
+++ b/x11-wm/icepref/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: icepref
+# Date created: 06 June 2000
+# Whom: Michael Urban <murban@tznet.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icepref
+PORTVERSION= 1.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://209.132.18.205/downloads/portfiles/
+
+MAINTAINER= murban@tznet.com
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= ${LOCALBASE}/lib/python1.5/site-packages/GTK.py:${PORTSDIR}/x11-toolkits/py-gtk
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_X_PREFIX= yes
+NO_BUILD= yes
+MAN1= icepref.1
+FETCH_BEFORE_ARGS= -b
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS="@comment "
+.else
+PLIST_SUB+= PORTDOCS=""
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/icepref ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/icepref.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/icepref
+.for DOC in README FAQ LICENSE
+ ${INSTALL_DATA} ${WRKSRC}/${DOC} ${PREFIX}/share/doc/icepref
+.endfor
+.endif
+
+.include <bsd.port.mk>