aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/icewm
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-08-17 03:49:34 +0800
committerkrion <krion@FreeBSD.org>2004-08-17 03:49:34 +0800
commit4d4c4ab66e5d9a55f38a04edbaa008561f616e9d (patch)
tree392c1c4e41bcaa8ca8c07f2d5b7952bd3df3fe84 /x11-wm/icewm
parent1e341f72db922a9e4e64a7d603fbc8c1304cfbc2 (diff)
downloadfreebsd-ports-gnome-4d4c4ab66e5d9a55f38a04edbaa008561f616e9d.tar.gz
freebsd-ports-gnome-4d4c4ab66e5d9a55f38a04edbaa008561f616e9d.tar.zst
freebsd-ports-gnome-4d4c4ab66e5d9a55f38a04edbaa008561f616e9d.zip
Update to verion 1.2.16
PR: ports/70549 Submitted by: Ports Fury
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Makefile6
-rw-r--r--x11-wm/icewm/distinfo4
-rw-r--r--x11-wm/icewm/files/patch-ak75
-rw-r--r--x11-wm/icewm/files/patch-configure.in56
-rw-r--r--x11-wm/icewm/files/patch-src_aapm.h18
-rw-r--r--x11-wm/icewm/files/patch-src_icesound.cc48
-rw-r--r--x11-wm/icewm/files/patch-src_ycmdline.cc11
-rw-r--r--x11-wm/icewm/pkg-plist2
8 files changed, 7 insertions, 213 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 64b101d9d02d..bc04b19b581b 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= icewm
-PORTVERSION= 1.2.14
-PORTREVISION= 1
+PORTVERSION= 1.2.16
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +19,7 @@ WANT_GNOME= yes
USE_GNOME= gnometarget
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 259
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --enable-shaped-decorations \
@@ -62,6 +61,7 @@ CONFIGURE_ARGS+= --with-icesound=oss
CONFIGURE_ARGS+= --enable-corefonts --disable-xfreetype
.else
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --enable-gradients
.endif
.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XINERAMA)
diff --git a/x11-wm/icewm/distinfo b/x11-wm/icewm/distinfo
index 938bfc06aa11..14e7fcb8a250 100644
--- a/x11-wm/icewm/distinfo
+++ b/x11-wm/icewm/distinfo
@@ -1,2 +1,2 @@
-MD5 (icewm-1.2.14.tar.gz) = 1a5670fd074731766a64d5905bad773f
-SIZE (icewm-1.2.14.tar.gz) = 932635
+MD5 (icewm-1.2.16.tar.gz) = 1aa92846cc516a2ac1d668d80c3ca5ea
+SIZE (icewm-1.2.16.tar.gz) = 947114
diff --git a/x11-wm/icewm/files/patch-ak b/x11-wm/icewm/files/patch-ak
deleted file mode 100644
index c06a68797b72..000000000000
--- a/x11-wm/icewm/files/patch-ak
+++ /dev/null
@@ -1,75 +0,0 @@
---- src/aapm.cc.orig Sun Aug 24 23:59:24 2003
-+++ src/aapm.cc Wed Sep 17 03:11:49 2003
-@@ -26,6 +26,13 @@
- #include <string.h>
- #include <stdio.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/file.h>
-+#include <sys/ioctl.h>
-+#include <sys/types.h>
-+#include <machine/apm_bios.h>
-+#endif
-+
- YColor *YApm::apmBg = 0;
- YColor *YApm::apmFg = 0;
- YFont *YApm::apmFont = 0;
-@@ -47,8 +54,12 @@
-
-
- void ApmStr(char *s, bool Tool) {
-+#ifdef __FreeBSD__
-+ struct apm_info ai;
-+#else
- char buf[80];
-- int len, i, fd = open("/proc/apm", O_RDONLY);
-+#endif
-+ int len, i, fd = open(APMDEV, O_RDONLY);
- char driver[16];
- char apmver[16];
- int apmflags;
-@@ -60,9 +71,31 @@
- char units[16];
-
- if (fd == -1) {
-+ static int error = 0;
-+ if (!error)
-+ perror("Can't open the apm device");
-+ error = 1;
- return ;
- }
-+#ifdef __FreeBSD__
-+ if (ioctl(fd,APMIO_GETINFO, &ai) == -1)
-+ {
-+ static int error = 0;
-+ if (!error)
-+ perror("Can't ioctl the apm device");
-+ error = 1;
-+ close(fd);
-+ return;
-+ }
-+ close(fd);
-
-+ sprintf(apmver, "%u.%u", ai.ai_major, ai.ai_minor);
-+ ACstatus = ai.ai_acline;
-+ BATflag = ai.ai_batt_stat == 3 ? 8 : 0;
-+ BATlife = ai.ai_batt_life;
-+ BATtime = ai.ai_batt_time == 0 ? -1 : ai.ai_batt_time;
-+ strcpy(units, "sec");
-+#else
- len = read(fd, buf, sizeof(buf) - 1);
- close(fd);
-
-@@ -76,10 +109,11 @@
- static int error = 1;
- if (error) {
- error = 0;
-- warn(_("/proc/apm - unknown format (%d)"), i);
-+ warn(_("%s - unknown format (%d)"), APMDEV, i);
- }
- return ;
- }
-+#endif
- if (BATlife == -1)
- BATlife = 0;
-
diff --git a/x11-wm/icewm/files/patch-configure.in b/x11-wm/icewm/files/patch-configure.in
deleted file mode 100644
index 86fa0c8893e8..000000000000
--- a/x11-wm/icewm/files/patch-configure.in
+++ /dev/null
@@ -1,56 +0,0 @@
---- configure.in.orig Sun May 23 15:18:18 2004
-+++ configure.in Mon May 24 14:00:32 2004
-@@ -21,53 +21,8 @@
-
- dnl ---------- Checking for a C compiler in hope that it understands C++ too ---
- dnl
--ICE_PROG_CXX_LIGHT
- AC_LANG_CPLUSPLUS
- AC_PROG_CXX
--
--dnl ----------- If both CC and CXX are GNU compilers, it is better to use CC ---
--dnl ---- for linking.
--if test x"$ac_cv_prog_gxx" = x; then
-- AC_PROG_CC
-- if test x"$ac_cv_prog_gcc" = x; then
-- CXX_LINK=${CC}
-- fi
--fi
--
--dnl ---------- Also check how to turn off RTTI and exception handling ---
--
--dnl --- SunONE C++ supports no-rtti flag only in compat=4 mode
--if test -z "`${CXX} -V 2>&1 | grep Sun`"; then
-- ICE_CXX_FLAG_ACCEPT(no_rtti, -fno-rtti)
--fi
--dnl --- Intel C++ supports -fno-rtti, but doens't support -fno-*-exceptions
--if test $(basename $CXX) != "icc"; then
-- if test -n "`${CXX} -V 2>&1 | grep Sun`"; then
-- dnl --- Sun ONE C++ syntax for "no exceptions"
-- ICE_CXX_FLAG_ACCEPT(no_exceptions, -features=no%except)
-- else
-- if test $(basename $CXX) = "g++" ||
-- test $(basename $CXX) = "gcc"; then
-- ICE_CXX_FLAG_ACCEPT(no_exceptions, -fno-exceptions)
-- if test x"$no_exceptions_ok" = xno; then
-- ICE_CXX_FLAG_ACCEPT(no_exceptions, -fno-handle-exceptions)
-- fi
-- fi
-- fi
--fi
--
--if test $(basename $CXX) = "g++" ||
-- test $(basename $CXX) = "gcc" ; then
-- ICE_CXX_FLAG_ACCEPT(warn_xxx, -Wall -Wpointer-arith -Wconversion -Wwrite-strings -Winline -Woverloaded-virtual -W)
-- ICE_CXX_FLAG_ACCEPT(permissive, -fpermissive)
--else
-- dnl --- Sun ONE doesn't support GCC -W* and -fpermissive
-- dnl --- Intel C++ doesn't supports lots of GCC -W* and -fpermissive
-- if test $(basename $CXX) = "icc"; then
-- dnl --- Using -w0 to avoid noisy "remark" messages
-- ICE_CXX_FLAG_ACCEPT(warn_xxx, -w0)
-- fi
--fi
-
- if test x"$CXX_LINK" = x; then
- CXX_LINK=$CXX
diff --git a/x11-wm/icewm/files/patch-src_aapm.h b/x11-wm/icewm/files/patch-src_aapm.h
deleted file mode 100644
index 72f99dce21ff..000000000000
--- a/x11-wm/icewm/files/patch-src_aapm.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/aapm.h.orig Sat Sep 27 16:54:45 2003
-+++ src/aapm.h Sun Oct 19 09:17:31 2003
-@@ -1,7 +1,5 @@
-
--#ifndef linux
--#undef CONFIG_APPLET_APM
--#elif CONFIG_APPLET_APM
-+#if (defined(linux) || defined (__FreeBSD__)) && defined(i386)
-
- #include "ywindow.h"
- #include "ytimer.h"
-@@ -64,4 +62,6 @@
- char *acpiACName;
-
- };
-+#else
-+#undef CONFIG_APPLET_APM
- #endif
diff --git a/x11-wm/icewm/files/patch-src_icesound.cc b/x11-wm/icewm/files/patch-src_icesound.cc
deleted file mode 100644
index 09ce7bb6bcbe..000000000000
--- a/x11-wm/icewm/files/patch-src_icesound.cc
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/icesound.cc.orig Sun May 23 15:18:19 2004
-+++ src/icesound.cc Wed Aug 4 23:45:45 2004
-@@ -190,7 +190,8 @@
- virtual int init(int & argc, char **& argv);
-
- private:
-- friend class CommandLine : public YCommandLine {
-+ friend class CommandLine;
-+ class CommandLine : public YCommandLine {
- public:
- CommandLine(int & argc, char **& argv, YOSSAudio & oss):
- YCommandLine(argc, argv), oss(oss) {}
-@@ -226,6 +227,7 @@
- YOSSAudio & oss;
- };
-
-+ friend class CommandLine;
- char const * device;
- };
-
-@@ -326,7 +328,8 @@
- virtual int init(int & argc, char **& argv);
-
- private:
-- friend class CommandLine : public YCommandLine {
-+ friend class CommandLine;
-+ class CommandLine : public YCommandLine {
- public:
- CommandLine(int & argc, char **& argv, YESDAudio & esd):
- YCommandLine(argc, argv), esd(esd) {}
-@@ -364,6 +367,7 @@
- };
-
- protected:
-+ friend class CommandLine;
- char const * speaker;
- int sample[ACOUNT(gui_events)]; // cache sample ids
- int socket; // socket to ESound Daemon
-@@ -502,7 +506,8 @@
- Coefficient lVol = 1.0, Coefficient rVol = 1.0);
-
- private:
-- friend class CommandLine : public YCommandLine {
-+ friend class CommandLine;
-+ class CommandLine : public YCommandLine {
- public:
- CommandLine(int & argc, char **& argv, YY2Audio & yiff):
- YCommandLine(argc, argv), yiff(yiff) {}
diff --git a/x11-wm/icewm/files/patch-src_ycmdline.cc b/x11-wm/icewm/files/patch-src_ycmdline.cc
deleted file mode 100644
index 6e22f0892ad4..000000000000
--- a/x11-wm/icewm/files/patch-src_ycmdline.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ycmdline.cc.orig Sun May 23 15:18:19 2004
-+++ src/ycmdline.cc Wed Aug 4 23:25:42 2004
-@@ -55,7 +55,7 @@
- if (*vptr == '=') ++vptr;
- while (ASCII::isSpaceOrTab(*vptr)) ++vptr;
- } else { // ------------------------- value assumed in the next argument ---
-- int idx(&arg - argv + 1);
-+ int idx = &arg - static_cast<char const* const*>(argv) + 1;
-
- if (idx < argc) {
- vptr = argv[idx];
diff --git a/x11-wm/icewm/pkg-plist b/x11-wm/icewm/pkg-plist
index a354410aa314..39cbc7f933f2 100644
--- a/x11-wm/icewm/pkg-plist
+++ b/x11-wm/icewm/pkg-plist
@@ -24,6 +24,7 @@ bin/icewmtray
%%PORTDOCS%%%%DOCSDIR%%/icewm-18.html
%%PORTDOCS%%%%DOCSDIR%%/icewm-19.html
%%PORTDOCS%%%%DOCSDIR%%/icewm-2.html
+%%PORTDOCS%%%%DOCSDIR%%/icewm-20.html
%%PORTDOCS%%%%DOCSDIR%%/icewm-3.html
%%PORTDOCS%%%%DOCSDIR%%/icewm-4.html
%%PORTDOCS%%%%DOCSDIR%%/icewm-5.html
@@ -352,6 +353,7 @@ bin/icewmtray
%%NLS%%share/locale/pt_BR/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/ro/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/ru/LC_MESSAGES/icewm.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/sl/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/sv/LC_MESSAGES/icewm.mo
%%NLS%%share/locale/tr/LC_MESSAGES/icewm.mo