aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/matchbox/Makefile
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:40 +0800
committerlawrance <lawrance@FreeBSD.org>2006-02-13 18:03:40 +0800
commit90612dca75adcd000449221db4d61c9c8b9adda3 (patch)
treeb4eaa2f4fef277eaaf6c07fead56ef534b1fa03b /x11-wm/matchbox/Makefile
parentb95a97cb96490cbd755c9c326a7409be85671f76 (diff)
downloadfreebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.tar.gz
freebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.tar.zst
freebsd-ports-gnome-90612dca75adcd000449221db4d61c9c8b9adda3.zip
Update to 0.9.5.
PR: ports/93247 Submitted by: Ports Fury
Diffstat (limited to 'x11-wm/matchbox/Makefile')
-rw-r--r--x11-wm/matchbox/Makefile79
1 files changed, 31 insertions, 48 deletions
diff --git a/x11-wm/matchbox/Makefile b/x11-wm/matchbox/Makefile
index 6f56ecfdf210..2a2c68349535 100644
--- a/x11-wm/matchbox/Makefile
+++ b/x11-wm/matchbox/Makefile
@@ -6,65 +6,48 @@
#
PORTNAME= matchbox
-PORTVERSION= 0.3
+PORTVERSION= 0.9.5
CATEGORIES= x11-wm
-MASTER_SITES= http://handhelds.org/~mallum/downloadables/matchbox/
+MASTER_SITES= http://projects.o-hand.com/matchbox/sources/matchbox-window-manager/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION:R}
+DISTNAME= ${PORTNAME}-window-manager-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Window manager suitable for low-resolution screens
-DOCS= AUTHORS COPYING ChangeLog NEWS README TODO
-
-CONFIGURE_ARGS= --prefix=${PREFIX}
-GNU_CONFIGURE= yes
-MAN1= matchbox.1 mbcontrol.1 monolaunch.1 miniapm.1 minisys.1 minitime.1 minivol.1
-PLIST= ${WRKDIR}/pkg-plist
+USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-pre-install:
- ${ECHO_CMD} bin/matchbox > ${PLIST}
-.for ii in minitime minisys minivol monolaunch mbcontrol mbdock
- ${ECHO_CMD} bin/${ii} >> ${PLIST}
-.endfor
-.for ii in defaults icon.xpm
- ${ECHO_CMD} share/matchbox/${ii} >> ${PLIST}
-.endfor
-.for ii in mbdock themes
- cd ${WRKSRC}/data/${ii} && ${FIND} -s . -type f | \
- ${CUT} -c3-999 | \
- ${SED} -e 's:^:share/matchbox/${ii}/:' >> ${PLIST} \
- && ${FIND} -d . -type d | \
- ${CUT} -c3-999 | \
- ${SED} -e 's:^:@dirrm share/matchbox/${ii}/:' >> ${PLIST}
-.endfor
-.if !defined(NOPORTDOCS)
-.for ii in ${DOCS}
- ${ECHO_CMD} share/doc/matchbox/${ii} >> ${PLIST}
-.endfor
- ${ECHO_CMD} @dirrm share/doc/matchbox >> ${PLIST}
+PORTDOCS= ${DOCS}
+PLIST_FILES= bin/matchbox-window-manager bin/matchbox-remote \
+ etc/matchbox/kbdconfig
+PLIST_DIRS= etc/matchbox
+
+DOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3 || defined(WITHOUT_XFT)
+CONFIGURE_ARGS+= --enable-standalone
+.else
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --enable-standalone-xft
.endif
- ${ECHO_CMD} @dirrm share/matchbox >> ${PLIST}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox ${PREFIX}/bin
-.for ii in minitime minisys minivol monolaunch mbcontrol
- ${INSTALL_PROGRAM} ${WRKSRC}/util/${ii} ${PREFIX}/bin
-.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/dock/mbdock ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC}/data/ && ${PAX} -r -w themes ${DATADIR} \
- && ${PAX} -r -w mbdock ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox-remote ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/matchbox-window-manager ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/etc/matchbox
+ ${INSTALL_DATA} ${WRKSRC}/data/kbdconfig ${PREFIX}/etc/matchbox
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for ii in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.for ii in defaults icon.xpm
- ${INSTALL_DATA} ${WRKSRC}/data/${ii} ${DATADIR}
-.endfor
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${PREFIX}/man/man1/
-.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>