aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/mate-window-manager
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-11-23 19:39:07 +0800
committerkwm <kwm@FreeBSD.org>2013-11-23 19:39:07 +0800
commit7bca6ea6f563c85388f53d6aa74a11e52672425f (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /x11-wm/mate-window-manager
parent9a25b340e90f1811045215d11f228f12434fa124 (diff)
downloadfreebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.tar.gz
freebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.tar.zst
freebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.zip
Say hello to Mate 1.6.
Mate is a lite desktop forked from gnome2. Most of the work is done by Jeremy Messenger (mezz@). The only thing I did was update a few ports to later 1.6 release and attempting to keep up with ports infra changes. Resulting bugs are all mine. Mate is a sort of replacement for Gnome 2. So people wanting to keep a Gnome 2 like desktop should switch. Gnome 2 will be replaced by Gnome 3 in the near future. This switch will be announce with a transition time so people have more time to switch if they haven't already. This release was made possible by everyone that send friendly pokes to keep mate on my mind. Approved by: portmgr (bapt)
Diffstat (limited to 'x11-wm/mate-window-manager')
-rw-r--r--x11-wm/mate-window-manager/Makefile35
-rw-r--r--x11-wm/mate-window-manager/distinfo2
-rw-r--r--x11-wm/mate-window-manager/files/patch-src_core_delete.c10
-rw-r--r--x11-wm/mate-window-manager/files/patch-src_core_main.c14
-rw-r--r--x11-wm/mate-window-manager/pkg-descr6
-rw-r--r--x11-wm/mate-window-manager/pkg-plist256
6 files changed, 323 insertions, 0 deletions
diff --git a/x11-wm/mate-window-manager/Makefile b/x11-wm/mate-window-manager/Makefile
new file mode 100644
index 000000000000..0e5c16815b19
--- /dev/null
+++ b/x11-wm/mate-window-manager/Makefile
@@ -0,0 +1,35 @@
+# Created by: Garrett Rooney <rooneg@electricjellyfish.net>
+# $FreeBSD$
+
+PORTNAME= mate-window-manager
+PORTVERSION= 1.6.2
+CATEGORIES= x11-wm mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Window manager for the adult in you
+
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification \
+ libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= dialogs docutils
+USE_XORG= x11 xcomposite xcursor xdamage xrandr
+USE_GNOME= gdkpixbuf2 glib20 gnomehier gtk20 intlhack ltverhack pango
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.mate.marco.gschema.xml
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmarco-private.so.0
+
+.include <bsd.port.mk>
diff --git a/x11-wm/mate-window-manager/distinfo b/x11-wm/mate-window-manager/distinfo
new file mode 100644
index 000000000000..60f0ac571340
--- /dev/null
+++ b/x11-wm/mate-window-manager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-window-manager-1.6.2.tar.xz) = d4c887c7de76073409bf653701ae1d16d17ca5205776fd4dcc952cb3128120e1
+SIZE (mate/mate-window-manager-1.6.2.tar.xz) = 1102396
diff --git a/x11-wm/mate-window-manager/files/patch-src_core_delete.c b/x11-wm/mate-window-manager/files/patch-src_core_delete.c
new file mode 100644
index 000000000000..c72b0f60ae0e
--- /dev/null
+++ b/x11-wm/mate-window-manager/files/patch-src_core_delete.c
@@ -0,0 +1,10 @@
+--- src/core/delete.c.orig 2010-01-30 18:56:27.000000000 -0500
++++ src/core/delete.c 2010-01-30 18:56:53.000000000 -0500
+@@ -32,6 +32,7 @@
+ #include "workspace.h"
+
+ #include <sys/types.h>
++#include <sys/wait.h>
+ #include <signal.h>
+ #include <unistd.h>
+ #include <errno.h>
diff --git a/x11-wm/mate-window-manager/files/patch-src_core_main.c b/x11-wm/mate-window-manager/files/patch-src_core_main.c
new file mode 100644
index 000000000000..2d5171e5deda
--- /dev/null
+++ b/x11-wm/mate-window-manager/files/patch-src_core_main.c
@@ -0,0 +1,14 @@
+--- src/core/main.c.orig 2010-01-21 11:09:25.000000000 -0500
++++ src/core/main.c 2010-01-30 18:53:17.000000000 -0500
+@@ -58,7 +58,11 @@
+
+ #include <stdlib.h>
+ #include <sys/types.h>
++#ifdef __linux__
+ #include <wait.h>
++#else
++#include <sys/wait.h>
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <signal.h>
diff --git a/x11-wm/mate-window-manager/pkg-descr b/x11-wm/mate-window-manager/pkg-descr
new file mode 100644
index 000000000000..7dc83a91914b
--- /dev/null
+++ b/x11-wm/mate-window-manager/pkg-descr
@@ -0,0 +1,6 @@
+Marco (mate-window-manager) is a low-frills Window Manager, and
+is the default Window Manager of the MATE desktop. It provides
+most of the features expected of a Window Manager, but leaves
+everything it can up to other components of the MATE environment.
+
+WWW: http://mate-desktop.org/
diff --git a/x11-wm/mate-window-manager/pkg-plist b/x11-wm/mate-window-manager/pkg-plist
new file mode 100644
index 000000000000..4c06b21e2b6f
--- /dev/null
+++ b/x11-wm/mate-window-manager/pkg-plist
@@ -0,0 +1,256 @@
+bin/marco
+bin/marco-message
+bin/marco-theme-viewer
+bin/marco-window-demo
+include/marco-1/marco-private/boxes.h
+include/marco-1/marco-private/common.h
+include/marco-1/marco-private/gradient.h
+include/marco-1/marco-private/preview-widget.h
+include/marco-1/marco-private/theme-parser.h
+include/marco-1/marco-private/theme.h
+include/marco-1/marco-private/util.h
+lib/libmarco-private.a
+lib/libmarco-private.la
+lib/libmarco-private.so
+lib/libmarco-private.so.0
+libdata/pkgconfig/libmarco-private.pc
+man/man1/marco-message.1.gz
+man/man1/marco-theme-viewer.1.gz
+man/man1/marco-window-demo.1.gz
+man/man1/marco.1.gz
+share/MateConf/gsettings/marco.convert
+share/applications/marco.desktop
+share/locale/am/LC_MESSAGES/marco.mo
+share/locale/ar/LC_MESSAGES/marco.mo
+share/locale/as/LC_MESSAGES/marco.mo
+share/locale/ast/LC_MESSAGES/marco.mo
+share/locale/az/LC_MESSAGES/marco.mo
+share/locale/be/LC_MESSAGES/marco.mo
+share/locale/be@latin/LC_MESSAGES/marco.mo
+share/locale/bg/LC_MESSAGES/marco.mo
+share/locale/bn/LC_MESSAGES/marco.mo
+share/locale/bn_IN/LC_MESSAGES/marco.mo
+share/locale/br/LC_MESSAGES/marco.mo
+share/locale/bs/LC_MESSAGES/marco.mo
+share/locale/ca/LC_MESSAGES/marco.mo
+share/locale/ca@valencia/LC_MESSAGES/marco.mo
+share/locale/crh/LC_MESSAGES/marco.mo
+share/locale/cs/LC_MESSAGES/marco.mo
+share/locale/cy/LC_MESSAGES/marco.mo
+share/locale/da/LC_MESSAGES/marco.mo
+share/locale/de/LC_MESSAGES/marco.mo
+share/locale/dz/LC_MESSAGES/marco.mo
+share/locale/el/LC_MESSAGES/marco.mo
+share/locale/en@shaw/LC_MESSAGES/marco.mo
+share/locale/en_AU/LC_MESSAGES/marco.mo
+share/locale/en_CA/LC_MESSAGES/marco.mo
+share/locale/en_GB/LC_MESSAGES/marco.mo
+share/locale/eo/LC_MESSAGES/marco.mo
+share/locale/es/LC_MESSAGES/marco.mo
+share/locale/et/LC_MESSAGES/marco.mo
+share/locale/eu/LC_MESSAGES/marco.mo
+share/locale/fa/LC_MESSAGES/marco.mo
+share/locale/fi/LC_MESSAGES/marco.mo
+share/locale/fr/LC_MESSAGES/marco.mo
+share/locale/ga/LC_MESSAGES/marco.mo
+share/locale/gl/LC_MESSAGES/marco.mo
+share/locale/gu/LC_MESSAGES/marco.mo
+share/locale/ha/LC_MESSAGES/marco.mo
+share/locale/he/LC_MESSAGES/marco.mo
+share/locale/hi/LC_MESSAGES/marco.mo
+share/locale/hr/LC_MESSAGES/marco.mo
+share/locale/hu/LC_MESSAGES/marco.mo
+share/locale/hy/LC_MESSAGES/marco.mo
+share/locale/id/LC_MESSAGES/marco.mo
+share/locale/ig/LC_MESSAGES/marco.mo
+share/locale/is/LC_MESSAGES/marco.mo
+share/locale/it/LC_MESSAGES/marco.mo
+share/locale/ja/LC_MESSAGES/marco.mo
+share/locale/ka/LC_MESSAGES/marco.mo
+share/locale/kn/LC_MESSAGES/marco.mo
+share/locale/ko/LC_MESSAGES/marco.mo
+share/locale/ku/LC_MESSAGES/marco.mo
+share/locale/ky/LC_MESSAGES/marco.mo
+share/locale/la/LC_MESSAGES/marco.mo
+share/locale/lt/LC_MESSAGES/marco.mo
+share/locale/lv/LC_MESSAGES/marco.mo
+share/locale/mai/LC_MESSAGES/marco.mo
+share/locale/mg/LC_MESSAGES/marco.mo
+share/locale/mk/LC_MESSAGES/marco.mo
+share/locale/ml/LC_MESSAGES/marco.mo
+share/locale/mn/LC_MESSAGES/marco.mo
+share/locale/mr/LC_MESSAGES/marco.mo
+share/locale/ms/LC_MESSAGES/marco.mo
+share/locale/nb/LC_MESSAGES/marco.mo
+share/locale/nds/LC_MESSAGES/marco.mo
+share/locale/ne/LC_MESSAGES/marco.mo
+share/locale/nl/LC_MESSAGES/marco.mo
+share/locale/nn/LC_MESSAGES/marco.mo
+share/locale/oc/LC_MESSAGES/marco.mo
+share/locale/or/LC_MESSAGES/marco.mo
+share/locale/pa/LC_MESSAGES/marco.mo
+share/locale/pl/LC_MESSAGES/marco.mo
+share/locale/pt/LC_MESSAGES/marco.mo
+share/locale/pt_BR/LC_MESSAGES/marco.mo
+share/locale/ro/LC_MESSAGES/marco.mo
+share/locale/ru/LC_MESSAGES/marco.mo
+share/locale/rw/LC_MESSAGES/marco.mo
+share/locale/si/LC_MESSAGES/marco.mo
+share/locale/sk/LC_MESSAGES/marco.mo
+share/locale/sl/LC_MESSAGES/marco.mo
+share/locale/sq/LC_MESSAGES/marco.mo
+share/locale/sr/LC_MESSAGES/marco.mo
+share/locale/sr@latin/LC_MESSAGES/marco.mo
+share/locale/sv/LC_MESSAGES/marco.mo
+share/locale/ta/LC_MESSAGES/marco.mo
+share/locale/te/LC_MESSAGES/marco.mo
+share/locale/th/LC_MESSAGES/marco.mo
+share/locale/tk/LC_MESSAGES/marco.mo
+share/locale/tr/LC_MESSAGES/marco.mo
+share/locale/uk/LC_MESSAGES/marco.mo
+share/locale/vi/LC_MESSAGES/marco.mo
+share/locale/wa/LC_MESSAGES/marco.mo
+share/locale/xh/LC_MESSAGES/marco.mo
+share/locale/yo/LC_MESSAGES/marco.mo
+share/locale/zh_CN/LC_MESSAGES/marco.mo
+share/locale/zh_HK/LC_MESSAGES/marco.mo
+share/locale/zh_TW/LC_MESSAGES/marco.mo
+share/mate-window-manager/icons/marco-window-demo.png
+share/mate-control-center/keybindings/50-marco-desktop-key.xml
+share/mate-control-center/keybindings/50-marco-global-key.xml
+share/mate-control-center/keybindings/50-marco-window-key.xml
+share/mate/help/creating-marco-themes/C/creating-marco-themes.xml
+share/mate/wm-properties/marco-wm.desktop
+share/themes/ClearlooksRe/metacity-1/metacity-theme-1.xml
+share/themes/Dopple-Left/metacity-1/metacity-theme-1.xml
+share/themes/Dopple/metacity-1/metacity-theme-1.xml
+share/themes/DustBlue/metacity-1/button_close_normal.png
+share/themes/DustBlue/metacity-1/button_close_prelight.png
+share/themes/DustBlue/metacity-1/button_close_pressed.png
+share/themes/DustBlue/metacity-1/button_max_normal.png
+share/themes/DustBlue/metacity-1/button_max_prelight.png
+share/themes/DustBlue/metacity-1/button_max_pressed.png
+share/themes/DustBlue/metacity-1/button_menu_normal.png
+share/themes/DustBlue/metacity-1/button_menu_prelight.png
+share/themes/DustBlue/metacity-1/button_menu_pressed.png
+share/themes/DustBlue/metacity-1/button_min_normal.png
+share/themes/DustBlue/metacity-1/button_min_prelight.png
+share/themes/DustBlue/metacity-1/button_min_pressed.png
+share/themes/DustBlue/metacity-1/menu.png
+share/themes/DustBlue/metacity-1/metacity-theme-1.xml
+share/themes/Spidey-Left/metacity-1/metacity-theme-1.xml
+share/themes/Spidey/metacity-1/metacity-theme-1.xml
+share/themes/Splint-Left/metacity-1/metacity-theme-1.xml
+share/themes/Splint/metacity-1/metacity-theme-1.xml
+share/themes/WinMe/metacity-1/close_normal.png
+share/themes/WinMe/metacity-1/close_normal_small.png
+share/themes/WinMe/metacity-1/close_pressed.png
+share/themes/WinMe/metacity-1/close_pressed_small.png
+share/themes/WinMe/metacity-1/maximize_normal.png
+share/themes/WinMe/metacity-1/maximize_pressed.png
+share/themes/WinMe/metacity-1/metacity-theme-1.xml
+share/themes/WinMe/metacity-1/minimize_normal.png
+share/themes/WinMe/metacity-1/minimize_pressed.png
+share/themes/WinMe/metacity-1/restore_normal.png
+share/themes/WinMe/metacity-1/restore_pressed.png
+share/themes/eOS/metacity-1/close.png
+share/themes/eOS/metacity-1/close_unfocused.png
+share/themes/eOS/metacity-1/close_unfocused_over.png
+share/themes/eOS/metacity-1/maximize.png
+share/themes/eOS/metacity-1/maximize_unfocused.png
+share/themes/eOS/metacity-1/maximize_unfocused_over.png
+share/themes/eOS/metacity-1/menu.png
+share/themes/eOS/metacity-1/menu_prelight.png
+share/themes/eOS/metacity-1/metacity-theme-1.xml
+share/themes/eOS/metacity-1/minimize.png
+share/themes/eOS/metacity-1/minimize_unfocused.png
+share/themes/eOS/metacity-1/minimize_unfocused_over.png
+share/themes/eOS/metacity-1/trough_left.png
+share/themes/eOS/metacity-1/trough_left_unfocused.png
+share/themes/eOS/metacity-1/trough_middle.png
+share/themes/eOS/metacity-1/trough_middle_unfocused.png
+share/themes/eOS/metacity-1/trough_right.png
+share/themes/eOS/metacity-1/trough_right_unfocused.png
+share/themes/eOS/metacity-1/unmaximize.png
+share/themes/eOS/metacity-1/unmaximize_unfocused.png
+share/themes/eOS/metacity-1/unmaximize_unfocused_over.png
+@dirrm share/themes/eOS/metacity-1
+@dirrm share/themes/eOS
+@dirrm share/themes/WinMe/metacity-1
+@dirrm share/themes/WinMe
+@dirrm share/themes/Splint/metacity-1
+@dirrm share/themes/Splint-Left/metacity-1
+@dirrm share/themes/Splint-Left
+@dirrm share/themes/Splint
+@dirrm share/themes/Spidey/metacity-1
+@dirrm share/themes/Spidey-Left/metacity-1
+@dirrm share/themes/Spidey-Left
+@dirrm share/themes/Spidey
+@dirrm share/themes/DustBlue/metacity-1
+@dirrm share/themes/DustBlue
+@dirrm share/themes/Dopple/metacity-1
+@dirrm share/themes/Dopple-Left/metacity-1
+@dirrm share/themes/Dopple-Left
+@dirrm share/themes/Dopple
+@dirrm share/themes/ClearlooksRe/metacity-1
+@dirrm share/themes/ClearlooksRe
+@dirrmtry share/themes
+@dirrm share/mate/wm-properties
+@dirrm share/mate/help/creating-marco-themes/C
+@dirrm share/mate/help/creating-marco-themes
+@dirrm share/mate-window-manager/icons
+@dirrm share/mate-window-manager
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/yo/LC_MESSAGES
+@dirrmtry share/locale/yo
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ig/LC_MESSAGES
+@dirrmtry share/locale/ig
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/ha/LC_MESSAGES
+@dirrmtry share/locale/ha
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/crh/LC_MESSAGES
+@dirrmtry share/locale/crh
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrm include/marco-1/marco-private
+@dirrm include/marco-1