aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/mcwm/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-17 21:17:13 +0800
committermiwi <miwi@FreeBSD.org>2011-03-17 21:17:13 +0800
commit87f1cf28401db0de95d42f49ab2deaa3b51d47d7 (patch)
treef9a068ce529461bc3ee518ce32d5a822dc11f060 /x11-wm/mcwm/Makefile
parent0d7b006ed077cdee12eb21e18dec6f349e5ae233 (diff)
downloadfreebsd-ports-gnome-87f1cf28401db0de95d42f49ab2deaa3b51d47d7.tar.gz
freebsd-ports-gnome-87f1cf28401db0de95d42f49ab2deaa3b51d47d7.tar.zst
freebsd-ports-gnome-87f1cf28401db0de95d42f49ab2deaa3b51d47d7.zip
mcwm is a minimalistic floating window manager for the X Window System.
It is built directly on top of XCB, the C binding for the X11 protocol. It doesn't use the Xlib API at all. All functions are available from the keyboard, but the mouse can be used for moving,resizing and raise/lower. WWW: http://hack.org/mc/hacks/mcwm/ PR: ports/155610 Submitted by: Jakub Lach <jakub_lach at mailplus.pl>
Diffstat (limited to 'x11-wm/mcwm/Makefile')
-rw-r--r--x11-wm/mcwm/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/mcwm/Makefile b/x11-wm/mcwm/Makefile
new file mode 100644
index 000000000000..c54805966b28
--- /dev/null
+++ b/x11-wm/mcwm/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mcwm
+# Date created: 16 March 2011
+# Whom: Jakub Lach <jakub_lach@mailplus.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcwm
+PORTVERSION= 20110308
+CATEGORIES= x11-wm
+MASTER_SITES= http://hack.org/mc/hacks/mcwm/
+
+MAINTAINER= jakub_lach@mailplus.pl
+COMMENT= A small window manager inspired by CTWM, evilwm, and tinywm
+
+BUILD_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
+RUN_DEPENDS= xcb-util>=0.3.6:${PORTSDIR}/x11/xcb-util
+
+USE_XORG= x11
+USE_BZIP2= yes
+
+MAN1= mcwm.1
+PLIST_FILES= bin/mcwm
+PORTDOCS= LICENSE README
+
+pre-everything::
+ @${ECHO_MSG} "You can build mcwm with your own config.h using the MCWM_CONF knob:"
+ @${ECHO_MSG} "make MCWM_CONF=/path/to/dwm/config.h install clean"
+
+post-extract:
+.if defined(MCWM_CONF)
+ @${ECHO_MSG} "creating config.h from ${MCWM_CONF}"
+ @${CP} ${MCWM_CONF} ${WRKSRC}/config.h
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>