aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/obconf
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-09-24 09:06:01 +0800
committernovel <novel@FreeBSD.org>2011-09-24 09:06:01 +0800
commitaa4a99c8c7537ceb87c57295dfdd06addf00c006 (patch)
tree36cbe4747f99b3c67080ad7c96aed4bb6971f22d /x11-wm/obconf
parenta3846492a250130556d093828ed901eed5e8c061 (diff)
downloadfreebsd-ports-gnome-aa4a99c8c7537ceb87c57295dfdd06addf00c006.tar.gz
freebsd-ports-gnome-aa4a99c8c7537ceb87c57295dfdd06addf00c006.tar.zst
freebsd-ports-gnome-aa4a99c8c7537ceb87c57295dfdd06addf00c006.zip
Merge upstream fix for config path handling bug for obconf invoked with
--config-file argument. Reported by: Tom Abate Jr. <tom.abate@comcast.net> Obtained from: obconf git repository
Diffstat (limited to 'x11-wm/obconf')
-rw-r--r--x11-wm/obconf/Makefile2
-rw-r--r--x11-wm/obconf/files/patch-src-main.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/x11-wm/obconf/Makefile b/x11-wm/obconf/Makefile
index c5f41bcf29e9..e21836dc39db 100644
--- a/x11-wm/obconf/Makefile
+++ b/x11-wm/obconf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= obconf
PORTVERSION= 2.0.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-wm
MASTER_SITES= http://openbox.org/dist/obconf/
diff --git a/x11-wm/obconf/files/patch-src-main.c b/x11-wm/obconf/files/patch-src-main.c
new file mode 100644
index 000000000000..5c07a63f3f4b
--- /dev/null
+++ b/x11-wm/obconf/files/patch-src-main.c
@@ -0,0 +1,18 @@
+--- src/main.c.orig
++++ src/main.c
+@@ -233,11 +233,10 @@ int main(int argc, char **argv)
+ }
+
+ xmlIndentTreeOutput = 1;
+- if (!obt_xml_load_config_file(parse_i,
+- "openbox",
+- (obc_config_file ?
+- obc_config_file : "rc.xml"),
+- "openbox_config"))
++ if (!((obc_config_file &&
++ obt_xml_load_file(parse_i, obc_config_file, "openbox_config")) ||
++ obt_xml_load_config_file(parse_i, "openbox", "rc.xml",
++ "openbox_config")))
+ {
+ obconf_error(_("Failed to load an rc.xml. You have probably failed to install Openbox properly."), TRUE);
+ exit_with_error = TRUE;