aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/pawm
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /x11-wm/pawm
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'x11-wm/pawm')
-rw-r--r--x11-wm/pawm/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/x11-wm/pawm/Makefile b/x11-wm/pawm/Makefile
index ba754fffe29a..32f07893cb60 100644
--- a/x11-wm/pawm/Makefile
+++ b/x11-wm/pawm/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2 # only
LICENSE_FILE= ${WRKSRC}/GPL
USE_XORG= x11 xft xrandr xrender xpm
-USES= cmake pkgconfig ninja tar:bzip2
+USES= cmake pkgconfig tar:bzip2
CMAKE_ARGS= -DCMAKE_CONFIG_PREFIX:STRING="${PREFIX}/etc" \
-DX11_LIBRARY_DIRS:STRING="${LOCALBASE}/lib"
LDFLAGS+= -L${LOCALBASE}/lib -lXext -lXrender