aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/pekwm/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2002-11-04 01:05:52 +0800
committervanilla <vanilla@FreeBSD.org>2002-11-04 01:05:52 +0800
commit653bc1e0abe9c3c4ff8341181c24ead24946c9af (patch)
treed2c16c106afd56a4e550da0cecfdb6bb5354478f /x11-wm/pekwm/Makefile
parent379cf49a16497d25fa73a8a288416854140f5e0f (diff)
downloadfreebsd-ports-gnome-653bc1e0abe9c3c4ff8341181c24ead24946c9af.tar.gz
freebsd-ports-gnome-653bc1e0abe9c3c4ff8341181c24ead24946c9af.tar.zst
freebsd-ports-gnome-653bc1e0abe9c3c4ff8341181c24ead24946c9af.zip
Add pekwm, it's a windowmanager based on aewm++.
PR: ports/44815 Submitted by: Anders Andersson <anders@hack.org>
Diffstat (limited to 'x11-wm/pekwm/Makefile')
-rw-r--r--x11-wm/pekwm/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
new file mode 100644
index 000000000000..977a857fbce3
--- /dev/null
+++ b/x11-wm/pekwm/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pekwm
+# Date created: Nov 1, 2002
+# Whom: anders@hack.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pekwm
+PORTVERSION= 0.1.1
+CATEGORIES= x11-wm
+MASTER_SITES= http://pekwm.babblica.net/files/source/
+
+MAINTAINER= anders@hack.org
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+.if defined(WITH_XINERAMA)
+CONFIGURE_ARGS+= --enable-xinerama
+.endif
+
+.if !defined(WITH_XINERAMA)
+pre-everything:
+ @${ECHO_CMD} "To enable xinerama support define WITH_XINERAMA"
+.endif
+
+post-install:
+ @strip ${PREFIX}/bin/pekwm
+
+.include <bsd.port.mk>