aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/qlwm/files
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2001-08-28 06:37:52 +0800
committertrevor <trevor@FreeBSD.org>2001-08-28 06:37:52 +0800
commit1a677de7f5e7f13adff79c09251a862268ff6039 (patch)
tree7d7ffab88309807fc5b105188cb8f15cb48cde21 /x11-wm/qlwm/files
parenta7623336c5740f102383202c353c08878c686558 (diff)
downloadfreebsd-ports-gnome-1a677de7f5e7f13adff79c09251a862268ff6039.tar.gz
freebsd-ports-gnome-1a677de7f5e7f13adff79c09251a862268ff6039.tar.zst
freebsd-ports-gnome-1a677de7f5e7f13adff79c09251a862268ff6039.zip
Update to 2.6. Fix script.
Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'x11-wm/qlwm/files')
-rw-r--r--x11-wm/qlwm/files/patch-dclock_Makefile11
-rw-r--r--x11-wm/qlwm/files/patch-mail_Makefile11
-rw-r--r--x11-wm/qlwm/files/patch-src_Makefile20
-rw-r--r--x11-wm/qlwm/files/qlwm4
4 files changed, 3 insertions, 43 deletions
diff --git a/x11-wm/qlwm/files/patch-dclock_Makefile b/x11-wm/qlwm/files/patch-dclock_Makefile
deleted file mode 100644
index a9078c1c3087..000000000000
--- a/x11-wm/qlwm/files/patch-dclock_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- dclock/Makefile.orig Tue Oct 17 05:05:22 2000
-+++ dclock/Makefile Thu Jan 25 16:52:37 2001
-@@ -6,7 +6,7 @@
- #CXXFLAGS = -Wall -pipe
-
- # include files
--INCPATH = -I$(QTDIR)/include
-+INCPATH = -I$(QTDIR)/include -I${X11BASE}/include/qt2
-
- # libraries
- LFLAGS = -L$(QTDIR)/lib
diff --git a/x11-wm/qlwm/files/patch-mail_Makefile b/x11-wm/qlwm/files/patch-mail_Makefile
deleted file mode 100644
index bbabd1b7fd36..000000000000
--- a/x11-wm/qlwm/files/patch-mail_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- mail/Makefile.orig Tue Oct 17 05:05:20 2000
-+++ mail/Makefile Thu Jan 25 16:52:45 2001
-@@ -8,7 +8,7 @@
- #CXXFLAGS = -Wall -pipe
-
- # include files
--INCPATH = -I$(QTDIR)/include
-+INCPATH = -I${X11BASE}/include/qt2 -I${X11BASE}/include
-
- # libraries
- LFLAGS = -L$(QTDIR)/lib
diff --git a/x11-wm/qlwm/files/patch-src_Makefile b/x11-wm/qlwm/files/patch-src_Makefile
deleted file mode 100644
index 69e19afc14fe..000000000000
--- a/x11-wm/qlwm/files/patch-src_Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Makefile.orig Tue Oct 17 05:05:22 2000
-+++ src/Makefile Thu Jan 25 16:54:44 2001
-@@ -7,7 +7,7 @@
- #CXXFLAGS = -pipe -DDEBUGMSG
-
- # include files
--INCPATH = -I/usr/X11R6/include -I$(QTDIR)/include
-+INCPATH= -I${X11BASE}/include/qt2 -I${X11BASE}/include
-
- # libraries
- LFLAGS = -L/usr/X11R6/lib -L$(QTDIR)/lib
-@@ -30,7 +30,7 @@
- .SUFFIXES: .cpp
-
- .cpp.o:
-- $(CXX) -c $(CXXFLAGS) $(INCPATH) -o $@ $<
-+ $(CXX) $(CXXFLAGS) $(INCPATH) -o $@ -c $<
-
- ####### Build rules
-
diff --git a/x11-wm/qlwm/files/qlwm b/x11-wm/qlwm/files/qlwm
index d404fd766b4c..6a63dac6adf0 100644
--- a/x11-wm/qlwm/files/qlwm
+++ b/x11-wm/qlwm/files/qlwm
@@ -3,6 +3,8 @@ PREFIX=%PREFIX%
if ! test -e $HOME/.qlwm
then
mkdir -p $HOME/.qlwm
- cp ${PREFIX}/lib/qlwm/files/{defaults,appdefaults,menuconfig} $HOME/.qlwm
+ for i in defaults appdefaults menuconfig; \
+ do cp -v ${PREFIX}/lib/qlwm/files/$i $HOME/.qlwm; \
+ done
fi
exec ${PREFIX}/lib/qlwm/qlwm "$@"