aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/ratpoison
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-10-14 09:03:09 +0800
committerhq <hq@FreeBSD.org>2005-10-14 09:03:09 +0800
commitde3b668f7541a0867d173ab1f4923f4057ffa169 (patch)
treed87eb35916a1c848cc33736742441232085a6ac5 /x11-wm/ratpoison
parent8f91a2bbfd270eef2c41e7092905c36664a8d1be (diff)
downloadfreebsd-ports-gnome-de3b668f7541a0867d173ab1f4923f4057ffa169.tar.gz
freebsd-ports-gnome-de3b668f7541a0867d173ab1f4923f4057ffa169.tar.zst
freebsd-ports-gnome-de3b668f7541a0867d173ab1f4923f4057ffa169.zip
- Patch some shell scripts to have them use ${PREFIX}/bin/bash rather than
/bin/bash - Register shells/bash as a dependency - Bump PORTREVISION Reported by: James Bowman <jamesb@acelere.net>
Diffstat (limited to 'x11-wm/ratpoison')
-rw-r--r--x11-wm/ratpoison/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/x11-wm/ratpoison/Makefile b/x11-wm/ratpoison/Makefile
index 1322764450c5..b870c18e1203 100644
--- a/x11-wm/ratpoison/Makefile
+++ b/x11-wm/ratpoison/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ratpoison
PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,13 +15,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= hq@FreeBSD.org
COMMENT= Simple window manager with no fat library dependencies
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
OPTIONS= GDM_SUPPORT "Install session data files for GDM" off
.include <bsd.port.pre.mk>
+post-patch:
+.for file in rpws allwindows.sh
+ ${REINPLACE_CMD} '1s|!\(/bin/bash\)|!/usr/local\1|' ${WRKSRC}/contrib/${file}
+.endfor
+
.if defined (WITH_GDM_SUPPORT)
PLIST_SUB+= WITH_GDM=""
post-configure: