aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/skippy/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-05-20 14:15:43 +0800
committerkrion <krion@FreeBSD.org>2004-05-20 14:15:43 +0800
commit86a7801c1b69176140421b73564c5d42ebc899ca (patch)
tree689b63f67a7c91549b887d4ceddd88950d8cb461 /x11-wm/skippy/Makefile
parent621fff64e61a333673ae9f0cb6ac04a5cdc56063 (diff)
downloadfreebsd-ports-gnome-86a7801c1b69176140421b73564c5d42ebc899ca.tar.gz
freebsd-ports-gnome-86a7801c1b69176140421b73564c5d42ebc899ca.tar.zst
freebsd-ports-gnome-86a7801c1b69176140421b73564c5d42ebc899ca.zip
- Update to version 0.5.0
PR: ports/66920 Submitted by: maintainer
Diffstat (limited to 'x11-wm/skippy/Makefile')
-rw-r--r--x11-wm/skippy/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/x11-wm/skippy/Makefile b/x11-wm/skippy/Makefile
index 9d6fcfcdc5bf..20c41358f502 100644
--- a/x11-wm/skippy/Makefile
+++ b/x11-wm/skippy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= skippy
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= x11-wm
MASTER_SITES= http://thegraveyard.org/files/
@@ -20,14 +20,24 @@ USE_XLIB= yes
USE_BZIP2= yes
USE_GNOME= pkgconfig
USE_REINPLACE= yes
-PLIST_FILES= bin/skippy
+PLIST_FILES= bin/skippy \
+ %%DATADIR%%/skippyrc-default
+PLIST_DIRS= %%DATADIR%%
+PKGMESSAGE= ${WRKDIR}/pkg-message
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|; \
s|/usr/local|${LOCALBASE}|; s|gcc|${CC}|' \
${WRKSRC}/Makefile
+post-build:
+ @${SED} 's|%%DATADIR%%|${DATADIR}|' ${PKGDIR}/pkg-message >${PKGMESSAGE}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/skippy ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/skippyrc-default ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>