aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/tinywm/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-16 08:58:29 +0800
committerpav <pav@FreeBSD.org>2005-01-16 08:58:29 +0800
commit912bd73ac4155998a28e16bdad73ad1d6fba05d4 (patch)
tree68a8c6eb0360dae0471a134f061357bdccfe211d /x11-wm/tinywm/Makefile
parentd1f43931d0d2c0f3a112ac5a603218b413edf6d7 (diff)
downloadfreebsd-ports-gnome-912bd73ac4155998a28e16bdad73ad1d6fba05d4.tar.gz
freebsd-ports-gnome-912bd73ac4155998a28e16bdad73ad1d6fba05d4.tar.zst
freebsd-ports-gnome-912bd73ac4155998a28e16bdad73ad1d6fba05d4.zip
TinyWM is a ridiculously tiny window manager implemented in nearly as few
lines of C as possible, without being obfuscated or entirely useless. It allows you to move, resize, focus (sloppy), and raise windows. PR: ports/76077 Submitted by: Florent Thoumie <flz@xbsd.org>
Diffstat (limited to 'x11-wm/tinywm/Makefile')
-rw-r--r--x11-wm/tinywm/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/tinywm/Makefile b/x11-wm/tinywm/Makefile
new file mode 100644
index 000000000000..9349700f547d
--- /dev/null
+++ b/x11-wm/tinywm/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: tinywm
+# Date created: Jan 10 2005
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinywm
+PORTVERSION= 1.0
+CATEGORIES= x11-wm
+MASTER_SITES= http://incise.org/files/dev/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Ridiculously tiny window manager
+
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/tinywm
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CC)|CC) ${CFLAGS}|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tinywm ${PREFIX}/bin
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+
+.include <bsd.port.mk>