aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/windowmaker-i18n/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-07-17 11:50:17 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-07-17 11:50:17 +0800
commitda42424bfe4188b5368ab5c25a3e0a2900155271 (patch)
treec0d112afc36745f269f983e1c013d5050a279824 /x11-wm/windowmaker-i18n/Makefile
parentd030147a959f295af5d6c2734f8cad7cb335f581 (diff)
downloadfreebsd-ports-gnome-da42424bfe4188b5368ab5c25a3e0a2900155271.tar.gz
freebsd-ports-gnome-da42424bfe4188b5368ab5c25a3e0a2900155271.tar.zst
freebsd-ports-gnome-da42424bfe4188b5368ab5c25a3e0a2900155271.zip
Update to 0.60.0
PR: 12424 Submitted by: maintainer
Diffstat (limited to 'x11-wm/windowmaker-i18n/Makefile')
-rw-r--r--x11-wm/windowmaker-i18n/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/x11-wm/windowmaker-i18n/Makefile b/x11-wm/windowmaker-i18n/Makefile
index 21fbb9f2c97e..d019c4dd75f7 100644
--- a/x11-wm/windowmaker-i18n/Makefile
+++ b/x11-wm/windowmaker-i18n/Makefile
@@ -1,15 +1,15 @@
# New ports collection makefile for: WindowMaker with i18n extention
-# Version required: 0.53.0
+# Version required: 0.60.0
# Date created: 24 Nov 1998
# Whom: mac@jp.freebsd.org
#
-# $Id: Makefile,v 1.57 1999/05/01 02:43:22 steve Exp $
+# $Id: Makefile,v 1.58 1999/05/27 07:32:45 tg Exp $
+#
-DISTNAME= WindowMaker-0.53.0
-PKGNAME= windowmaker-i18n-0.53.0
+DISTNAME= WindowMaker-0.60.0
+PKGNAME= windowmaker-i18n-0.60.0
CATEGORIES= x11-wm windowmaker
-MASTER_SITES= ${MASTER_SITE_WINDOWMAKER} \
- ftp://muse.brain.riken.go.jp/pub/ja.po/
+MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= beta/srcs
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -28,20 +28,21 @@ RUN_DEPENDS= ${X11BASE}/share/WindowMaker/Themes/Checker.themed/style:${PORTSDIR
USE_BZIP2= yes
USE_PERL5= yes
USE_X_PREFIX= yes
+USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= X11BASE=${X11BASE} LOCALBASE=${LOCALBASE} \
CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib" \
LINGUAS="de es fi fr hr it ja_JP.EUC ko nl no pl pt ru"
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
- --with-nlsdir=${PREFIX}/share/locale \
- --disable-debug --enable-kanji --disable-shared
+ --with-nlsdir=${PREFIX}/share/locale --disable-debug
MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x \
- wdwrite.1x wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x
+ wdwrite.1x wmaker.1x wmsetbg.1x wxcopy.1x wxpaste.1x wsetfont.1x
-JA_CATALOGFILE= WindowMaker-0.53.0ja1
+JA_CATALOGFILE= WindowMaker-0.60.0ja2
-.if defined(JA_CATALOGFILE) && ${JA_CATALOGFILE} != ""
+.if defined(JA_CATALOGFILE) && !empty(JA_CATALOGFILE)
+MASTER_SITES+= ftp://muse.brain.riken.go.jp/pub/ja.po/
DISTFILES+= ${JA_CATALOGFILE}${EXTRACT_SUFX}
.endif