aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/wmakerconf/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-08-29 01:07:49 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-08-29 01:07:49 +0800
commit2cba66ec10260c810d591a027950106e147c8c32 (patch)
tree85a6580456bb6f739e7563feeccb16492a4c3e22 /x11-wm/wmakerconf/Makefile
parentd8b4a6a91a8f67c644fbe689f36813d3952bd952 (diff)
downloadfreebsd-ports-gnome-2cba66ec10260c810d591a027950106e147c8c32.tar.gz
freebsd-ports-gnome-2cba66ec10260c810d591a027950106e147c8c32.tar.zst
freebsd-ports-gnome-2cba66ec10260c810d591a027950106e147c8c32.zip
1. Support for bzip'ed themes (RUN_DEPENDS=bunzip2)
2. Configuration files upgrade via Inet (RUN_DEPENDS=wget,rpm) 3. PLIST fixed PR: 13426 Submitted by: Maxim Sobolev <sobomax@altavista.net>
Diffstat (limited to 'x11-wm/wmakerconf/Makefile')
-rw-r--r--x11-wm/wmakerconf/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index a2adb51be548..f38bdce67335 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -1,18 +1,22 @@
# New ports collection makefile for: wmakerconf
# Version required: 2.1
# Date Created: 14 August 1999
-# Whom: Dominik Rothert <dr@domix.de>
+# Whom: Dominik Rothert <dr@domix.de>
#
-# $Id$
+# $FreeBSD$
#
DISTNAME= wmakerconf-2.1
CATEGORIES= x11-wm
MASTER_SITES= http://www2.informatik.uni-wuerzburg.de/staff/ulli/wmakerconf/
-MAINTAINER= dr@domix.de
+MAINTAINER= dr@domix.de
+
+RUN_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker \
+ rpm:${PORTSDIR}/misc/rpm \
+ bunzip2:${PORTSDIR}/archivers/bzip2 \
+ wget:${PORTSDIR}/ftp/wget
-RUN_DEPENDS= wmaker:${PORTSDIR}/x11-wm/windowmaker
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.4:${PORTSDIR}/graphics/imlib \
PropList.1:${PORTSDIR}/devel/libPropList \
@@ -22,6 +26,9 @@ LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
png.3:${PORTSDIR}/graphics/png \
wraster.3:${PORTSDIR}/x11-wm/windowmaker
+BUILD_DEPENDS= bunzip2:${PORTSDIR}/archivers/bzip2 \
+ wget:${PORTSDIR}/ftp/wget
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config