aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce/Makefile
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /x11-wm/xfce/Makefile
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'x11-wm/xfce/Makefile')
-rw-r--r--x11-wm/xfce/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-wm/xfce/Makefile b/x11-wm/xfce/Makefile
index aa8b63f157d2..5fb415e0b003 100644
--- a/x11-wm/xfce/Makefile
+++ b/x11-wm/xfce/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
iconv.3:${PORTSDIR}/converters/libiconv \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GTK= yes
USE_XPM= yes
@@ -56,13 +57,13 @@ pre-everything::
.endif
pre-patch:
- @${PERL} -pi -e 's|=aclocal|=${TRUE}|g ; \
+ @${REINPLACE_CMD} -e 's|=aclocal|=${TRUE}|g ; \
s|=autoconf|=${TRUE}|g ; \
s|=automake|=${TRUE}|g ; \
s|=autoheader|=${TRUE}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${PERL} -pi -e 's|gtk-config|${GTK_CONFIG:T}|g' ${WRKSRC}/xfce/setup.c
- @${PERL} -pi -e 's|xfplay|internal|g' ${WRKSRC}/other/xfsoundrc.in
+ @${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG:T}|g' ${WRKSRC}/xfce/setup.c
+ @${REINPLACE_CMD} -e 's|xfplay|internal|g' ${WRKSRC}/other/xfsoundrc.in
post-install:
@${LN} -sf ${PREFIX}/share/xfce/help/html/images \