aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-desktop/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-31 00:49:12 +0800
committermiwi <miwi@FreeBSD.org>2012-05-31 00:49:12 +0800
commit21bddc2d1a2042f4ff865a4332c025b6cecd51a1 (patch)
tree7b85dd509c1a2721bcf825a6028fd3c680a3783b /x11-wm/xfce4-desktop/Makefile
parent063b50bb312d418ad41be26a35a64173a0c3b545 (diff)
downloadfreebsd-ports-gnome-21bddc2d1a2042f4ff865a4332c025b6cecd51a1.tar.gz
freebsd-ports-gnome-21bddc2d1a2042f4ff865a4332c025b6cecd51a1.tar.zst
freebsd-ports-gnome-21bddc2d1a2042f4ff865a4332c025b6cecd51a1.zip
- Convert complete XFCE to new options framework
While here some extra work: - Remove 6.X gruft - Correct NOPORTDOCS - Pet portlint - Whitespaces fixes Reviewed by: beat, bapt (thx!)
Diffstat (limited to 'x11-wm/xfce4-desktop/Makefile')
-rw-r--r--x11-wm/xfce4-desktop/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 83fea8624484..480769ff284d 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -30,21 +30,22 @@ USE_XFCE= configenv garcon libmenu libutil libexo xfconf
CONFIGURE_ARGS+=--enable-gio-unix \
--enable-notifications
-OPTIONS= THUNAR "Enable thunar support" on \
- NLS "Enable Native Language Support" on
+OPTIONS_DEFINE= THUNAR NLS
+OPTIONS_DEFAULT= THUNAR NLS
+THUNAR_DESC= Enable thunar support
MAN1= xfdesktop.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_THUNAR)
+.if ${PORT_OPTIONS:MTHUNAR}
CONFIGURE_ARGS+=--enable-thunarx --with-file-manager-fallback=Thunar
USE_XFCE+= thunar
.else
CONFIGURE_ARGS+=--disable-thunarx --without-file-manager-fallback
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -56,4 +57,4 @@ PLIST_SUB+= NLS="@comment "
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>