aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-wm/Makefile
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-03-06 06:52:30 +0800
committerolivierd <olivierd@FreeBSD.org>2015-03-06 06:52:30 +0800
commita8fcb605935f51f7c1487a6b10e2ccbbf792ede1 (patch)
tree0f1a4d58acfbb6944387e341f218a018154dc4ad /x11-wm/xfce4-wm/Makefile
parentf79c1de878eea01ceb02aa890c8f1735f64e7070 (diff)
downloadfreebsd-ports-gnome-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.tar.gz
freebsd-ports-gnome-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.tar.zst
freebsd-ports-gnome-a8fcb605935f51f7c1487a6b10e2ccbbf792ede1.zip
The FreeBSD Xfce team proudly presents Xfce 4.12.
Announce: http://www.xfce.org/about/news/?post=1425081600 Global changes: - Switch to USES= xfce (D677) - Reorganize options helper - Fix USES= gettext-* when NLS option is not set [1], [2] - Add LICENSE (when missing) Update: - to 4.12 (core components) - audio/xfce4-mpc-plugin to 0.4.5 - deskutils/xfce4-tumbler to 0.1.31 - deskutils/xfce4-xkb-plugin to 0.7.1 - editors/mousepad to 0.4.0 - graphics/ristretto to 0.8.0 - multimedia/xfce4-parole to 0.8.0 - sysutils/garcon to 0.4.0 - sysutils/xfce4-diskperf-plugin to 2.5.5 [3] - sysutils/xfce4-fsguard-plugin to 1.0.2 - sysutils/xfce4-power-manager to 1.4.3 - sysutils/xfce4-wavelan-plugin to 0.5.12 - x11/libexo to 0.10.3 - x11-fm/thunar to 1.6.6 - x11-themes/gtk-xfce-engine to 3.2.0 PR: 196003 [1], 197251 [2], 198132 Differential Revision: https://reviews.freebsd.org/D677 Submitted by: Kamil Szczesny [1], amdmi3@ [2], myself Exp-run by: antoine@ Approved by: danilo@ (maintainer) [3] Tested by: Ivan <enitarzi@gmail.com>
Diffstat (limited to 'x11-wm/xfce4-wm/Makefile')
-rw-r--r--x11-wm/xfce4-wm/Makefile60
1 files changed, 20 insertions, 40 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index 170e65c00d9e..6853e569258e 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -2,63 +2,43 @@
# $FreeBSD$
PORTNAME= xfce4-wm
-PORTVERSION= 4.10.1
-PORTREVISION= 1
+PORTVERSION= 4.12.0
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/xfce/xfwm4/${PORTVERSION:R}
DISTNAME= xfwm4-${PORTVERSION}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
COMMENT= Xfce's window manager
-LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libwnck-1.so:${PORTSDIR}/x11-toolkits/libwnck
+LICENSE= GPLv2
+
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS= --enable-xsync \
--enable-render \
--enable-randr \
+ --enable-compositor \
--disable-kde-systray
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= pathfix pkgconfig gmake tar:bzip2
-USE_GNOME= gtk20 intltool intlhack
+USES= pkgconfig gmake gettext-tools xfce tar:bzip2
+USE_GNOME= gtk20 intltool intlhack libwnck
USE_LDCONFIG= yes
-USE_XFCE= configenv libmenu libutil xfconf
-USE_XORG= x11 sm xext xrandr xrender
+USE_XFCE= libmenu
+USE_XORG= x11 sm xcomposite xdamage xext xfixes xrandr xrender
DATADIR= ${PREFIX}/share/xfwm4
-OPTIONS_DEFINE= COMPOSITE NLS NOTIFY REVMOUSE
-OPTIONS_DEFAULT= COMPOSITE NOTIFY
-REVMOUSE_DESC= Reverse mouse workspace changing direction
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCOMPOSITE}
-CONFIGURE_ARGS+=--enable-compositor
-.else
-CONFIGURE_ARGS+=--disable-compositor
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
-CONFIGURE_ARGS+=--enable-startup-notification
-.else
-CONFIGURE_ARGS+=--disable-startup-notification
-.endif
-
-.if ${PORT_OPTIONS:MREVMOUSE}
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-src__events.c
-.endif
+OPTIONS_DEFINE= DRM NLS STARTUP
+OPTIONS_DEFAULT= NLS STARTUP
+DRM_DESC= Direct Rendering Module service
+STARTUP_DESC= Startup notification
+DRM_LIB_DEPENDS= libdrm.so:${PORTSDIR}/graphics/libdrm
+DRM_CONFIGURE_ENABLE= libdrm
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+STARTUP_CONFIGURE_ENABLE= startup-notification
+OPTIONS_SUB= yes
.include <bsd.port.mk>