aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-wm/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-12 07:17:29 +0800
committerpetef <petef@FreeBSD.org>2003-05-12 07:17:29 +0800
commitc48258b3d51363c6b361c50851adbeff0c2e57a3 (patch)
tree2c2399c651f662a965651980d82a20f900dcf7ac /x11-wm/xfce4-wm/Makefile
parent67650acbf541e5768efdd6a2b21025e9c6198fa9 (diff)
downloadfreebsd-ports-gnome-c48258b3d51363c6b361c50851adbeff0c2e57a3.tar.gz
freebsd-ports-gnome-c48258b3d51363c6b361c50851adbeff0c2e57a3.tar.zst
freebsd-ports-gnome-c48258b3d51363c6b361c50851adbeff0c2e57a3.zip
Add xfwm4 020724, gtk-2.0 based window manager part of the XFCE
project. PR: 41678 Submitted by: James Earl <jamesearl@shaw.ca>
Diffstat (limited to 'x11-wm/xfce4-wm/Makefile')
-rw-r--r--x11-wm/xfce4-wm/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
new file mode 100644
index 000000000000..0a98d5bf2fa9
--- /dev/null
+++ b/x11-wm/xfce4-wm/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xfwm4
+# Date created: August 14, 2002
+# Whom: James Earl <jamesearl@shaw.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfwm4
+PORTVERSION= 020724
+CATEGORIES= x11-wm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://belnet.dl.sourceforge.net/sourceforge/xfce/ \
+ http://unc.dl.sourceforge.net/sourceforge/xfce/
+MASTER_SITE_SUBDIR= xfce
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gtk-2.0 based window manager part of the XFCE project
+
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/src/pixmap.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xfwm4 ${PREFIX}/share/examples/xfwm4
+ ${MKDIR} ${PREFIX}/share/examples/xfwm4
+
+ ${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/TODO ${PREFIX}/share/doc/xfwm4
+ ${INSTALL_MAN} ${WRKSRC}/example.xfwm4rc ${WRKSRC}/example.gtkrc-2.0 ${PREFIX}/share/examples/xfwm4
+
+ @${ECHO} "===> Configuration:" ;
+ @${ECHO} " - Example rc files installed in ${PREFIX}/share/examples/${PORTNAME}" ;
+ @${ECHO} " - Refer to documentation in ${PREFIX}/share/doc/${PORTNAME}" ;
+ @${ECHO} " - For online help see: http://xfce.sourceforge.net" ;
+.endif
+
+.include <bsd.port.mk>