aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-wm/Makefile
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2003-07-29 02:27:32 +0800
committeroliver <oliver@FreeBSD.org>2003-07-29 02:27:32 +0800
commite1ab570f941364ee23efb9f9683db771c3d9b8a2 (patch)
tree7eb4f3a4de18eab293e043f6af8a8e4eb5a097fb /x11-wm/xfce4-wm/Makefile
parent3ad8fa0bc792710a9ebada9a3644a3621b441130 (diff)
downloadfreebsd-ports-gnome-e1ab570f941364ee23efb9f9683db771c3d9b8a2.tar.gz
freebsd-ports-gnome-e1ab570f941364ee23efb9f9683db771c3d9b8a2.tar.zst
freebsd-ports-gnome-e1ab570f941364ee23efb9f9683db771c3d9b8a2.zip
Update xfce4-wm to 3.99.2
PR: 53168 Submitted by: James Earl <jdearl@telus.net>
Diffstat (limited to 'x11-wm/xfce4-wm/Makefile')
-rw-r--r--x11-wm/xfce4-wm/Makefile40
1 files changed, 14 insertions, 26 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index 0a98d5bf2fa9..325e2ec943b3 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -1,43 +1,31 @@
# New ports collection makefile for: xfwm4
# Date created: August 14, 2002
-# Whom: James Earl <jamesearl@shaw.ca>
+# Whom: James Earl <jdearl@telus.net>
#
# $FreeBSD$
#
-PORTNAME= xfwm4
-PORTVERSION= 020724
+PORTNAME= xfce4-wm
+PORTVERSION= 3.99.2
CATEGORIES= x11-wm
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://belnet.dl.sourceforge.net/sourceforge/xfce/ \
- http://unc.dl.sourceforge.net/sourceforge/xfce/
-MASTER_SITE_SUBDIR= xfce
+MASTER_SITES= http://www.xfce.org/archive/xfce4-rc2/src/ \
+ ftp://ftp.unix-ag.org/user/bmeurer/xfce4/rc2/separate/ \
+ http://usuarios.lycos.es/xfce4/tarballs/rc2/separate/ \
+ http://linux.imp.mx/xfce4/rc2/xfce4-rc2/src/
+DISTNAME= xfwm4-${PORTVERSION}
+DIST_SUBDIR= xfce4
MAINTAINER= ports@FreeBSD.org
-COMMENT= Gtk-2.0 based window manager part of the XFCE project
+COMMENT= XFce 4 window manager
+
+BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
+LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
USE_GNOME= gtk20
-USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-
-post-patch:
- @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/src/pixmap.c
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/xfwm4 ${PREFIX}/share/examples/xfwm4
- ${MKDIR} ${PREFIX}/share/examples/xfwm4
-
- ${INSTALL_MAN} ${WRKSRC}/README ${WRKSRC}/TODO ${PREFIX}/share/doc/xfwm4
- ${INSTALL_MAN} ${WRKSRC}/example.xfwm4rc ${WRKSRC}/example.gtkrc-2.0 ${PREFIX}/share/examples/xfwm4
-
- @${ECHO} "===> Configuration:" ;
- @${ECHO} " - Example rc files installed in ${PREFIX}/share/examples/${PORTNAME}" ;
- @${ECHO} " - Refer to documentation in ${PREFIX}/share/doc/${PORTNAME}" ;
- @${ECHO} " - For online help see: http://xfce.sourceforge.net" ;
-.endif
+CONFIGURE_ARGS= --enable-xinerama
.include <bsd.port.mk>