aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-wm
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2008-02-13 02:11:07 +0800
committeroliver <oliver@FreeBSD.org>2008-02-13 02:11:07 +0800
commit45e72c6194235ddb6310560df15adde7dff61639 (patch)
treeac64caded36de405e9e794a1d55d9e0a6c1b9663 /x11-wm/xfce4-wm
parent767ce3b15134a4730fa76edbf5d047893f10d7aa (diff)
downloadfreebsd-ports-gnome-45e72c6194235ddb6310560df15adde7dff61639.tar.gz
freebsd-ports-gnome-45e72c6194235ddb6310560df15adde7dff61639.tar.zst
freebsd-ports-gnome-45e72c6194235ddb6310560df15adde7dff61639.zip
update xfce4 to 4.4.2
Approved by: portmgr (linimon) Security: CVE-2007-6531, CVE-2007-6532
Diffstat (limited to 'x11-wm/xfce4-wm')
-rw-r--r--x11-wm/xfce4-wm/Makefile4
-rw-r--r--x11-wm/xfce4-wm/distinfo6
-rw-r--r--x11-wm/xfce4-wm/files/patch-client.c26
-rw-r--r--x11-wm/xfce4-wm/files/patch-display.c40
-rw-r--r--x11-wm/xfce4-wm/files/patch-display.h10
-rw-r--r--x11-wm/xfce4-wm/files/patch-hint.c61
-rw-r--r--x11-wm/xfce4-wm/files/patch-hint.h10
-rw-r--r--x11-wm/xfce4-wm/pkg-plist2
8 files changed, 7 insertions, 152 deletions
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index 73e4a7223b62..a4afb916d742 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xfce4-wm
-PORTVERSION= 4.4.1
-PORTREVISION= 2
+PORTVERSION= 4.4.2
+PORTREVISION= 0
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= xfwm4-${PORTVERSION}
diff --git a/x11-wm/xfce4-wm/distinfo b/x11-wm/xfce4-wm/distinfo
index 20f57eb8d5ff..9b9c1711ecb0 100644
--- a/x11-wm/xfce4-wm/distinfo
+++ b/x11-wm/xfce4-wm/distinfo
@@ -1,3 +1,3 @@
-MD5 (xfce4/xfwm4-4.4.1.tar.bz2) = c531edad76c909001acccc02936404f2
-SHA256 (xfce4/xfwm4-4.4.1.tar.bz2) = 4c7def1dfe4fe723dfd2728187d70b96682896649461507d230906aafffc0475
-SIZE (xfce4/xfwm4-4.4.1.tar.bz2) = 1645973
+MD5 (xfce4/xfwm4-4.4.2.tar.bz2) = 21da77e50b07e72bba784bf3418ca067
+SHA256 (xfce4/xfwm4-4.4.2.tar.bz2) = 710120122bc4acaaecdb0646656c5aa92f1d44c4c81d1a6775688abab04cca0a
+SIZE (xfce4/xfwm4-4.4.2.tar.bz2) = 1548533
diff --git a/x11-wm/xfce4-wm/files/patch-client.c b/x11-wm/xfce4-wm/files/patch-client.c
deleted file mode 100644
index 337570fccaf1..000000000000
--- a/x11-wm/xfce4-wm/files/patch-client.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/client.c.orig 2007-04-02 21:48:20.000000000 +0200
-+++ src/client.c 2007-10-25 22:26:36.000000000 +0200
-@@ -4868,21 +4868,19 @@
-
- if (passdata.c)
- {
-- GdkPixbuf *icon;
--
- TRACE ("entering cycle loop");
- passdata.wireframe = wireframeCreate (passdata.c);
-- icon = getAppIcon (display_info, passdata.c->window, 32, 32);
- passdata.tabwin = tabwinCreate (passdata.c->screen_info->gscr, c,
- passdata.c, passdata.cycle_range,
- screen_info->params->cycle_workspaces);
- eventFilterPush (display_info->xfilter, clientCycleEventFilter, &passdata);
- gtk_main ();
- eventFilterPop (display_info->xfilter);
-- wireframeDelete (screen_info, passdata.wireframe);
- TRACE ("leaving cycle loop");
- tabwinDestroy (passdata.tabwin);
- g_free (passdata.tabwin);
-+ wireframeDelete (screen_info, passdata.wireframe);
-+ updateXserverTime (display_info);
- }
-
- if (passdata.c)
diff --git a/x11-wm/xfce4-wm/files/patch-display.c b/x11-wm/xfce4-wm/files/patch-display.c
deleted file mode 100644
index ccb01816167a..000000000000
--- a/x11-wm/xfce4-wm/files/patch-display.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/display.c.orig 2007-04-02 21:32:01.000000000 +0200
-+++ src/display.c 2007-10-25 22:26:36.000000000 +0200
-@@ -178,6 +178,19 @@
- FALSE, display_info->atoms) != 0);
- }
-
-+static void
-+myDisplayCreateTimestampWin (DisplayInfo *display_info)
-+{
-+ XSetWindowAttributes attributes;
-+
-+ attributes.event_mask = PropertyChangeMask;
-+ attributes.override_redirect = TRUE;
-+ display_info->timestamp_win =
-+ XCreateWindow (display_info->dpy, DefaultRootWindow (display_info->dpy),
-+ -100, -100, 10, 10, 0, 0, CopyFromParent, CopyFromParent,
-+ CWEventMask | CWOverrideRedirect, &attributes);
-+}
-+
- DisplayInfo *
- myDisplayInit (GdkDisplay *gdisplay)
- {
-@@ -309,6 +322,8 @@
- display->resize_cursor[CORNER_COUNT + SIDE_BOTTOM] =
- XCreateFontCursor (display->dpy, XC_bottom_side);
-
-+ myDisplayCreateTimestampWin (display);
-+
- display->xfilter = NULL;
- display->screens = NULL;
- display->clients = NULL;
-@@ -340,6 +355,8 @@
- display->move_cursor = None;
- XFreeCursor (display->dpy, display->root_cursor);
- display->root_cursor = None;
-+ XDestroyWindow (display->dpy, display->timestamp_win);
-+ display->timestamp_win = None;
-
- if (display->hostname)
- {
diff --git a/x11-wm/xfce4-wm/files/patch-display.h b/x11-wm/xfce4-wm/files/patch-display.h
deleted file mode 100644
index a893a3069628..000000000000
--- a/x11-wm/xfce4-wm/files/patch-display.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/display.h.orig 2007-04-02 21:32:01.000000000 +0200
-+++ src/display.h 2007-10-25 22:26:36.000000000 +0200
-@@ -226,6 +226,7 @@
- gboolean quit;
- gboolean reload;
-
-+ Window timestamp_win;
- Cursor busy_cursor;
- Cursor move_cursor;
- Cursor root_cursor;
diff --git a/x11-wm/xfce4-wm/files/patch-hint.c b/x11-wm/xfce4-wm/files/patch-hint.c
deleted file mode 100644
index fbdc0ada8324..000000000000
--- a/x11-wm/xfce4-wm/files/patch-hint.c
+++ /dev/null
@@ -1,61 +0,0 @@
---- src/hints.c.orig 2007-03-11 14:44:43.000000000 +0100
-+++ src/hints.c 2007-10-25 22:26:36.000000000 +0200
-@@ -1167,27 +1167,18 @@
- return setXAtomManagerOwner(display_info, display_info->atoms[atom_id], root, w);
- }
-
--
--static Bool
--checkPropEvent (Display *display, XEvent *xevent, XPointer arg)
-+void
-+updateXserverTime (DisplayInfo *display_info)
- {
-- DisplayInfo *display_info;
- ScreenInfo *screen_info;
-+ char c = '\0';
-
-- display_info = (DisplayInfo *) arg;
-- g_return_val_if_fail (display_info, FALSE);
--
-- screen_info = myDisplayGetDefaultScreen (display_info);
-- g_return_val_if_fail (screen_info, FALSE);
-+ g_return_if_fail (display_info);
-
-- if ((xevent->type == PropertyNotify) &&
-- (xevent->xproperty.window == screen_info->xfwm4_win) &&
-- (xevent->xproperty.atom == display_info->atoms[XFWM4_TIMESTAMP_PROP]))
-- {
-- return TRUE;
-- }
--
-- return FALSE;
-+ XChangeProperty (display_info->dpy, display_info->timestamp_win,
-+ display_info->atoms[XFWM4_TIMESTAMP_PROP],
-+ display_info->atoms[XFWM4_TIMESTAMP_PROP],
-+ 8, PropModeReplace, (unsigned char *) &c, 1);
- }
-
- Time
-@@ -1196,7 +1187,6 @@
- ScreenInfo *screen_info;
- XEvent xevent;
- Time timestamp;
-- char c = '\0';
-
- g_return_val_if_fail (display_info, (Time) CurrentTime);
- timestamp = myDisplayGetCurrentTime (display_info);
-@@ -1206,12 +1196,8 @@
- g_return_val_if_fail (screen_info, (Time) CurrentTime);
-
- TRACE ("getXServerTime: Using X server roundtrip");
-- XChangeProperty (display_info->dpy, screen_info->xfwm4_win,
-- display_info->atoms[XFWM4_TIMESTAMP_PROP],
-- display_info->atoms[XFWM4_TIMESTAMP_PROP],
-- 8, PropModeReplace, (unsigned char *) &c, 1);
-- XIfEvent (display_info->dpy, &xevent, checkPropEvent, (XPointer) display_info);
--
-+ updateXserverTime (display_info);
-+ XWindowEvent (display_info->dpy, display_info->timestamp_win, PropertyChangeMask, &xevent);
- timestamp = (Time) myDisplayUpdateCurrentTime (display_info, &xevent);
- }
-
diff --git a/x11-wm/xfce4-wm/files/patch-hint.h b/x11-wm/xfce4-wm/files/patch-hint.h
deleted file mode 100644
index fd7931597545..000000000000
--- a/x11-wm/xfce4-wm/files/patch-hint.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/hints.h.orig 2007-03-11 14:44:43.000000000 +0100
-+++ src/hints.h 2007-10-25 22:26:36.000000000 +0200
-@@ -269,6 +269,7 @@
- int,
- Window ,
- Window);
-+void updateXserverTime (DisplayInfo *);
- Time getXServerTime (DisplayInfo *);
-
- #ifdef ENABLE_KDE_SYSTRAY_PROXY
diff --git a/x11-wm/xfce4-wm/pkg-plist b/x11-wm/xfce4-wm/pkg-plist
index d53111852df4..b7b06345a9db 100644
--- a/x11-wm/xfce4-wm/pkg-plist
+++ b/x11-wm/xfce4-wm/pkg-plist
@@ -17,6 +17,7 @@ share/icons/hicolor/48x48/apps/xfwm4.png
share/icons/hicolor/scalable/apps/wmtweaks.svg
share/icons/hicolor/scalable/apps/xfce4-workspaces.svg
share/icons/hicolor/scalable/apps/xfwm4.svg
+share/locale/am/LC_MESSAGES/xfwm4.mo
share/locale/ar/LC_MESSAGES/xfwm4.mo
share/locale/az/LC_MESSAGES/xfwm4.mo
share/locale/be/LC_MESSAGES/xfwm4.mo
@@ -46,6 +47,7 @@ share/locale/ja/LC_MESSAGES/xfwm4.mo
share/locale/ka/LC_MESSAGES/xfwm4.mo
share/locale/ko/LC_MESSAGES/xfwm4.mo
share/locale/lt/LC_MESSAGES/xfwm4.mo
+share/locale/lv/LC_MESSAGES/xfwm4.mo
share/locale/mk/LC_MESSAGES/xfwm4.mo
share/locale/mr/LC_MESSAGES/xfwm4.mo
share/locale/ms/LC_MESSAGES/xfwm4.mo